Q8 Parasitic drain

8 posts / 0 new
Last post
jigsaw
Offline
Last seen: 1 hour 9 min ago
Joined: 01/15/2016 - 17:35
Posts: 186
Location: Michigan, USA
Q8 Parasitic drain

Has anyone experienced parasitic drain with a Q8? I bought 3 of them almost a year ago. One of them was for a friend and his has bad parasitic drain.The other two work perfectly. It will completely drain a set of four cells in about two days if left alone. I have not done any major testing yet. I have disabled the led in the side switch and there doesn’t seem to be any light coming from the emitters when turned off. Any ideas of where to start testing?

BlueSwordM
BlueSwordM's picture
Online
Last seen: 4 min 29 sec ago
Joined: 11/29/2017 - 12:34
Posts: 1689
Location: Canada

A small short somewhere could cause a current drain, which would drain the cells in less than 2 days.

Otherwise, I do not know anyone who experienced this.

Until the problem is resolved, mechanically lock out the light to get rid of the problem.

ImA4Wheelr
Offline
Last seen: 16 min 22 sec ago
Joined: 02/03/2013 - 14:51
Posts: 7766
Location: SC

Maybe check to make sure all 4 of his cells are healthy and not self discharging.  Check the driver to make sure there are no solder bridges and that there are no components on R1 and R2.  There should be some good pictures of the driver around here somewhere to compare against.

jigsaw
Offline
Last seen: 1 hour 9 min ago
Joined: 01/15/2016 - 17:35
Posts: 186
Location: Michigan, USA

Thanks guys. The first thing we did was check the cells. They were a brand new set of 30Q. Had the same problem with a different set of known good cells. I’ll open it up and look at the driver. Yes, he has been mechanically locking it out since we discovered there was an issue. I need to look for some pics of the driver, or I suppose I could compare it to myQ8 .

Calaveras
Offline
Last seen: 1 hour 46 min ago
Joined: 12/08/2017 - 19:25
Posts: 85
Location: California Gold Country

I keep the green lighted switch on at all times and never noticed any drain after a month

Calaveras
Offline
Last seen: 1 hour 46 min ago
Joined: 12/08/2017 - 19:25
Posts: 85
Location: California Gold Country

No drain after two months in mine and I leave the switch on 24/7.

Mikeadoo
Offline
Last seen: 11 hours 24 min ago
Joined: 02/12/2017 - 22:27
Posts: 344
Location: Chesterfield, Michigan

3 months no drain on mine either. 30Q. Switch also on 24/7 like Calaveras ^^

I like flashlights!!

jigsaw
Offline
Last seen: 1 hour 9 min ago
Joined: 01/15/2016 - 17:35
Posts: 186
Location: Michigan, USA

Well its pretty obvious that the problem in not in the switch. Hopefully something obvious on the driver.