Astrolux S3 flashes off quickly

4 posts / 0 new
Last post
pellidon
Offline
Last seen: 3 hours 29 min ago
Joined: 07/31/2014 - 05:41
Posts: 8
Location: Indianapolis Indiana
Astrolux S3 flashes off quickly

I turn it on and it flashes brightly then goes off in less than 1/2 second. I can’t get it back on unless I loosen the tailcap and tighten it back down. Also when I tried using a plain wire (no switch) the same thing happens. It won’t seem to stay on. It worked fine with the current battery till it went dead.

This is the first time I have recharged the battery in it. It is an Olight 14500 battery. I charged it after it finally went dead. The battery
works in another light so I don’t think this is the issue.

I’ve been looking at the pages for the modes and have not yet found anything. I will keep looking.

Rusty
Offline
Last seen: 4 hours 38 min ago
Joined: 04/11/2011 - 16:38
Posts: 32
Location: UK

Is the battery protected? Sounds like the torch could be exceeding the current limit, assuming the battery is protected; your other torch may have a lower current draw, thus the battery operates without issue in this one.

pellidon
Offline
Last seen: 3 hours 29 min ago
Joined: 07/31/2014 - 05:41
Posts: 8
Location: Indianapolis Indiana

It’s an Olight High Drain battery that I have used in the light since I bought it. This just started after the battery died due to the drain the switch LED creates. It took months to drain.

Rusty
Offline
Last seen: 4 hours 38 min ago
Joined: 04/11/2011 - 16:38
Posts: 32
Location: UK

Have you another battery you can try in the torch and/or have you a meter to ensure the battery charged correctly in the torch, I it’s the first time you’ve used the charge functionality?

If not charged, the volt sag could be tripping the LVP at full power, but may have just enough juice for your other torch if it’s lower draw?