Nitecore - Common Failure Mode?

3 posts / 0 new
Last post
funkychateau
funkychateau's picture
Offline
Last seen: 2 months 3 weeks ago
Joined: 07/01/2018 - 02:05
Posts: 107
Location: Dallas, Texas
Nitecore - Common Failure Mode?

I’ve been using my Nitecore D2 as my “go-to” charger for 3 or 4 years. It has performed flawlessly when charging a variety of 14500 and 18650 li-ion cells, as well as AA Ni-mh cells.

Earlier this week I plugged it in, and instead of the normal display, I only see the greenish backlight illumination – no data or symbols at all – a blank screen.

The only hint I’ve had of anything out of the ordinary is that I recently noticed that I had to plug the charger in and let it initialize before inserting any batteries. Previously, I believe I could put the batteries in before plugging in the charger, and it would still power up OK. Not sure if this is related to my current issue with the display.

Has anyone else experienced a similar failure of this model? Is it common?

HorizontalHunter
HorizontalHunter's picture
Offline
Last seen: 4 weeks 1 day ago
Joined: 04/04/2016 - 22:15
Posts: 579
Location: Western Mass

My D4 is the same age and has always worked fine. Is it possible you got a counterfeit charger?

Bob

Vegetarian: vejiˈte(ə)rēən/noun: old Indian word for lousy hunter.

funkychateau
funkychateau's picture
Offline
Last seen: 2 months 3 weeks ago
Joined: 07/01/2018 - 02:05
Posts: 107
Location: Dallas, Texas

I doubt it. I bought it from a reputable dealer, Illumn.com.