Nanjg 105c always on

4 posts / 0 new
Last post
YuvalS
YuvalS's picture
Offline
Last seen: 3 hours 14 min ago
Joined: 09/26/2018 - 10:39
Posts: 474
Nanjg 105c always on

Hi all,
I am building an Headlamp and having an issue with the Nanjg 105c driver.
After flashing the FW and connecting the battery the LED is always on even for very simple  OCR0B = 0; OCR0A = 0;  FW.

The same FW and driver worked great before but I did some soldering and may destroy something.

Any idea what could go wrong?

Thanks
Yuval

My FW repository

My BLF/OL contest entries: 7th 8th 9th 

YuvalS
YuvalS's picture
Offline
Last seen: 3 hours 14 min ago
Joined: 09/26/2018 - 10:39
Posts: 474

My guess is that one 7135 is malfunction and always on.
1. Is it possible?
2. Is there a simple way to check all 7135s on board without soldering it out 1 by 1  

My FW repository

My BLF/OL contest entries: 7th 8th 9th 

Henk4U2
Henk4U2's picture
Offline
Last seen: 2 hours 32 min ago
Joined: 02/13/2014 - 17:52
Posts: 4128
Location: The heart of the Netherlands (GMT+1)

Hi Yuval, maybe I am mis-understanding you completely. If so, I apologize.
But there is no switch on the driver board. That is in the tail, or elsewhere in the light.

If you connect the battery, some current will flow. Question is: how much.
Is the light always 100% on? Can you regulate the current by clicking?

You are a flashaholic if you are forced to come out of the closet, to make room for more flashlights.

YuvalS
YuvalS's picture
Offline
Last seen: 3 hours 14 min ago
Joined: 09/26/2018 - 10:39
Posts: 474

Henk4U2 wrote:
Hi Yuval, maybe I am mis-understanding you completely. If so, I apologize. But there is no switch on the driver board. That is in the tail, or elsewhere in the light. If you connect the battery, some current will flow. Question is: how much. Is the light always 100% on? Can you regulate the current by clicking?


I am connecting momentary switch to pin 2 on pull down mode but it has no affect.

I try to flash a very simple blink FW and also always off FW but no mater what, the LED is always on when I connect a battery.
I don't know if it is 100% or less   

My FW repository

My BLF/OL contest entries: 7th 8th 9th