Opus BT-C3100 not working out of the box

22 posts / 0 new
Last post
YuvalS
YuvalS's picture
Offline
Last seen: 7 hours 50 min ago
Joined: 09/26/2018 - 10:39
Posts: 514
Opus BT-C3100 not working out of the box

My friend have just bought a new BT-C3100 charger.
When connecting it to the socket, the screen lit up but nothing happen when inserting a cell. 

Any advice on how to solve this?

My FW repository

My BLF/OL contest entries: 7th 8th 9th 

sp5it
sp5it's picture
Online
Last seen: 13 min 25 sec ago
Joined: 12/25/2012 - 07:51
Posts: 1455
Location: Poland

Fill complaint and send back to seller to get working one. As simple as that.
Mike

Think of how stupid the average person is, and realize half of them are stupider than that. George Carlin

 Anyone offended by my signature please fill Complaint Form. Thank you.

 If a lot of people listen to Slayer, the world would be a better place to live" - Tommy Wiseau

YuvalS
YuvalS's picture
Offline
Last seen: 7 hours 50 min ago
Joined: 09/26/2018 - 10:39
Posts: 514

sp5it wrote:
Fill complaint and send back to seller to get working one. As simple as that. Mike

Unfortunately, when finding out it is not working, he just put it aside and wait so now it is over a year and no longer under a warranty 

My FW repository

My BLF/OL contest entries: 7th 8th 9th 

raccoon city
raccoon city's picture
Offline
Last seen: 3 hours 21 min ago
Joined: 10/06/2010 - 02:35
Posts: 17319
Location: रॅकून सिटी Palm Desert CA USA

If you don't want to return it, that's fine, but "just bought" and "over a year" ago don't jive together.  ;)

ChrisGarrett
ChrisGarrett's picture
Offline
Last seen: 4 hours 29 min ago
Joined: 02/12/2014 - 22:03
Posts: 1031
Location: Miami, Florida

You have to press buttons to get it to start charging.

Chris

tatasal
Offline
Last seen: 21 hours 48 min ago
Joined: 02/15/2012 - 08:40
Posts: 5657
Location: Far East

After inserting the psu, the display light will light up, NULL will show on the empty bays and will turn off when nothing is inserted while still showing the same status on a darkened screen.

Inserting an 18650 (as an example) will turn on the display light again, and if no button is pressed within a few seconds, it will still commence Charging mode at the default of 500ma.

Btw, the screen’s display should stay in a darkened state while showing “NULL” in all four, presumably empty slots. If it does still stay fully-darkened even a when a healthy cell is inserted, perhaps then there is something wrong with it.

patmurris
patmurris's picture
Offline
Last seen: 2 weeks 5 days ago
Joined: 12/22/2014 - 15:54
Posts: 1715
Location: Nice, France

Are you sure the cell is fine?
For instance a protected cell may sort of lockout itself and will show as NULL when inserted in the charger.
Did you try various cells and specifically unprotected?

CNCman
CNCman's picture
Offline
Last seen: 9 hours 3 min ago
Joined: 04/07/2018 - 10:10
Posts: 1231
Location: Mississippi Gulf Coast

Read the comments below the video, maybe this will help. Good luck !
https://www.youtube.com/watch?v=-tbaso1HkCM
.

YuvalS
YuvalS's picture
Offline
Last seen: 7 hours 50 min ago
Joined: 09/26/2018 - 10:39
Posts: 514

Thanks all for your replies, apparently I failed to described the problem.
Here is a short video showing side by side my working charger (on the right) and my friend's (on the left)
Hope it will explain the issue  

My FW repository

My BLF/OL contest entries: 7th 8th 9th 

ChrisGarrett
ChrisGarrett's picture
Offline
Last seen: 4 hours 29 min ago
Joined: 02/12/2014 - 22:03
Posts: 1031
Location: Miami, Florida

“He’s dead, Jim.”

Chris

tatasal
Offline
Last seen: 21 hours 48 min ago
Joined: 02/15/2012 - 08:40
Posts: 5657
Location: Far East

Yeah, dead as in ded Sad

NeutralFan
NeutralFan's picture
Offline
Last seen: 3 days 4 hours ago
Joined: 03/20/2014 - 19:22
Posts: 1597
Location: Wisconsin, USA

The video certainly shows there’s an issue with the charger. Curious to know where your friend bought the Opus from?

I’d rather use my flashlight around the house than turn on the lights.

FlashKat
Offline
Last seen: 1 week 3 days ago
Joined: 11/27/2014 - 20:54
Posts: 194
Location: Anaheim, CA

Throw it in the trash.
I had one that malfunctioned and charged my battery to over 5 volts.
Not worth keeping.
I prefer XTAR chargers.

chops728
Offline
Last seen: 5 hours 7 min ago
Joined: 08/30/2014 - 16:00
Posts: 1528
Location: Swampland,La

The last 3 BT 3100 I bought had to update the fans in order to get a nonstop Discharge Cycle — They would overheat and pause several times for a 3000 mah cell

YuvalS
YuvalS's picture
Offline
Last seen: 7 hours 50 min ago
Joined: 09/26/2018 - 10:39
Posts: 514

It turns out that resurrection is not a myth.

A little adhesive tape to put pressure on the screen brought the charger back to life.



My FW repository

My BLF/OL contest entries: 7th 8th 9th 

tatasal
Offline
Last seen: 21 hours 48 min ago
Joined: 02/15/2012 - 08:40
Posts: 5657
Location: Far East
Thumbs Up Beer
ChrisGarrett
ChrisGarrett's picture
Offline
Last seen: 4 hours 29 min ago
Joined: 02/12/2014 - 22:03
Posts: 1031
Location: Miami, Florida

I had a Kyocera stick phone that would do that with its little postage stamp sized screen and I had all sorts of tissue padding taped to the back.

Congrats on figuring things out!

Chris

CNCman
CNCman's picture
Offline
Last seen: 9 hours 3 min ago
Joined: 04/07/2018 - 10:10
Posts: 1231
Location: Mississippi Gulf Coast

Great save YuvalS !! Thumbs Up
Cannot beat a cheap fix ! Big Smile

tatasal
Offline
Last seen: 21 hours 48 min ago
Joined: 02/15/2012 - 08:40
Posts: 5657
Location: Far East

My old crt TV used to do all sorts of vertical or horizontal picture hold problems and a slight tap on the ride side of the housing would bring it back to normal…though eventually even a mallet can’t bring it back to life.

NeutralFan
NeutralFan's picture
Offline
Last seen: 3 days 4 hours ago
Joined: 03/20/2014 - 19:22
Posts: 1597
Location: Wisconsin, USA

Glad you were able to fix it YuvalS! Still strange that it didn’t work in the first place.

I’d rather use my flashlight around the house than turn on the lights.

YuvalS
YuvalS's picture
Offline
Last seen: 7 hours 50 min ago
Joined: 09/26/2018 - 10:39
Posts: 514

NeutralFan wrote:
Glad you were able to fix it YuvalS! Still strange that it didn't work in the first place.

 

Not so strange.. It is poorly engineered.

This is the 2nd Opus charger I had to fix out of the box.

 

The first one had a defective power socket.

 

In addition my other Opus malfunctioned and almost got my house on fire.

 

Opus chargers are very low quality and I don't recommend anyone to buy it

My FW repository

My BLF/OL contest entries: 7th 8th 9th 

NeutralFan
NeutralFan's picture
Offline
Last seen: 3 days 4 hours ago
Joined: 03/20/2014 - 19:22
Posts: 1597
Location: Wisconsin, USA

My Opus BT-C3100 (version 2.0) that I’ve had since 2014 has been working flawlessly. Never had a problem with it, including the fan which is nice and quiet.

Maybe the quality has gotten bad, but it appears I got lucky with mine since so many people have had issues with them.

If mine ever goes bad, I will probably buy another one unless there’s another analyzing charger with the same features at a similar price.

I’d rather use my flashlight around the house than turn on the lights.