HD2010 stuck on high w/26650

14 posts / 0 new
Last post
RAW74
RAW74's picture
Offline
Last seen: 2 months 1 week ago
Joined: 07/23/2012 - 16:01
Posts: 816
Location: east coast USA
HD2010 stuck on high w/26650
Hello, I have been lurking here for a few months and finally decided to join. I have a HD2010 that works perfectly with Tenergy 18650s, but when I install one of my Trustfire 26650 it will not change modes off of high until the cell voltage is down to 3.8v or so. I thought at first it might be pressure on the driver from the longer cell, but that dosen’t appear to be the case…I can unscrew the tailcap almost all the way and the problem still presists. The only thing I can see that would be differant between the cells is that the voltage sag under load would be much less with the 26650 until it gets low, but I’m not sure how that could affect the driver? Does anyone have any ideas?
scaru
scaru's picture
Offline
Last seen: 4 years 10 months ago
Joined: 03/22/2012 - 13:36
Posts: 6946
Location: Virginia

Have you tried removing the tailcap and completing the circuit with a metal object of some kind? 

Ubehebe
Offline
Last seen: 6 years 12 months ago
Joined: 06/28/2012 - 01:14
Posts: 882
Location: Death Valley, Calif.

Welcome aboard! BLF is more fun than Club Med.

I had a similar problem where my hd2010 would NOT go to high. Problem was battery dependant. I found the ++ONLY++ batts I could use reliably were (solid green) Moli unprotected 26650, REAL TFF 18650 (fake TFFs would NOT work), Xtar, and ANY unprotected 18650 I could throw at it: Sanyo, Panny, Sony, Samsung, etc. It also would NOT work with various ultra(crap)fires: the golds and the red on whites. Would blink on high and shut down. I would suspect it sucks too much juice triggering the battery shutoff.

Surprisingly, it worked with the worst battery ever, the much-maligned ultrafire red 3000 mah, but I would NOT recommend using those becuase there are so many fakes out there.

I have more 26650s on the way but they haven’t arrived yet. Moli green 26650 from flea bay worked the best, but YMMV.

It may be something else besides the batteries; I let others chime in on that issue.

And — oh yeah — some of these batts DID work if the voltage got low enough, just as you said!

RAW74
RAW74's picture
Offline
Last seen: 2 months 1 week ago
Joined: 07/23/2012 - 16:01
Posts: 816
Location: east coast USA
Hey scaru, I just tried using one of my DVOM leads in place of the tailcap to complete the circuit. It still won’t change modes with a charged 26650. But get this, it won’t with an 18650 either?!I replaced the tailcap and it switches modes normally with just the 18650. So now I have to wonder…how does the driver know when to switch modes if not by breaking the circuit? All of my other lights switch modes when I interupt power doing tailcap current measurments, except this one?
RAW74
RAW74's picture
Offline
Last seen: 2 months 1 week ago
Joined: 07/23/2012 - 16:01
Posts: 816
Location: east coast USA
Ok…I tried a cheap paylight 3k 18650 and it works the same as the Tenergy cell. I also checked the tailcap resistance thinking that there may be a resister in there that allows a little current to the driver in off so that it can sense mode changes. No dice on that idea…has normal open and closed resistance. I guess I should order another brand of 26650’s to try in this light, but then I will have two lonely trustfire cells with no home. I supposed the only morally correct thing to do would be to get another 26650 light for them to power?
joerch
Offline
Last seen: 2 months 4 days ago
Joined: 07/15/2011 - 10:17
Posts: 200
Location: Germany

Just do the driver swap to a 7135 based one, you will find instructions in the forum, this is also a way (if you want ) to get rid of the blinky modes.
I modded my 2010 to the shiningbeam 2,8A 3-mode driver and I love this way.
Just use the the search function.

RAW74
RAW74's picture
Offline
Last seen: 2 months 1 week ago
Joined: 07/23/2012 - 16:01
Posts: 816
Location: east coast USA
I was looking at driver swaps that others have done here but all of them had problems with the retaining ring/space. If the driver from SB fits normally then I might try that…..but I would miss the SOOS mode so much!
joerch
Offline
Last seen: 2 months 4 days ago
Joined: 07/15/2011 - 10:17
Posts: 200
Location: Germany

When doing the driver swap you will have to press a brass or copper ring into the pill where the new driver will sit in and you can solder it to, you can insatll it the way the original driver is. You can use a part of a P60 pill, a Dremel might be handy.

kramer5150
kramer5150's picture
Offline
Last seen: 3 months 4 days ago
Joined: 05/19/2010 - 13:43
Posts: 2331
Location: Palo Alto CA

Funny you post this… I just finished building a P60 drop-in using the EAST-92 (HD2010) driver and a 4-P wired MCE. Electrically its 4x XRE-Q4 dies wired in parallel, driven by the east-92. I finished it all up and it works like a charm. Tailcap current measurement pulls a healthy 3.8A from a CGR18650E. Mode cycling works fine, H-M-L-Disco-SOS. So I’m thinking successful DIY build! I notice the Ultrafire host threads are a little dirty and gunked up from 3-4 years of regular use so I do a complete tear-down and re-lube.

Try it again and no more modes… its just single mode only, HI (3.8Amps). I take it apart double check everything, even unscrew the pill from the reflector quite a bit to make sure I dont have a reflector short, and no dice. Still single mode only.

I try different batteries sony, samsung, sanyo, LG… even pulled some old tired cells out of the recycle bin. NADA, still single mode only.

At this point I realized the O-ring gasket behind the front lens is skewed a little and blocking some light, so I pull it apart and get it put back together right…. and now everything works!! Tried all different batteries (even the old ones from the recycle bin), and now it works fine…???? I even tried tightening the brass pill all the way against the plastic reflector insulator, and it still works fine.

I’m totally puzzled and can not explain what happened. I have built 10 ± P60 modules over the years, using all kinds of (what I call) mystery-mode driver boards from DX and I have never seen anything like this.

I think it might be a dodgy EPROM chip… but I have no way to validate that.
So for now I am happy, since I use this light as a constant-ON task flood light and usually leave it on LO-MED.

and heres the pic of the east-92 in my (then stock) HD2010. Its actually a great driver (IMHO).

RAW74
RAW74's picture
Offline
Last seen: 2 months 1 week ago
Joined: 07/23/2012 - 16:01
Posts: 816
Location: east coast USA
Kramer, thats just as strange as what mine is doing. I am going to take the whole light apart and see what happens. With my luck though, when I get it back together it will only work on high with 18650’s too!Well, I guess that would push the issue to replace the driver anyways!
raccoon city
raccoon city's picture
Offline
Last seen: 24 min 28 sec ago
Joined: 10/06/2010 - 02:35
Posts: 17075
Location: रॅकून सिटी Palm Desert CA USA

Welcome to the addiction, RAW74!

Best0270

raw1

raw2

RAW74
RAW74's picture
Offline
Last seen: 2 months 1 week ago
Joined: 07/23/2012 - 16:01
Posts: 816
Location: east coast USA

Thanks Racoon, I took the light apart last night and cleaned/lubed the threads….adjusted the pill up and down, ect. Still only has high with a 26650 but at least it works with my 18650’s. I think I may leave it for now and purchase another 26650 light for the cells I have(trustfire 5000 protected). Now I am torn between a Uniquefire A8, UF2200, or the Shadow JMO7 pro. I like the A8 but it dosen’t appear to be driven that hard. Does anyone know how hard the Shadow pro is driven? I haven’t seen it reviewed here. Thanks to all, Rick

BetweenRides
BetweenRides's picture
Offline
Last seen: 3 years 2 months ago
Joined: 01/02/2011 - 10:34
Posts: 2959
Location: Chicagoland, USA
RAW74
RAW74's picture
Offline
Last seen: 2 months 1 week ago
Joined: 07/23/2012 - 16:01
Posts: 816
Location: east coast USA

Thanks Between, I missed Foy’s review….I still like the looks of the A8, but the Shadow w/ a NW emmiter is probably gonna be the one. Or mabey I, need, both? Now I have to ask myself, what would Jenny do?