I just received my brass D4V2 and have a few questions

7 posts / 0 new
Last post
Wrench
Offline
Last seen: 1 week 3 days ago
Joined: 02/12/2019 - 11:43
Posts: 39
Location: Minnesota
I just received my brass D4V2 and have a few questions

The Aux lights cycle through the colors at a super slow rate compared to my other older D4V2 and the D4SV2 I got a week or so ago. Has the latest Anduril firmware slowed the change from color to color in rainbow mode from a change of once per second to what seems like 4 seconds? One other thing I noticed is its way harder to click fast enough to access battery check or any of the special functions. Like they shortened the time allowed between clicks?

Thanks
Bill

Edited by: Wrench on 01/08/2020 - 09:06
ToyKeeper
ToyKeeper's picture
Offline
Last seen: 2 days 15 hours ago
Joined: 01/12/2013 - 14:40
Posts: 10827
Location: (469219) 2016 HO3 // I get way more privmsgs than I can respond to, so please ask in a public thread if possible, for a faster answer.

The rainbow mode was slowed down to make it look less frantic. However, I don’t think the button timing has changed. It has been the same since before the D4 V2 came out.

Wrench
Offline
Last seen: 1 week 3 days ago
Joined: 02/12/2019 - 11:43
Posts: 39
Location: Minnesota

Well I just flashed to anduril. 2019-12-17.emisar-d4v2 and accessing special functions is back to the way I’m used to be. I have no idea what firmware was on the light as it was impossible to access version check. My other Emisar’s are running 2019-11-20 and the aux LED speed is the old faster way and accessing special functions is as easy as always. Maybe my brass D4V2 had a bad flash from the factory and flashing fixed the problem? BTW I never thought rainbow mode was too fast. In fact I liked it. Any chance of meeting half way in the middle? Say 2 seconds?

Thanks
Bill

P.S. Thank you for all you do for the flashlight community! You Rock!

ToyKeeper
ToyKeeper's picture
Offline
Last seen: 2 days 15 hours ago
Joined: 01/12/2013 - 14:40
Posts: 10827
Location: (469219) 2016 HO3 // I get way more privmsgs than I can respond to, so please ask in a public thread if possible, for a faster answer.

Adjusting the speed is a one-line change, if I recall correctly. Maybe this would be a good excuse to grab the code and set up a toolchain for building it? Smile

Some caution about the 12-17 builds though… and really, everything from 11-18 to the end of the year: They’re based on a somewhat experimental branch which is known to have some difficulty with thermal regulation. It fixes a bunch of other issues which had been around for ages, but it’s not quite what I’d call stable yet. So if you’re using these recent versions, try not to run it on really high modes unattended.

Hopefully I’ll have fixes for that merged soon, but thermal stuff always takes a long time to test.

Wrench
Offline
Last seen: 1 week 3 days ago
Joined: 02/12/2019 - 11:43
Posts: 39
Location: Minnesota

Is it OK to flash back to an older version firmware? The brass D4V2 has a lighted switch does all older firmware support this? If so it looks like I would need to go back to 2019-09-28 to be before 11-18 builds. On the D4SV2 it would be 2019-10-06. If I remember correctly these versions do not have the muggle mode fix correct. Is there a list of changes some where?

Thanks
Bill

ToyKeeper
ToyKeeper's picture
Offline
Last seen: 2 days 15 hours ago
Joined: 01/12/2013 - 14:40
Posts: 10827
Location: (469219) 2016 HO3 // I get way more privmsgs than I can respond to, so please ask in a public thread if possible, for a faster answer.

The change log may be useful…

https://bazaar.launchpad.net/~toykeeper/flashlight-firmware/fsm/changes

In particular, r456 added support for the d4v2 button LED. And the muggle mode fix was a long time ago. As far as I recall, none of the builds on my site have that issue. The very first firmware posted for it was already fixed.

Wrench
Offline
Last seen: 1 week 3 days ago
Joined: 02/12/2019 - 11:43
Posts: 39
Location: Minnesota

So there is no older firmware for a D4V2 with lighted side switch, It started with builds made after 2019-11-25 so anduril.2019-12-17.emisar-d4v2? If so the light must have shipped with the same firmware I flashed it with as I flashed with anduril.2019-12-17.emisar-d4v2. My brass D4V2 must have came with a bad flash as flashing it fixed the accessing special functions problemI was having.