GTmicro weirdness

8 posts / 0 new
Last post
Lightbringer
Lightbringer's picture
Offline
Last seen: 58 min 27 sec ago
Joined: 08/30/2016 - 14:12
Posts: 15474
Location: nyc
GTmicro weirdness

Just a little oddity that popped up at random a handful of times, wondering if anyone knows what might be happening.

Turn on the light, shine it around a few seconds, click to turn off and nothing, it stays on.

Click again (as if to turn on had it turned off), and nothing.

Click again (had it turned off then back on again), and it turns off. Only the lit sideswitch is now turned off.

Click on and click off, and it turns on then off as expected, only now the sideswitch lights normally again.

Is there a “shortcut” to temporarily turn off the sideswitch light that I may’ve hit by accident? Only control over the sideswitch light is in the config mode, unless I’m missing something.

I was wondering if maybe “sticky” operation of the switch triggered something, eg, a click registering as click’n‘hold or doubleclick or something.

And nope, it’s not repeatable. Seems to happen purely at random. I’ll click on/off a bunch of times after it happens, trying to retrigger it into happening again, and can’t.

Any ideas? Might be a nifty feature if I could do it consistently. LOL

09 F9 11 02 9D 74 E3 5B D8 41 56 C5 63 56 88 C0

Unheard
Unheard's picture
Offline
Last seen: 4 hours 14 min ago
Joined: 01/16/2019 - 11:38
Posts: 2181
Location: Germany

There’s a known bug in Narsil. No fix since it’s useful: Just switch off shortly after switching it on or pressing the switch shortly and the aux stays off once.

As to why it doesn’t register pressing the switch I don’t know. Andúril had it, too, Something with timing. That’s fixed. Maybe you press for too long? The FT03 does it, too.

Smile, you cannot kill them all.

hodor
hodor's picture
Offline
Last seen: 11 hours 57 min ago
Joined: 07/11/2018 - 03:58
Posts: 1062
Location: UK

Sounds like a combination of the notoriously dodgy switch used in the GTmini family and standard NarsilM side switch LED behaviour. IIRC click on, click off, click on relatively quickly (not sure on timings) disables the switch LED until next click on.

Lightbringer
Lightbringer's picture
Offline
Last seen: 58 min 27 sec ago
Joined: 08/30/2016 - 14:12
Posts: 15474
Location: nyc
Unheard wrote:
There’s a known bug in Narsil. No fix since it’s useful: Just switch off shortly after switching it on or pressing the switch shortly and the aux stays off once.

Interesting. That’s weird… but potentially useful.

Seems like the same in-between time to get to moonlight: longer than a regular click to last-used mode but shorter than lowest-then-start-ramping.

In this case, too short a time is a 2click to turbo, too long a time is on-then-off, and “just right” is on/off with no aux light.

Huh… learn something new every day.

Unheard wrote:
As to why it doesn’t register pressing the switch I don’t know. Andúril had it, too, Something with timing. That’s fixed. Maybe you press for too long? The FT03 does it, too.

I can’t repeat it on demand. Light can be on a few seconds, at least 3-4, maybe a minute, yet not register the click-off. And it’s not just a missed click because there’s always another eaten click after it, like a completely missed off/on cycle before finally turning off but with the no sidelight.

09 F9 11 02 9D 74 E3 5B D8 41 56 C5 63 56 88 C0

Lightbringer
Lightbringer's picture
Offline
Last seen: 58 min 27 sec ago
Joined: 08/30/2016 - 14:12
Posts: 15474
Location: nyc
hodor wrote:
Sounds like a combination of the notoriously dodgy switch used in the GTmini family…

That’s what I thought at first, until I noticed always another eaten click. That part was consistent.

And the sidelight-off after was another consistent quirk.

Had/Has me stumped.

09 F9 11 02 9D 74 E3 5B D8 41 56 C5 63 56 88 C0

Blackbeard
Blackbeard's picture
Offline
Last seen: 2 days 2 hours ago
Joined: 11/09/2017 - 23:12
Posts: 602
Location: USA

mine is a bit flaky as well, I notice if you do a slower click to turn it off it thinks you want to ramp and doesnt shut, when you do a speedy click for off that seems to work every time, kinda annoying but you get used to it

Lightbringer
Lightbringer's picture
Offline
Last seen: 58 min 27 sec ago
Joined: 08/30/2016 - 14:12
Posts: 15474
Location: nyc

Yeah, I noticed, but I’d actually expect that, though.

09 F9 11 02 9D 74 E3 5B D8 41 56 C5 63 56 88 C0

Blackbeard
Blackbeard's picture
Offline
Last seen: 2 days 2 hours ago
Joined: 11/09/2017 - 23:12
Posts: 602
Location: USA

Ahh well it’s hard to describe this on forum, I had meant the casual push you would do for any e switch light and expect the function to occur, in this case turn off….does not always work on the GT micro and it stays lit.
You have to do a speedy press as if the button was a red hot 200°F and lingering on it would give you a blister Smile