Problems with UNBRANDED LEP LIGHT ON NEALSGADGETS

5 posts / 0 new
Last post
Satisfaction
Satisfaction's picture
Offline
Last seen: 1 month 2 weeks ago
Joined: 01/13/2018 - 07:50
Posts: 126
Location: Vermont
Problems with UNBRANDED LEP LIGHT ON NEALSGADGETS

I just got mine in the mail as a birthday gift from my Father-in-Law and was super excited to try it out. I put a fully charged EVVA 4500mAh 26650 in it and nothing. I tried another and still nothing. So I tried plugging in the USB-C charging cable and it lit up 100% with a progressive charging icon. I tried turning it on again while plugged in and it blinks on and then immediately off and indicates 2.5v. If the cord is not plugged in there is no power at all.

Does anyone have any Idea?

Satisfaction
Satisfaction's picture
Offline
Last seen: 1 month 2 weeks ago
Joined: 01/13/2018 - 07:50
Posts: 126
Location: Vermont

Not flat top and I put it in the right way.

Satisfaction
Satisfaction's picture
Offline
Last seen: 1 month 2 weeks ago
Joined: 01/13/2018 - 07:50
Posts: 126
Location: Vermont

this is possible

Satisfaction
Satisfaction's picture
Offline
Last seen: 1 month 2 weeks ago
Joined: 01/13/2018 - 07:50
Posts: 126
Location: Vermont
flashburn wrote:
battery too long, so the tailcap does not close and make contact to the tube?
Quote:
Physical Lock Out = Slightly loosen tail cap

THANK YOU!!!!!!!
This was it

once again this community is awesome!

Satisfaction
Satisfaction's picture
Offline
Last seen: 1 month 2 weeks ago
Joined: 01/13/2018 - 07:50
Posts: 126
Location: Vermont

flashburn wrote:
Happy Birthday Wink

it is now Smile