Wurkkos HD20 Switch LEDs

3 posts / 0 new
Last post
Entr0py
Offline
Last seen: 3 hours 45 min ago
Joined: 10/22/2021 - 17:19
Posts: 22
Location: United States
Wurkkos HD20 Switch LEDs

This is my first new post and wanted to say I am happy to know I’m not the only person addicted to flashlights! I recently purchased a Wurkkos HD20 from amazon and noticed that the e-switch behaves differently from the other Sofirn/Wurrkos models I own. Typically there are two green LEDs in the e-switch which illuminate green when powered on. The e-switch in the HD20 only illuminates one LED, the rear, the forward LED remains unlit. Can someone with an HD20 please verify this is the intended behavior while turning on? I am not sure if I have bugged firmware, it just seems inconsistent in design compared to my other models. Thanks in advance.

Serlite
Offline
Last seen: 9 hours 29 min ago
Joined: 11/01/2018 - 16:14
Posts: 459

This is normal, yeah. I noticed it when I got my HD20 as well.
Some of the pictures still show green LEDs on both sides of the switch, but that was likely an earlier iteration.

I think the manual had some details on what to expect, though I don’t have it readily available to verify.
You can see it mentioned in the description of this Amazon listing (scroll down to the part about “Power Indicator”).

Entr0py
Offline
Last seen: 3 hours 45 min ago
Joined: 10/22/2021 - 17:19
Posts: 22
Location: United States

Thanks Serlite, I totally missed that, thanks for pointing it out. It just seems odd, i’m glad I don’t have something bugged.