FW3A, a TLF/BLF EDC flashlight - SST-20 available, coupon codes public

It’s called bulk purchasing power. It’s always better to buy more of something if you can justify it, sell it, or use it.

If you can buy 2000 pcs of something vs 1000 pcs of something, it may lower the cost as much by a factor of 2 (50% or 1/2).

That’s my experience with ordering custom springs anyway.

Thanks, I was going in through the tailcap because apparently Im a du-mas and cant read instructions, inserted the battery from the front and everything works.

So is WW, NW or CW better?


Which one is better?

5000k 95CRI SST-20.

So NW obviously for most uses, and warm white for outdoor lights and lamp posts.

If only there was a 5000k 95CRI SST-20 though…

That would make things so much easier. better.

Good one Mr. Scott!! :+1:
I predict that is one “controversy” that will never be solved…… :innocent:

Hi…. Go HERE . Read it, do what is says, and hopefully that will fix you up. :+1:

Make sure the threads are clean too

what does one use to clean the threads? Alcohol? How about Hydrogen Peroxide? Or WD 40? Any of these? Then Super Lube Synthetic Grease afterwards? Thanks!

A simple cleaning rag.

Yeah… like BSM said, a rag.

Put the rag in your open hand, grasp the threads, and give it a twist. Clean threads.

Inside threads… use rag over finger tip.

Super Lube is great.

Interesting, mine said that mine was “on the way” like a 5 days ago but the tracking number draws a blank on every site that I try it on…
Anyone else experiencing this?

Still no sign of the SST-20 version? It is almost a month now.

Could someone please link me to a colour comparison between the 3 emitters.

1A - 3D - 7A

I already got my NW, but I too am waiting for the SST-20…

Please add this compile-time option. I prefer undelayed release-off. Thank you.

Is there a factory reset? When I got the light, it ramped to point and stopped…double tap to turbo…
Now it ramps to a blink, and continues on to turbo… It’s been out of my hands for the weekend

There should be a “blink” in the middle of the ramp. That’s the light swapping from the single channel to the multi. It stops at the top of the regulated channels and double-click engages the FET. Try it — ramp until it stops, then double-click and see if it doesn’t get brighter. I’d bet its working properly you just didn’t notice the “blip” in the ramp earlier.

Nope…. When I first got it,it ramped to a point and stopped.no blink.double for turbo.

Now I tried it like you said, and after it ramped through the blink, and hit a ceiling, double click did nothing.
Fixed the steps/ramp

Cell fully charged? Maybe it can’t supply the amperage needed for turbo?

I keep asking because the behavior you describe isn’t even programmable. Its not something you can reset (as far as I know). You’re describing a full-on malfunction. Which is possible, but not easily fixable if its happened.

Charger says 77%