HaikeLite MT09R

Hi to all

Got my HaikeLite MT09R out of storage after couple of years and now the switch led is not working, more than likely I turned the darn thing off before storing it, still no clue in which box the manual may be hiding (hope that my wife did not help it by mistake into the recycling bin).
I tried all the combinations that are floating in my head to turn it back on however my memory isn`t that good and none helped.
Anyone have a clue how to turn it back on or is it possible that the led just died?
The batteries still are at 3.9v after a couple of years in storage.
Any ideas/suggestions are very much appreciated.

Thank you for looking.

Do you remember that MT09R has the Narsilm UI and therefore with 4 clicks from off you lock and unlock it electronically?

@Fedtro thanks for chiming in. :+1:

Yes I did remember about the Narsil firmware that is why I am surprised that the switch led did not come to live even after doing a factory reset.
To reset settings to factory defaults, in firmware version # display, press&hold for at least 1.2 seconds if I remember correctly.

Yes, reset is right, 1.2 second press and hold

The light functions as intended unfortunately so far no luck of turning the switch blue led on, seen a couple of very dim flashes of the blue led however it does not stay on.
Any ideas how to fix it?

Narsim is about midway down the page.

I’ve got Haikelite XPH35, I had this kind of issue. I carried my flashlight to the cellphone repaire service. Repairer had changed some very small SMD and returned me it within 1 day.


Thank you for the link, i have seen it briefly before and never bothered to read the whole tread however this time decided to read the whole thing and have discovered that my MTR09R had the Strobe modes disabled.

Thanks to @d_t_a for clear instructions how to enable them, now I can enjoy more blinking/strobing lights and keep annoying the neighbors.

Unfortunately I was not able to restore the switch blue led to a working state, perhaps as _@Alex5542_ mentioned one of the resistors has gone hay-wire and needs to be replaced to gain full functionality of the led.

Update 11/26/22:

Few days have gone by and now the whole switch has gone mad it does absolutely nothing, no back light or any kind of light that works, the power switch is done not working at all.

Yes i did send an e-mail to Haikelite still waiting on replay.

Any ideas where I can get an original replacement switch from?