Has anyone used this AA boost driver?

You can ask BanL in this thread or by PM.

I have a couple of these drivers but they’re all 4 or 5 years old so things could have changed since then.

I’ve just installed the 17mm KD driver listed in the OP and can confirm it has no mode memory and works on 14500, though obviously don’t know how that affects reliability. Also seems to work quite nicely on a 3v lithium.
Now i know it works i’ll solder the stars to set the l-m-h mode.

Good to know. I’ll probably order a couple to try. I also want to use L-M-H.

The reliability is determined by the components in series with the led and the value of the feedback resistor that determines the current. With a R120 feedback resistor (from the pics) it should be reliable more so with the smaller battery sizes like 14500 and 16340 that have more voltage sag under load.
I upgraded the components in a V11R that uses the same PAM2803 with a 316BCG rotary position sensor for more current.

This driver could also probably benefit from the same type component upgrades for more current.
@Marc E What is value of the feedback resistor on the new drivers you just received from KD? In the pics it looks like it is using a R120.

Oooooh, more current! I like the sound of that.
I haven’t memorised how to read SMD values yet (and have forgotten the discreet resistor band values :person_facepalming: ) so have this 2000 word equivalent answer:

There is a problem with the driver though, on full power mode with an NiMH the output pulses. Every couple of seconds the output briefly increases by a few lumens. Need more time to test but here’s a video of what happens: (Haven’t learnt how to embed videos yet either. Soooo much to learn, only one brain… :confounded: )

Oh well, looks like it’s junk. Glad I didn’t order any yet. Seems like a decent AA boost driver with good modes doesn’t exist. The best ones seem to only come in specific flashlights and aren’t sold by themselves.

@Marc E, Do you get the same flickering effect after a few minutes of being on. Or is it happening only in the first few minutes of being turned on?

@jasonguitarist, in the event you’re still looking, I’ve used this CF 17 in a couple of Mini-Mag mods and can confirm that it does NOT have mode-memory. The driver runs without issue on either 2xAAA’s or single 14500 w/dummy, all modes in both cases. I use one (more frequently) with NiMH and the other (used less frequently) with 14500.

I bridged Stars from default H-M-L-Strb-SOS to Mode-3 L-M-H. I don’t have a light meter but I grabbed a couple of quick power readings just now at using a 14500 (4.11V), I got 0.12/0.68/2.18A readings at start respectively.

Uses PWM but not noticeable in use.

No strange pulsing on high mode with nimh AA like in the video on post #11?

I have used this KD driver several times in 1AA cut down mini mags and never had a issue. Did you order more than one driver, maybe try another if you did.

Nothing that I can detect running 2x NiMH. Went ahead and ran using only 1xNiMH as well to see if perhaps it could be a single cell struggling to keep up, still no pulsing.

Here’s a short video of driver in action (first video post for me). Those changes in light level on High (after start-up from Low-Med) are as a result of my hand moving with the flashlight and not the driver pulsing.

Chucked an NiMH in it, turned it on… no pulsing. :person_facepalming: Waited a couple of minutes, still none.
Let it fester in the back of my mind for a while then ran it on a 3V lithium for a couple of minutes to warm it up, changed to an NiMH and…. pulsing!
After 12 minutes i noticed the pulsing was slowing down slightly erratically. Bright for roughly 4 secs, dim for roughly 1, bright for 6, dim for 1, bright 5, dim 1, bright 3 dim 1, 4-1, 9-1, 7-1 etc etc.
After 16 minutes the pulsing stopped. Turned it off, turned it on, no pulsing.
Remembered i’d measured the lux when i first turned it on, measured again and it was the same, so not losing any power.
Ran it on 3V again for a couple of minutes, no pulsing, then back to NiMH and… still no pulsing. Had it running for about 10 minutes now on NiMH and it’s pulsed a couple of times but that’s it.

At a guess it seems temperature related and possibly only on an NiMH which might not get hot enough on it’s own to trigger it, so not sure how much of a problem it is. Could be component in the process of failing though.
I don’t really use the light but i’ll try and use it at some point, see if anything happens.

The video link is: - YouTube which definitely isn’t right, and when corrected to - YouTube the video doesn’t exist.
Do you know the right URL for the video?

@Marc E, frankly it’s not much of a video.

When I copied and pasted, the long form resolved to this, try - “- YouTube

I got this same driver and I’m having a little trouble with it too. Any help would be appreciated.

I put it in a D26 dropin with an SST20 and a single CR123. I’m only getting one mode. My thought is it’s going direct drive. With a slightly used battery I get just under a half amp. That seems to match up with what direct drive would be. Any thoughts?

Here is a picture (I hope it shows up ok I have not posted a photo before).

Edit: Sorry if the photo is too big. I tried to make it not break the page.

You should probably make the image 100% wide.

Instructions are here:


Raccoon City, thanks for the advice and for your nice how-to. I did read it before hand and thought I had followed the instructions. I did put ‘100%’ in for the relative width size but still wound up with the above. I reread your instructions and reviewed my post but couldn’t see what I had done wrong. I left it alone, afraid I might mess it up more. I did the post on my phone, I don’t know if that matters.

Just edit the post text and change the link picture (width) percentage to something like 60% and save. It will reduce the pic size.
change to

Sorry, I can't get hardly anything done on my phone, so I don't know how to help you.

Thanks guys! I changed it to 60% like Moderator007 suggested. It looks fine on my phone now. Now if I can just get this driver figured out…