help with avrdude and D4 flashing kit

I want to reflash an ATtiny13a but all the instructions I found use Arduino Uno and Arduino IDE. I have Arduino IDE but not an Uno. I have one of Hank’s flashing kits and thought maybe I could do it with that instead. I followed these instructions to install avrdude which seems to have worked but i’m kinda stuck now. I can’t seem to get my pc to recognize the device, it says the “usb device is malfunctioning”. So how can I get the pc and flashing device communicating? I have the ATtiny temporarily soldered to the flasher matching up 6 of the pins (vcc, mosi, miso, rst, sck and gnd).

Any help appreciated :slight_smile:

I followed Hoop’s guide to set mine up. It was a while ago now so can’t remember all the details but I don’t recall any issues with the setup.

Thanks hodor. Looks like I was missing USBasp driver for the device. Unfortunately, when I follow Hoop’s instructions to “update driver software” I get a message that “the best drviers for my device are already installed”.

Funny… the best drivers don’t recognise my device :person_facepalming:

Any other suggestions?

Hanks kit will work, it’s just a. USBasp. You need to install a driver for the USBasp. Step 2 in Hoop’s guide, or step 1 in the D4v2 flashing instructions.

Once the driver is installed, avrdude should recognize the programmer. If you still see the device is malfunctioning message, restart your PC and plug the programmer directly into one of the USB ports, not into a hub.

See if it shows up in zadig from the D4v2 guide (I’ve never used it)

Thanks treellama. I was just learning to install the drivers through Zadig. About to restart…

Still no go. I think I need to go back to simple manually making stuff. This digital jargon is really frustrating the crap outta me.

Zadig says the driver was successfully installed but nothing shows up in the zadig window.

Does it still show up as malfunctioning in the device manager? Try plugging it in without the leads to the micro attached. If it still doesn’t work, maybe you got a bad one?

Did you try Arduino IDE with libusbK driver?
You can select it on Zadig installer.

Device manager still shows “Unknown USB device (Device Descriptor Request Failed)

When I try the Zadig now it says “Installation fail. Resource already exists”

I was just screwing around trying to see if Arduino ide would recognise it I don’t really know how to do that either

I somehow managed to get Zadig to show with a USBasp device. When I try the test code in command prompt I get this message -

avrdude: Warning: cannot query manufacturer for device:
avrdude: Warning: cannot query product for device:
avrdude: error: could not find USB device with vid=0x16c0 pid=0x5dc vendor=‘’ product=‘USBasp’

avrdude done. Thank you.

On Arduino IDE you should have installed your MCU library, select USBasp on “Tool->Programmer” and use “Sketch->Upload using programmer” to flash code.

I hope it works

Thanks for your help Dlux.

I tried what you said and got the same message with Arduino IDE as with command prompt

An error occurred while uploading the sketch
avrdude: Warning: cannot query manufacturer for device: Input/output error
avrdude: Warning: cannot query product for device: Input/output error
avrdude: error: could not find USB device with vid=0x16c0 pid=0x5dc vendor=‘’ product=‘USBasp’

I finally got the USBasp device to show up in the device manager but on the events log I am getting a message “device requires further installation”.

I’ve already updated windows and tried to update the driver. I found one other thing to do which was to update the Intel® PROSet/Wireless Software.

It hasn’t fixed the issue :weary:

It is extrange, I solved that same warning error installing libusbK (note the K at the end) driver with Zadig.

Here is what I did:

Edit: I’ve just seen I used Zadig 2.4, maybe last version has a bug

Personally if it were me, I would go back and try to uninstall everything and start again with Hoop’s guide. If you get any errors, ignore them and keep going. I have a feeling my drivers didn’t look like they installed correctly but turned out to work just fine.

Checking the connection with “avrdude -p t13 -c usbasp -n” in Atmel Studio Command Prompt is the only test I need to check the connection is good and everything else is working.

I just had another little go at this.

If I unplug the device and plug it back in the pc reverts to “usb device is malfunctioning” and I have to go through the zadig process again to get it to show up. No matter what I do though I cannot get rid of the “device requires further installation” message. I tried disabling the Driver Signature Enforcer and rolling back the driver version but nothing seems to work.

Yes I’ve been trying the “avrdude -p t1634 -c usbasp -n” connection check at every point. I still get the same error message.

Not only does my soldering iron hate me, my pc does as well :weary:

Looks like uninstalling and reinstalling avrdude is going to be as much of a headache as the rest of this has been

Thanks Man w/O shadow. I’ll have a look later tonight


I finally got it to work !!

I plugged it in to a different usb port. Don’t look at me like that :neutral_face: I already tried it. For some reason this time I tried a 3rd port and it woked perfectly fine this time.

So I programmed the ATtiny13a and wired up an led and battery….

Thanks to everyone for your suggestions and helpful advice. :beer:

You know if it wasn’t for the virus making shipping super slow lately I probably wouldn’t have tried this. Maybe I’ll explore it a little more now :wink: