TK's Emisar D4 review

Intl-outdoor will sell it was well (should be free shipping to NL), so don’t worry.

Thanks! Will wait for that. :+1:

Cheers! :beer:

In case you didn’t know, Hank Wang (member here as well) is the man behind Noctigon and Emisar, and Intl-outdoor is his business. The firmware for the D4 is most likely adapted now before he starts selling them on his site.

The output on this 18350 2 1/2” light is insane!

I know, right? I didn’t know one could get 2800 lm from an 18350 cell. At first I thought I did the measurement wrong.

… and I don’t even have those fancy new Aspire cells yet. I’ll have to get some, when they’re slightly easier to obtain. They make the shorty version of this light rather practical, even for pretty long nights.

On a related note, the springs are holding up unexpectedly well. Even after running at the maximum brightness with my highest-amp cell for thermal testing, the springs don’t appear to be sagging at all. Hank must have sourced some unusually good springs.

I’m surprised I haven’t damaged anything yet, testing this thing with thermal regulation disabled. It was so hot that I nearly burned myself just pressing the rubber button to turn it off.

I was under the impression that those springs are identical to that of the M43, see post #213: New 4XP Noctigon MCPCB for quad optic

The dark purple Efest 18350 will deliver the most current, the Aspire does ok and of course has longer run time, just doesn’t give maximum output.

Wondering what this little green meanie would be like with Nichia 319’s? :wink:

Next time I take it apart. It’s pretty shallow though; barely enough room for the tiny85 chip to fit. Something like this is way too big; even the capacitors may be too thick:

Yes. The only reason the driver needs any contact with the pill is for thermal measurement. The pill has no electrical contact.

I have the Aspire cells and switched to the Efest purples with the XPL Hi and crude burnt my stupid fingers in under a minute, just set it down and reached for something and turned around and picked up the light and that’s it burnt toasty fingers big time, the other two can run on turbo for a long time after you figure out how to keep it on Turbo, drops like a rock to moon in about 5 seconds but a single click will push it back to turbo and it will stay if you don’t ramp down even a 1/2 percent then try and go back up to turbo, it will just drop again.
Will need to tell R. about this and see if I can ship them back to be reflashed with Narsil like TK did…? Sort of annoying.

Edit: I tried to pull the spring and board out of the tail and it must be glued, but the springs are rock solid IMO, put in a protected and cranked on the tail cap and head as hard as possible to see if I could make a connection and couldn’t but the springs held up, put in a copper crush washer in the tail and a protected cell pany will work and not show threads. The tail end of the battery tube threading is not consistent, had they made the threading one more maybe two complete turns protected cells would work I think, but as they are now looking at the three tail caps they are all three at different angles with the branding, drives me nuts, anal something I guess, has to be dead on or it bugs me.

Aa you can see, slim one-side fet-based board contacts shelf from the one side and cell from the other. There is even no way to add extra 7135 over stock one.

Cheap and easy solution. Im not sure in pcb copper layer friction abilities, if they decided to exclude retaining ring, they could at least add thick (in comparation with 0.35mil cu layer) brass ring soldered to the driver.

That one light might be triggering LVP. The low-voltage behavior is to drop directly to the lowest level.

So it could just be a weak cell. Does the weird behavior move if you move the battery to a different D4?

Cheap and easy are fine, as long as they’re good enough. I’ve had my SRK for several years now, with quite a bit of friction on its PCB copper BAT+ ring, and it has no problems. If it stopped working though, I could easily just spread a bit of solder on it to freshen it up. A thicker ring would be nice, but it seems unnecessary.

Sweet! Thanks for sharing your method. :+1:

Looks like I’m finally gonna be buying the stuff needed for re-flashing. :wink:

Does anyone have suggestions before I do my own research on this?

To get lots of info about it, click the Link in my signature. :slight_smile:

(also, it’s worth noting that Narsil’s thermal regulation is calibrated for the Q8, and probably won’t respond fast enough on the D4… so, you should probably manage heat manually if you take that option)

D’oh! I’ve been there before but totally forgot about it. Thanks!

That capital ‘L’ only just now tipped me off to the Easter egg in your sig. :smiley:

Beamshots, finally.

I’m not very good at beamshots, but I hope these show what to expect. It has a round hotpot and a pinwheel-shaped corona, and not much spill outside that.

Shortest to longest exposure:

Yep, once I saw your graph TK I went and checked my cells with just a ZTS cell tester and they were low.
I have a lot of quads and none drain cells this fast,
What is the voltage the LVP kicks in at…? And it does do a three blink just before the drop I’m guessing…? I’m going to get voltage readings next time this starts to happen. Maybe it’s tripping early.
Thanks TK, appreciate your help, I think case solved… happy I don’t need to tell RMM anything now…
I would have really looked stupid, ah have you checked to see if your cells are charged, NO, let me go look… ha ha… Oh man, these lights did suck those Aspires bone dry fast, but that Aspire was in the XPL 1200 mAH just like that, wow or I lost track of time, really stupid no matter how I look at it frankly.

Edit: Nice beam shots, mine look like quad stars with 4 points to the profile,

LVP is configured for step-down at 3.0V and shut-off at 2.8V.

If you’re seeing 3 blinks before the step-down, it’s definitely LVP kicking in.

Ya, I had somehow put some partially charged cells in with fully charged cells, do I need say more…?
Thank you TK… :blush:

Did a little GITD on one light tonight but didn’t use the right camera settings for the pic,

Thermal regulation update

If you recall, the original thermal protection behavior looked like this. It took way too long and got way too hot and never tried to step back up again:

As a quick check, I tried decreasing its timeout so it could respond faster. It responded faster and didn’t get quite as hot, but it still exceeded what I’d consider a safe temperature, then went down too far and never came back up.

So I decided to go with the original plan and rewrite that part from scratch.

I changed lots of things, but the main thing new method does is try to predict what the temperature is going to be in the future… then react based on that. This helps eliminate the effect of the time it takes for heat to travel from the emitters to the sensor. The correction is proportional to how far the prediction exceeds the thermal ceiling, so it adjusts a lot faster while heat is increasing quickly.

Also, it does regulation instead of protection, meaning it will also try to step back up if the temperature gets too low. But step-up is intentionally slow to avoid oscillations.

So, here’s how the first test went. It was certainly faster, but it over-shot and then took too long to recover.

I slowed it down and tried again, but it slowed down too far. This time it got too hot and took too long to drop to a safe level.

After fixing that, I checked again and behavior was better but it was awfully noisy / bumpy. I also noticed a bug where it could step down then up immediately, or vice-versa. That shouldn’t happen.

After fixing those issues, I tweaked some other things and increased the sensor resolution (ish), and tried again. This time it turned out reasonably well. Not perfect, but not bad. It dropped fast enough to prevent skin burns, then gradually adjusted from there. It didn’t even overshoot.

Some of the dips and bumps here were due to me holding the light and changing hands in an attempt to keep it somewhat heat-sinked, but I think in the future I’ll just point a fan at it.

Note, I didn’t recharge the cell between tests… so by the time I did this last test it was starting at only 3.7V. I’ll have to do that next time. For now though, I think this is a good improvement.

I’m also going to have to be extra-careful when I reflash the driver, because I’ve already managed to break one of the switch wires and pull out the other one. I don’t want to have to repair that again.