TLF/BLF/Lumintop FW3A review (18650, 3x XP-L HI cool white)

Removing the FET and some 7135’s would be the permanent hardware method.

Probably a quick fix is just to disable the FET. Just unsolder the R1 resistor. It can still ramp up to 900-1000 lumen, but not higher. Then you could probably set the ramp level to a lower point so it maxes out at 500lm or whatever. A double click would turn off the leds, but the brains will still be active. Just don’t double click, or if you do, ramp back down before turning off the light. No programming involved.

If you want to reflash it with custom code, maybe that’s easier than soldering for you, then you could do that as well. You’d still have to unsolder the led wires to get to the driver, though.

Thanks everybody! All great info, but unfortunately I am not nearly that good with a soldering iron! :disappointed: Has anybody used this light in muddle mode? Maybe setting it to ramp from low to 400 lumen would do the trick. I wish I brought the light with me (we are visiting my wife’s parents this week for Christmas), but will play with it this weekend!

Muggle works fine for me. Ramps up and down only and the brightest doesn’t make much heat.

I was just thinking about something regarding this light and flashing it. It does not have a USB interface and to reprogram it, it involves some desoldering. With so many things these days being bluetooth, why not a flashlight interface with a bluetooth connection with an app you install on your phone? We all have our phones on us all the time so it would not be an extra thing to lug around and would make programming, and just setting up the light as we want so much easier. Is this even possible, or has a light already been designed like this and I just missed it?? What do all of you think? Is this a brain storm, or just a slight drizzle?? :sunglasses: :smiley:

Toykeeper actually made special software and this driver was designed with an optical input (pin 7 on the MCU) that accepts flashing the driver from a blinking light source such as a cell phone. Unfortunately it took a long time and was overly complicated, so it was not put in to use.

I’m not aware of any flashlight with a USB interface, only USB charging.

There are older flashlights with a bluetooth interface and an app you control with your phone that let’s you do cool stuff like change the settings, flash to music and remote turn on/off, but it was expensive so people didn’t buy it. The app was not kept up to date either. It doesn’t seem very practical. IDK, maybe future designs could use bluetooth, but it adds so much more complication.

Things today are going the way of the flashing pin array that you access without removing the driver and you can reflash the driver from your phone. Check the Emisar D4v2. The FW3A was designed a couple years ago when flashing pins where not popular.

Toykeeper is the one that’s really on top of flashing interfaces. I only know a little bit.

I just put the light in Muggle mode, and it works fine, except you apparently cannot set the ramping mode to anything else other than 5-240 lumens. I was under the impression I could maybe lift the ceiling lumens up a bit, but just read the instructions. It says to click on the switch four times while on to get into the ramp config mode, then hit the switch one time to set the lower level, or two times to set the upper one. So I clicked four times, then two, then 32 times and nothing happened. The other thing I noticed was that even when the light was at the upper level of 240 lumens, it started to slowly dim after it was on about a minute. The light was not even warm. I found another post about this issue and apparently it is a known one, but there is no solution. Am I correct?

I believe the biggest barrier to Bluetooth in flashlights is the firmware. There exist hw BT solutions for Ardiuno/ATMega, but the BT BLE libraries increase code size by hundreds of K. Apparently the libraries are fairly monolithic (and probably, written assuming 32 bits); by contrast, the ATTiny in flashlight driver has 1-4 K ROM. Build a driver with an Arduino class processor and 8MB ROM, and BT is an easy add on.

Muggle mode doesnt allow anything but ramping up and down. You have no menu options except to leave the mode.

There is a bug in that mode that activates the thermal stepdown too early. I haven’t looked into it. I think if it ramps down you can just ramp it back up. There is no fix that I’m aware of.

I got this light and it is not registering button clicks consistently. It can be in any mode, and it will be hard to leave that mode because it won’t take a click (single, double, triple, long hold, four clicks, etc.). It’s not in lockout. It’s not in muggle mode. Or it can be off and just hard to turn on.

I’ve found cranking the head all the way down helps (edit: not cranking hard. I mean just turning it gently all the way… not abusively). And pressing the button extra hard helps. It’s an intermittent problem.

I’ve also opened it (head end only, have never opened the tail end) and wiggled the inner tube liner that has the metal surface that makes contact with the metal in the head unit. I haven’t touched the metal, or the spring, or the ends of my battery. Battery has a full or almost full charge (4.1 volts now). Took care to clean the residue from the taped-on protective battery end cover that came on the battery from the maker. It’s a Samsung 35E, nothing surprising.

Can’t think of what I’ve done wrong here; is this thing just finicky? Or a bad unit maybe? More importantly, any mitigation ideas?

Are you running the pocket clip?

Make sure to loosen head, tighten tail firmly, then tighten head firmly.

And you can read up on intermittencies in the FW3A Troubleshooting and Useful Information threads.

Yes it has the pocket clip installed — I guess to remove it I have to remove the tail cap? Not completely unwilling to do that but I understand reassembly may take some doing and there’s a small part that can get lost if I’m not careful? (I will be if I do it). I like the clip but would be willing to remove it if that’s a fix.

Thanks KawiBoy1428, JasonWW and hank. That FAQ looks like what I was looking for… will be poring through that for a lot of information. I really like this light when it’s working, which seems to be about 80% of the time! :slight_smile:

For some people the clip is a bit too thick and it prevents the tail cap from tightening all the way down. If nothing else works and there is no gap around the clip, then try removing the clip and see if that fixes it. If so, you can make the clip thinner and reinstall it.

One of the tips from the FAQ / Troubleshooting thread (link a few comments up) seems to have fixed it for me.

It was the sequence of loosen tail and head, then tighten tail first, then tighten head. After that, it’s working great!

The sequence makes sense also (as you well know, but writing for the benefit of others here) since that inside tube that needs to make contact can be positioned in the wrong place, and only by having the head loose will there be room for the act of tightening the tail to push it up enough to sit where it can make good contact.

I imagine Lumintop could prevent this by making sure their final assembly entails tightening the tail first. But it’s a subtle point.

Edit: so to be clear, I got it working without having to remove the clip.

That’s the first thing I mentioned. Lol

Lumintop wanted to glue the tail caps. That would have solved that issue, but then you can’t change the clip or mod the button without a lot of work. So it’s got some compromises. Which is the better choice? IDK.

Welp I did read what you posted, and thank you :-).

To be fair, what you said exactly was:

>Make sure to loosen head, tighten tail firmly, then tighten head firmly.

My tail was already, prior to reading this, tightened firmly. I tried to tighten it some more, and it didn’t budge. I can assure you it was very tight.

So as a newbie to this flashlight it wasn’t clear to me that I needed to do anything more with the tail. And I effectively did as instructed by attempting to tighten it. And it did not fix the problem.

Only after I added the additional step of loosening the tail before tightening (this step is clearly spelled out in the troubleshooting thread), did it work.

What would have helped me right off the bat would have been:

“Make sure to loosen head, loosen tail, tighten tail firmly, then tighten head firmly, in that order.”

Just saying this in the spirit of feedback! Please don’t get me wrong; I very much appreciate all your help, thank you!

My light was starting to not only auto ramp down, but would all of a sudden just get brighter. The problem is very erratic and random. I just removed the head, tail, and the metal tube inside the light and cleaned it thoroughly with electronic contact cleaner. I noticed before I cleaned everything that the inner tube area by the tail cap, where it has an o-ring, was sticking up a bit too far where you could see the o-ring. After the cleaning, it tucked itself under the bottom of the flashlight body like it should have. So far the light has not auto changed brightness one way or the other. I have not been using it too much since the cleaning, so right now this is pretty inconclusive, but I will report back later.