slot #2 error on "Upgraded Miboxer C4-12" (got replacement unit..)

34 posts / 0 new
Last post

Pages

d_t_a
Offline
Last seen: 4 hours 33 min ago
Joined: 08/04/2017 - 23:58
Posts: 2266
Location: Manila, Philippines
slot #2 error on "Upgraded Miboxer C4-12" (got replacement unit..)

I decided to try out the new upgraded Miboxer C4-12 (2-button version).

  Just received the charger about a couple of weeks ago, and have been using it lightly only.

 

Suddenly the slot #2 displayed an error while I was starting to charge up some batteries today.

 

I did a little bit of troubleshooting by checking the voltage.

 

Slot #1, 3, 4 (the slots still working) have an open voltage (ie. when no battery is inserted) of 5.0 volts,

but the non-working slot #2 has an open voltage of 12 volts.

 

Video below shows my test:

 

Hopefully Miboxer can point out what is the problem and offer a solution.

Edited by: d_t_a on 08/19/2019 - 05:44
hank
hank's picture
Offline
Last seen: 9 hours 50 min ago
Joined: 09/04/2011 - 21:52
Posts: 9557
Location: Berkeley, California

Yeek! Failing to a higher voltage is not good.

hasddie293
hasddie293's picture
Offline
Last seen: 6 days 19 hours ago
Joined: 03/05/2019 - 08:53
Posts: 334
Location: Brunei

Mine work fine on all slots…no err shown…
But I cannot be 100% sure, haven’t had a test…but will check later on… Shocked

In search of the most ideal flashlight in town:
1. BRIGHTNESS
2. Durabillity
3. Design
4. Quality
5. Price$$$

Mishanchik
Mishanchik's picture
Offline
Last seen: 1 week 1 day ago
Joined: 04/12/2019 - 17:23
Posts: 85
Location: Russia

New Miboxer C4-12, use 2 weeks – all excellent.

Mishanchik
Mishanchik's picture
Offline
Last seen: 1 week 1 day ago
Joined: 04/12/2019 - 17:23
Posts: 85
Location: Russia

Any news from Miboxer? Did they repair your device?

Petr J.
Petr J.'s picture
Offline
Last seen: 1 month 2 weeks ago
Joined: 05/20/2018 - 10:07
Posts: 385
Location: CZ

Probably punctured the power output transistor.

d_t_a
Offline
Last seen: 4 hours 33 min ago
Joined: 08/04/2017 - 23:58
Posts: 2266
Location: Manila, Philippines
Mishanchik wrote:
Any news from Miboxer? Did they repair your device?

Sent video to Banggood, who has shipped out a replacement unit. Not sure if it’s the whole unit or just the charger… still in shipping status.

snakebite
snakebite's picture
Offline
Last seen: 5 days 13 hours ago
Joined: 11/20/2013 - 20:21
Posts: 1996
Location: dayton oh

can it source any current through the cell in the error state?
if it is trying to charge at 12v this could get ugly.

Mishanchik
Mishanchik's picture
Offline
Last seen: 1 week 1 day ago
Joined: 04/12/2019 - 17:23
Posts: 85
Location: Russia
d_t_a wrote:
Mishanchik wrote:
Any news from Miboxer? Did they repair your device?

Sent video to Banggood, who has shipped out a replacement unit. Not sure if it’s the whole unit or just the charger… still in shipping status.

Please, write on the result.

d_t_a
Offline
Last seen: 4 hours 33 min ago
Joined: 08/04/2017 - 23:58
Posts: 2266
Location: Manila, Philippines

Received replacement unit. Will need to try charging batteries to see if any errors still occur.

The unit that developed slot #2 error was originally functioning normally (I was trying testing different batteries, and they seem to charge properly), but the slot 2 error suddenly occurred. At first I thought I inserted battery incorrectly (reversed polarity will also show the same “C2 err” display), but when I double-checked, the battery was inserted properly, and the slot #2 suddenly developed that error, under normal usage scenario (only a few days test charging several batteries)..

Anyway, will still observe the replacement unit to see how it goes.. Appreciate all the responses.

I wonder if there’s a way to fix the “C2 Err” on the original unit…

snakebite
snakebite's picture
Offline
Last seen: 5 days 13 hours ago
Joined: 11/20/2013 - 20:21
Posts: 1996
Location: dayton oh

its probably just an infant mortality failure.
as for a repair open it up and you should see 4 identical stages one at each position.
you are likely looking for a shorted mosfet.
and you have 3 good stages to look at and compare readings.

lacrimal
Offline
Last seen: 10 months 3 weeks ago
Joined: 10/23/2019 - 11:58
Posts: 12
Location: Poland
snakebite wrote:
its probably just an infant mortality failure. as for a repair open it up and you should see 4 identical stages one at each position. you are likely looking for a shorted mosfet. and you have 3 good stages to look at and compare readings.

I have same issue, It looks like in c4-12 upgrade #2 slot is now faulty. I can buy bunch of mosfet-s and replace them again and again if this is the problem. But it looks like it is deeper since no one report other port than #2 as faulty.
Submitted a complaint to the seller with refund request.

d_t_a
Offline
Last seen: 4 hours 33 min ago
Joined: 08/04/2017 - 23:58
Posts: 2266
Location: Manila, Philippines
lacrimal wrote:
snakebite wrote:
its probably just an infant mortality failure. as for a repair open it up and you should see 4 identical stages one at each position. you are likely looking for a shorted mosfet. and you have 3 good stages to look at and compare readings.

I have same issue, It looks like in c4-12 upgrade #2 slot is now faulty. I can buy bunch of mosfet-s and replace them again and again if this is the problem. But it looks like it is deeper since no one report other port than #2 as faulty.
Submitted a complaint to the seller with refund request.

Could you show how to change the Mosfet (a picture of which part of the Miboxer C4-12 would be great) and what model/type of Mosfet replacement would be suitable for the slot #2 error? I’m not skilled nor knowledgeable enough to do such repairs, but if I can find someone to help do the “repair/soldering” to fix the slot #2.. Thanks in advance.

lacrimal
Offline
Last seen: 10 months 3 weeks ago
Joined: 10/23/2019 - 11:58
Posts: 12
Location: Poland

@D_T_A
Not opened it yet, waiting for seller information, I don’t want to broke warranty.
If dispute will be closed without luck I will try repair and send you some instructions if successfully.

tantien11
Offline
Last seen: 2 months 3 weeks ago
Joined: 07/28/2018 - 02:14
Posts: 8

I tried replacing ME3118A and it works

lacrimal
Offline
Last seen: 10 months 3 weeks ago
Joined: 10/23/2019 - 11:58
Posts: 12
Location: Poland
tantien11 wrote:
I tried replacing ME3118A and it works

According to http://www.szyucan.com/upfile/IC-PDF/ME3118.pdf it has padded LX that can be pretty hard to replace it without proper tools.

Anyway still waiting for seller proposal.
[update]
AliEx proposed 1/4 of the price, currently can’t repair this for that amount so still negotiating.

Geronimo
Offline
Last seen: 3 weeks 1 day ago
Joined: 04/20/2019 - 19:11
Posts: 171
Location: Ohio

Any other news, mine shows an error on slot 4 today after using it three or four times?

Emisar d1s 3a. ZL sc700d,sc64w hi,H600c,Streamlight tlr1-hl, Astrolux mfo1s 4k/purple. Olight I3t Eos black. Ylp 2m cri.ZL sc64le inbound k1 xhp35 hi in 4k.

lacrimal
Offline
Last seen: 10 months 3 weeks ago
Joined: 10/23/2019 - 11:58
Posts: 12
Location: Poland

Hi yes,

I got refund for my broken c4-12 upgrade so now there is time and budget to open it.
After some measurements that I’m capable to do it looks like @tantien11 has right in my case.
Drain (LX) of second slot ME3118A gives full 12V and that gives overall error on this slot.
Attached picture that expose names of particular parts, not especially pretty but you should get part name.
I’m talking about 4 sop8 ICs placed on top – in my case it is second from left.

Geronimo
Offline
Last seen: 3 weeks 1 day ago
Joined: 04/20/2019 - 19:11
Posts: 171
Location: Ohio

Thanks, I was offered 1/4 refund since three slots still worked. I said no , so they are sending me a new one. Might try to open the faulty one up. No experience with this lol

Emisar d1s 3a. ZL sc700d,sc64w hi,H600c,Streamlight tlr1-hl, Astrolux mfo1s 4k/purple. Olight I3t Eos black. Ylp 2m cri.ZL sc64le inbound k1 xhp35 hi in 4k.

lacrimal
Offline
Last seen: 10 months 3 weeks ago
Joined: 10/23/2019 - 11:58
Posts: 12
Location: Poland

Geronimo wrote:
Thanks, I was offered 1/4 refund since three slots still worked. I said no , so they are sending me a new one. Might try to open the faulty one up. No experience with this lol

That was my first dispute on AliEx but there was no chance for full refund they first offered 1/4 of price and after that weirdly offered 55% without returning device.
Anyway it seems to me this IC is simply faulty and with my knowledge of several internet parts shop not found any decent repacement so ordered 5 pieces from ebay.
Whole crash probably happened when my protected 18650 was in #2 slot, that was my first attempt of loading of anything to this charger.
Only saw screen get reset and after that only error was displayed on #2 slot no mater what was putted there.
I have friend here who has hot air station and is capable to replace this IC – like said before it can be tricky to replace it only with soldering iron because of LX drain PFET pad that is placed under sop8 package. I don’t want to risk doing this myself Smile
d_t_a
Offline
Last seen: 4 hours 33 min ago
Joined: 08/04/2017 - 23:58
Posts: 2266
Location: Manila, Philippines
lacrimal wrote:
Geronimo wrote:
Thanks, I was offered 1/4 refund since three slots still worked. I said no , so they are sending me a new one. Might try to open the faulty one up. No experience with this lol
That was my first dispute on AliEx but there was no chance for full refund they first offered 1/4 of price and after that weirdly offered 55% without returning device. Anyway it seems to me this IC is simply faulty and with my knowledge of several internet parts shop not found any decent repacement so ordered 5 pieces from ebay. Whole crash probably happened when my protected 18650 was in #2 slot, that was my first attempt of loading of anything to this charger. Only saw screen get reset and after that only error was displayed on #2 slot no mater what was putted there. I have friend here who has hot air station and is capable to replace this IC – like said before it can be tricky to replace it only with soldering iron because of LX drain PFET pad that is placed under sop8 package. I don’t want to risk doing this myself Smile

You described how the error happened — I was also charging several 18650s on the C4-12 (I was near the charger since I was still observing this new charger), then the screen reset, and slot #2 showed Error.

If you’re able to open it, can I ask to take a picture of what parts are needed to be replaced? Thanks!
I don’t have the skill or knowledge to replace, but in case I can find someone who may be able to do it..

lacrimal
Offline
Last seen: 10 months 3 weeks ago
Joined: 10/23/2019 - 11:58
Posts: 12
Location: Poland
d_t_a wrote:
If you’re able to open it, can I ask to take a picture of what parts are needed to be replaced? Thanks! I don’t have the skill or knowledge to replace, but in case I can find someone who may be able to do it..

I’m talking about IC in SOP-8 package placed on top of my picture from previous post. There are 4 of them each for different slot.
It is named ME3118A.

lacrimal
Offline
Last seen: 10 months 3 weeks ago
Joined: 10/23/2019 - 11:58
Posts: 12
Location: Poland

Hi,

Can confirm now – replacing ME3118A gives live to broken slot.

5pcs of ME3118A from ebay was about 5$, my colleague said 1$ for work but I gave him 5$ too Smile

spacemanspliff
Offline
Last seen: 3 weeks 3 days ago
Joined: 11/24/2017 - 06:14
Posts: 37

Very nice, thank you for the update! I have the same problem with slot #2 (got a 50% refund on banggood) so I’m gonna order the part and try to fix it too

hammerJoe
Offline
Last seen: 10 months 4 days ago
Joined: 02/12/2015 - 19:56
Posts: 150
Location: Canada

I bought a second miboxer c4-12 and swear to not buying anything from Miboxer anymore.

Their customer support is non existant, their reply contact the seller for a refund, we dont care that we made a faulty device and not going to do anything about it.

My first “upgraded c4-12” (the same one with two buttons) does not charge the batteries properly, stopping way too early and has display artifacts errors (basically the numbers get out of bounds and it displays gibberish and that would explain why it terminates too soon).
This was a V2 model.
I reported this to Miboxer customer support and got the usual response contact the seller for a refund we dont care attitude.
Contacted the seller and got a full refund and got to keep it but unless someone would know how to fix it its useless.

A few months have passed and I thought that they would have a new version of this model and I really like the features of it so I ordered a new one.
Got it and its V2.2 so I was excited to use it.

Put it a bunch of old cells that I have and quickly realized that this charger also doesnt work.
First it starts charging at 300mA and not 100mA like the older one.
Thats fine but a few minutes in it crashes completely (it looks like it gets stuck in some sort of loop because it just keeps switching thru the slots) and stops charging.
It also doesnt display FULL when its finished (I assume its finished because it says 100% and the current is 0)

Again I reported this to miboxer with video and got the same response as the previous one.
Contacted the seller to get a refund but this time I have to return the unit.

Heres a video of the issue : https://www.youtube.com/watch?v=G07lo5LVEKM&t=60s

Miboxer, Never again.

lacrimal
Offline
Last seen: 10 months 3 weeks ago
Joined: 10/23/2019 - 11:58
Posts: 12
Location: Poland

Hi, it is obviously huge bad luck, with some help from miboxer. I agree they have customers that buying their stuff on place where light does not come Smile They only honor their official shop.

Miboxer has so long history of several models repeating with same problems described on forums, that it appears likie some risk is involved in buying one.

Don’t know what my charger version is, where can I find is it v2 or v2.2? Second thought – did you tried to use manual charge or use different slot ? Is the same effect there ?

It could be really bad battery and charger start to be stupid trying to revive it. Some combination of parameters that programmer never predicted – looks like bug that should never happen.

hammerJoe
Offline
Last seen: 10 months 4 days ago
Joined: 02/12/2015 - 19:56
Posts: 150
Location: Canada

lacrimal wrote:
Hi, it is obviously huge bad luck, with some help from miboxer. I agree they have customers that buying their stuff on place where light does not come Smile They only honor their official shop.

Miboxer has so long history of several models repeating with same problems described on forums, that it appears likie some risk is involved in buying one.

Don’t know what my charger version is, where can I find is it v2 or v2.2? Second thought – did you tried to use manual charge or use different slot ? Is the same effect there ?

It could be really bad battery and charger start to be stupid trying to revive it. Some combination of parameters that programmer never predicted – looks like bug that should never happen.

Its still their product and they should show more concern that theres problems with it.
The only way to tell what version it is as far I know is by looking at the manual.

This happened in all the slots with all sorts of batteries. It only worked fine with fresh new batteries or with low internal resistance.
Anyway its going back.

klrman
klrman's picture
Offline
Last seen: 2 weeks 2 days ago
Joined: 11/07/2016 - 22:44
Posts: 2837
Location: Canada

snakebite wrote:
can it source any current through the cell in the error state? if it is trying to charge at 12v this could get ugly.

 

This would be one of those times that a protected cell would be a good idea so that it can trip if the charging voltage is too high.

lacrimal
Offline
Last seen: 10 months 3 weeks ago
Joined: 10/23/2019 - 11:58
Posts: 12
Location: Poland

hammerJoe wrote:

Its still their product and they should show more concern that theres problems with it.
The only way to tell what version it is as far I know is by looking at the manual.

This happened in all the slots with all sorts of batteries. It only worked fine with fresh new batteries or with low internal resistance.
Anyway its going back.


Mine manual is branded with V2 in the lower right corner so i thing we are talking about it.
Since you are returning it, you cant relay look inside to spot differences but according to your issue with it, it is going worse.
When opened mine for repairs – there is no any sign of quality check or something like that, maybe this is their weakness.
hammerJoe
Offline
Last seen: 10 months 4 days ago
Joined: 02/12/2015 - 19:56
Posts: 150
Location: Canada

I didnt open mine so I dont know what it looks like inside.

Miboxer told me that the fact that it didnt show the word ‘FULL’ when the cell was charged that it was faulty and to return it.
Have you noticed that with your V2 especially with NIMH that it doesnt really charge up to 1.50V? On my V2 it usually stops at around 1.38V.
Also it gets messed up with the IR numbers and just shows gibberish instead of numbers.

Mishanchik
Mishanchik's picture
Offline
Last seen: 1 week 1 day ago
Joined: 04/12/2019 - 17:23
Posts: 85
Location: Russia

Have you wiped the contacts of the charger and your cells with alcohol?

Pages