Anduril 2 lockout moonlight modes


starting from advanced stepped ramping mode and manual memory off:

stepped floor could be 1/150 (from strepped mode, use 7H from On, release at first flash, clic once, wait till it stops flashing)

smooth floor could be 10/150 (use 7H from On, release on first flash, clic 10x, wait till it stops flashing)

thats all

1H will give 1/150
2H will give 10/150

Thanks. But that sounds like an awful lot of needle faffing (or some other kind of effing) around. Why is it not set like this by default??? (I know it isn’t you who wrote it. But this seems like a major but of backwards thinking when it worked on the older version).

Oh and to reinforce this. Was out walking just a while back. I missed clicked and got the light in some odd unusable mode. I didn’t have instructions with me and could fix it. Apart from doing a tail cap reset. Which would mean any time spent doing 500 clicks setting up stuff that should work by default would be lost and would have been a total and utter waste of time setting up.

It’s a real shame. As in concept it probably isn’t a bad idea. Just ruined by being far too fragile and bug ridden.

it works on the new version too

the difference is that some lights ship with different floor defaults for smooth and stepped ramp… which is what your Anduril 1 light did

some Anduril 2 lights also ship with different floor defaults for smooth and stepped ramp, so they work the same on lockout as your Anduril 1 light

I dont know all the lights you have, nor their defaults, but apparently one of your anduril 2 lights uses the same default floor for both stepped and smooth ramp, so on lockout, 1H and 2H, are the same… you could enable manual memory to make 2H use that level from lockout… or you can insure your light has different floors

this is all part of the Anduril Optional features … Manufacturers dont know what Options you or I will prefer, so if they guess wrong, we can fine tune Anduril Options to our individual preferences

Anduril is very feature rich, but it does require clicking to adjust Options…

if youre not willing to read the manual and learn to use the Options… maybe Anduril is too complex for your preferences

Expecting a manufacturer to set the Options you like from factory, is simply not real world.

Here is a list of all the Options I customise on my TS10. The light does not come with this set of Options from factory:

Aux on Low when off
turn on in Advanced ramping
ramping speed option 3 (slower)
10 lumen manual memory
10 minute temporary memory (this is set by default)
simple smooth and stepped ramping floor at 1/150 = 0.01 lumens
advanced smooth ramping ceiling at 110/150 = 250 lumens
Advanced stepped 120/150 = 350 lumens
2C gives ceiling, no Turbo
thermal limit set to 50C (sustains about 330 lumens freestanding)

I do a Lot of clicking, and I use the Manual… it is just the way of Anduril… lol

well… clearly, Anduril Bugs you… suggest you step back to a light with a more basic UI…

Boy oh boy, so much whining from one who purchased an enthusiast flashlight and wants everything to be super simple…. Anduril is obviously a UI you should be avoiding.

This here is so simple to follow and yet it’s too much for you. Again, it’s a flashlight UI meant for those who enjoy lots of settings. Perhaps, you should go and watch a tutorial on YouTube, there’s an excellent video from Flashlight Enthusiasts.

You could just do a factory reset and then you should have two levels like you want. You’ve most likely changed a setting without realizing.

I have a Sofirn SP10 and an Emisar KR4 both running Anduril 2, both have 2 brightness levels in lockout. I don’t know why your light doesn’t.

What makes you think it’s an ill-thought out design choice?
I’ve read a fair few of ToyKeeper’s posts/threads over the last few years and backwards thinking is not something i associate with her.

This is the Anduril 2 thread in which she seeks feedback for the UI:

Even just the first couple of posts worth a read if you want to understand Anduril 2 and it’s creation a little better.

It would have, he’s obviously messed with the settings without realizing. In another thread with another Anduril model, he got it into a low mode and couldn’t figure out how to exit so he had to reset it. I don’t quite understand what mode that would be since turning it off and on would exit any of the blinky/utility modes.

I wanted to check this observation on my recently flashed to Anduril 2 Q8… and I am still seeing 4 SPOTS 8 hours later.
So on this light the 1H moonlight definitely is NOT the same level as 2H

Lol! I refuse to admit to the number of times i’ve seen those spots. It wasn’t me! :smiley:

I can see how that is an obvious possibility.

However, i have just got my SP10 to do the same by turning off manual memory, i now the same brightness for both 1H and 2H from lockout and i assume it’s because both stepped and ramping floors are the same brightness.
I don’t see a way to set separate floor levels for stepped and smooth ramping in simple UI though so manual memory would need to be set for 2 lockout mode brightnesses.

you do it from Advanced mode.

turn on the light and select either smooth or stepped ramp, using 3C, then turn the light off

now do 10H and let go at the first flash. clic one time and just wait for the light to finish flickering… done…

same for both smooth and stepped, from off in advanced, 10H lets you set the floor of that ramp style, for simple mode
(you need to be in advaned to set the level for simple)…

now the two floors you set for simple mode, will be what you get from lockout, after you do 10C from off to be back in simple mode

Thanks. That’s what i initially thought, and it works for Advanced UI, but when i change the Simple UI floor (using 10H from off in advanced UI) it changes the floor for both ramping modes at the same time regardless of whether i’m in stepped or smooth in either simple or advanced.

And, funny enough, i’m going to quote pretty much the same bit of TK’s manual that i just quoted in the ‘What did you mod today’ thread:

“For smooth ramping mode, there are three menu options:

1. Floor. (default = 1/150)
2. Ceiling. (default = 120/150)
3. Ramp speed. (default = 1, fastest speed)

For the stepped ramping mode, there are three menu options:

1. Floor. (default = 20/150)
2. Ceiling. (default = 120/150)
3. Number of steps. (default = 7)

For the Simple UI mode, there are four menu options. The first three
are the same as stepped ramping mode.

1. Floor. (default = 20/150)
2. Ceiling. (default = 120/150)
3. Number of steps. (default = 5)
4. Turbo style. (default = 0, no turbo)”

To me that reads as one set of settings for the Simple UI.
Just in case i’m misinterpreting that, and the SP10 is slightly different to standard Anduril 2, i’m going to try it on the KR4. But that’s downstairs and i’m upstairs so may take a while… :slight_smile:

> 4. Turbo style. (default = 0, no turbo)

thanks, I did not know that :wink:

FYI according to Toykeepers Anduril 2 manual smooth ramping should default to a floor of 1 and stepped should default to a floor of 20. If that is done, then out of the box, your lockout 1H and 2H would be different levels. That said I don’t believe any of my Anduril 2 lights actually shipped that way. I had to configure the stepped floor (which is easy enough, but I agree it isn’t intuitive that those two functions are identical out of the box).

He was probably in momentary mode (5C from ON). He should probably stick to the simple UI interface. That’s how I use Anduril 2, since I have no use for the fun blinky modes.

Yeah lots of complaining. Truth is op you did something to put it into that state. ALL my Andruil 2 lights do exactly what you are asking about right out the box. I’d do a factory reset and try again since you seem to be confused.

Every single Anduril 2 light I have from Emisar/Noctigon arrived with both floors set to 1. This includes 9A driver, 12A driver, dual channel driver, and boost driver. It appears to be universal among Hanks lights that they ship this way. So I wouldn’t jump all over this guy saying he caused it. If you order a light from Hank, you will have to configure your ramp floors or your lockout momentary modes will be identical.

I can honestly say the exact opposite. When was the last time you got a light?

D4K 12A driver like a week ago. Both ramps set to floor of 1. Previous was a D1 and two dual channel D4V2s. Both identical on all lights. The floors were both 1 on the D1, and while I’m not sure what the floors were set to on the dual channel D4s (somewhere in the 10-15 range I think) the smooth and stepped were identical. Before that it was a 12V KR1, before that a standard DM11, etc., etc. Everything I’ve ever ordered from Hank with Anduril 2 has the floors set the same for both ramps.

Edit: and perhaps I should clarify I’m talking about advanced mode. I’m not sure what the floors are on simple mode as I never use it myself and only configure it for use by friends which does not involve worrying about the floor.

Yes, Hank’s flashlights are set to identical floor mostly. You can see it in the configuration files.

Excuse me, could you get off your hobby horse please.

The issues is when RESET by DEFAULT this doesn’t work. So you are 100% wrong with your last comment.

The issue is present on two lights:

-Emisar D1 Mini
-Noctigon DM11

Having to do 20 clicks or so to program something that is clearly wrong is at best a poor workaround. Because if you do another reset all of this will be lost.

As an enthusiast, I think this is poor. As a professional software tester I think this is poor design. Maybe it is the implementation Hank is doing, I don’t know. But how the lights arrive (and they weren’t cheap!!!) they are not configured correctly and there seems to be no way to actually set them up in a way that doesn’t risk being nuked should you actually need to reset them.

Tell me, how is this not a backwards step?

My Noctigon KR1 using Anduril does not have this issue, nor to any of my Astrolux lights on the older Anduril.