Astrolux S41 switch problems

Hi all, hoping one of you more knowledgable people can help me out here….
I just got a brand new Astrolux S41 - put the extended tube on and a protected 18650 in, then put tailcap on, as I’m screwing it up no flashes nothing, when done completely up it doesn’t function.
When testing the switch with a multimeter it seems to function ok.
I have 2 spare illuminated switches from the A6 - both light up blue when screwing on the cap and the light flashes on briefly when I’m doing the cap up (if you get it just right you can go through modes etc), but again, when it’s done up it doesn’t work at all.
Next I try the tailcap from my BLF A6 - this flashes on/off when doing up - but it works fine when tightened up.
What is going on here? I have tried an unprotected battery and that didn’t work either.
I’m lost…… the springs all look the same length to me on all 3 - the only difference visually seems to be the double spring affair on the A6 switches.
Any help would be most appreciated, I love this little beauty!

Are you sure the tube is correctly inserted? There’s a correct position for the tube.

I assume you mean the extension tube? if so then I have the clip part at the back.
I think I may have found an issue - I have tried all 3 switches in both tailcaps, and still only the A6 tailcap will work.
I think the problem could have something to do with the brass retaining ring (holding switch in) it protrudes above the aluminium shelf (above the thread looking in cap), whereas on the A6 one it sits below that shelf .
Other than that I can see no reason at all why they all shouldn’t work.

If the lighted switch works, the electrical connection of the tube is alright.

When I say it works, it illuminates only when you are screwing the cap on, once it’s done up tight - nothing works, it’s as though the ‘doing it up tight’ is what causes the fault.

Ah, possibly still a tube not connecting, when screwing in a tailcap I often get some temporarily connection because of electrical leaks through the ano. You can try the paperclip trick to check for it (put paperclip inside tail, bended in a ring the size of the tube wall to extend the tube a bit).

Yes, I remember having to do that on another light I had - it’s not the end of the world, but it is pretty poor construction quality.
My only issue with using the A6 tailcap is that the A6 is a hard shiny anodising, on the S1 it’s a dull, matt one so they don’t really match…… typical!
I put a claim into Banggood , hopefully they may send me a new one.

Hum, that thing happened to me ! Can you check if it can be a washer (plastic or metal, between the tailcap and the switch) issue?
I had to replace several of mine because they were too tall and made the switch and the retaining protrude therefore hindering a correct connection on the end of the tube!

Hi, it’s plastic and I do suspect this is part of the issue. BUT it is not the washer that is too thick - I took 3 tailcaps (from A6 X6 and s41) all apart and the washers were all the same size (as were the brass threaded retaining rings) - the problem is shown in the photo below. The one on the left is the one that works - off my A6 - the brass ring is lower than the bare aluminium bit.
On the right, the S41 tailcap - you notice the brass ring is higher than the bare aluminium. I believe this is the problem. Basically that brass ring is screwing down on the battery. they took too much aluminium out during the manufacture? A copper ring of wire should solve it, or a thinner washer but it is not ideal.

Yeah it is a bit taller :frowning:

May I ask, did you put another rubber tailcap (not the original)?

On my Convoys S2+, I tried to used some Kaidomain tailcaps but the lower “rubber ring” (large stuff that sits on the tailcap interior) is taller than the original ones from Convoy, so it made the switch and retaining go up.
I had to use a knife to cut a bit of that rubber to make it go to the place.

Also, on other light (Sofirn SF10), I had to file a bit of the retaining ring below the driver because it was causing an external gap after tightening the tube. It worked well!
Maybe you can try to sand your ring (the inferior part) with a flat file! :+1:

Also, can it be the switch PCB that is too large? Maybe filling a bit on the sides can help it to go further in the tailcap!

Yes I tried a couple of different rubber caps (the S41 is quite small) and it made no difference. The PCB is the same thickness on all 3 switch boards. I think it will be easier to make a thinner plastic washer than to make the brass one thinner, though it may be the case I need to do both :person_facepalming: if the plastic washer is too thin the switch doesn’t function so well as there is no room for the switch to click back up properly like you found out.
The copper ring method is easiest, but you always end up dropping them somewhere you can’t find them! and it’s not really a permanent fix.
It is definitely this tailcap that is to blame as it won’t work on my A6 either, whereas the A6 cap works on both.

Does an unprotected flat top 18650 cell work? (as in shorter battery)

Did you thoroughly clean the extension tube ends and surfaces inside the tailcap? Try bending a ring of copper wire and inserting it into the tailcap. If it works, you could use an o-ring to hide any gap created.

No Robert, it makes no difference.

Yes, the copper ring is a last resort, but yes I may go that route until I get a new cap off Banggood, or a credit to buy one.
Very annoying little problem it is.