Berserk Flashlight - Help Please

I bought a Reylight Dawn 2.1 Copper from a seller here a month or so ago. At first it worked ok. But then it went berzerk. I'm looking for suggestion as to how to fix it. I love the light, but want to actually be able to use it.

So, here's what's happening. It's fully repeatable.

First, I take the battery out, charge it fully, and let the light sit without a battery for a day or two. Two days always works. I've used an IMREN flat top 18350, a Samsung 18350 30q, and now a MXJO 18650 3000mAh 35A IMR. Behavior is always the same independent of battery.

When I insert the battery, the light behaves fine: 5 levels including a very bright turbo. Click to turn on, then half presses to change brightness. Brightness steps up to turbo and then back down to low. Memory even works. Nice!

But after 3 - 5 cycles of working it goes berzerk. It's almost impossible to turn off. Half presses mostly don't change the brightness, but sometime the brightness goes up to perhaps the 3rd or 4th level. But mostly it stays at a low level no matter whether I half-press or click. Often, when at a very low level, the light flutters (not strobe, just fast changing levels of low brightness).

Then I take the battery out and repeat the steps above. Here's a couple videos I made of this behavior.

The following shorter video shows behavior with tapping (half presses).

Does it have this UI?

Programming Guide

1. Turn on the light.

2. Press the button 8+ times. The light will now blink once, then strobe, blink twice, then strobe, blink three times, then strobe…After 5 blinks and a strobe, the sequence repeats.

a. 1 blink: mode group selection. Press the button to enter this menu.

i. 1 blink: (ML)–2–20–100%

ii. 2nd blink: (ML)–10–40–100%

iii. 3rd blink: (ML)–2–10–50%

iv. 4th blink: (ML)–50–100-strobe-SOS

It then repeats. Press the button during any blink to select that mode group.

b. 2 blinks: mode memory on-off toggle (default off). Press the button during the two blinks or during the strobe after to turn mode memory on. Repeat to turn mode memory off.

c. 3 blinks: moonlight mode off-on toggle (default on). Press the button during the three blinks or during the strobe after to turn moonlight off. Repeat to turn moonlight on.

d. 4 blinks: mode order toggle (default LMH). Press the button during the four blinks or during the strobe after to change the mode order from Low Medium High to High Medium Low. Repeat to reverse the order.

e. 5 blinks: factory reset. Press the button during the five blinks or during the strobe after to reset the light to factory settings.

Shorcut: quick double tap to turbo.

Otherwise, please try to tighten the retaining ring to ensure optimal contact.

Thanks. I appreciate your reply. Yes I believe it does have this Bistro UI. But I have had a hard time getting into it. I did tighten the retaining ring in the pill as best I could with tweezers. It did seem to move slightly. But that did not fix the problem.

Any other ideas?

Is there a good tool available for tightening the ring? I might be able to take it further if I had a better Tool than just tweezers.

Look for snap ring pliers are your local/favorite hardware store

I had a similar problem with the astrolux S43. I was never able to figure it out. Put it on ebay and the buyer figured it out in a minute.

Do you know what he did to fix it?

Did you manage to tighten the switch assembly as well?

I don’t see any way to tighten that. With the pill, there are two notches on either side that I can use to tighten it. I don’t see anything like that with the switch.

I am not familiar with this light. And I have only watched a minute of the 1st video.
but if its running Bistro UI.

I think you have a bad switch. Or power getting around the switch.

Edit— Just made a video of how to bypass the switch. Slow upload.
Will post asap

Interesting video. Thanks. Strangely, after so very many failures, at the moment, the light is behaving fine. Once it starts misbehaving, I'll try this bypass to test the switch.

Any damage on the cell wrappers?

All 3 are new and fine. Even tried short tube and new 18350.

Does it have a tail cap ? If so there is an easier way to bypass the switch lol.

The switch is in the tail cap as you can see here.

For me it looks like a broken switch. Could be due to arc in the contacts that partially welds the contacts.
I had a similar problem on a modded tail clicky. The old switch just could not handle the new LED’s amps and had to be raplaced with some better quality.
As a tool I recommend a V-type lens opener.

I believe those notches around the + in the tail cap is your retaining ring. Loosening that up all the way will get your switch out if you end up needing a new one. I think that ring will be kinda stiff at first making you think it won’t come loose. There is a oring in there that makes it feel that way. Make sure you have a good fitting tool for it so you don’t scratch that nice light. Snugging it down real good might fix your problem as well.

For a retaining ring tool I use to use, before I bought a tool, was electrical wiring staples. I’d bend them and grind them so they were a perfect fit, then grab the top with a pair of vise grips and twist away. Worked every time.

Thanks. I just ordered one V-type lens opener from Amazon. Much appreciated!