Booting Puppy Linux on a MK-802

This is a continuation of my previous thread here.

My basic plan is to install some form of linux, most likely puppy linux, and then use that to connect to the printer. I will then install chromium and then use the share printers function to link them to my google account.

So I have two of the MK-802s in hand and now I'm trying to figure out how to get linux on them. I have heard that both Lubuntu and Puppy Linux should work on these things and I have tried both by burning the iso to a micro sd card, but both times it just booted up into the normal android 4.0 OS.

Anyone have any ideas of what I'm doing wrong?

Did you see this page:

Ubuntu Linux on MK-802

You said you used an ISO, could it have been a standard x86 boot ISO, instead of one for MK-802 architecture? I don’t have one yet, but I’ve been thinking of getting one to play with. I’m subscribing to see how you do with it.

I'm pretty sure it was one meant for the A10 chip, but I'm downloading the one from that article now to try.

The author of that page said that he had to dink with his a bit… removing and re-inserting the micro SD card, power cycling the MK-802, etc. before it successfully booted into Ubuntu. Odd.

This version is meant for the A10 SoC and therefore for the version 1 of the MK802, which SoC do you have?

I believe you will find a detailed guide here.
I have already ordered a MK802 IIIS and I can’t wait.

I got the MK802 II, and so far I don't see any guides there for linux on that one. :(

This might help

OK this should work. Run Puppy on another machine and then use the installer it has in it. There is an option for all sorts of media. Install it to what you want. Doing that will make that media bootable. If that doesn’t work then someone on this forum will be able to help.

BTW, I love Puppy and it is on, and bootable from, my EDC pendrive.

Ok, I tested all of the different Lubuntu versions from this article.

I'm testing out creating a bootable disk within puppy linux now.

Ok, puppy linux is a no go. :( Anyone have any ideas?

“Anyone have any ideas?”

The forum I suggested certainly wiil. They’re a great bunch.

And it CAN be done. Here’s Puppy running on an MK802.

How about dsl (damn small linux)?

Ok, just tried another build meant specifically for these which also didn't work. :( I'm gonna register on that forum now and ask.

what about picuntu

btw. I have just received IMITO MX1 last week :slight_smile:

Ok, just posted on that forum asking for help. :)

I just found this page. It may help.

What kind of evil person boots poor little puppies?

Just tired Puppi Sap which also didn't work, it just booted straight into android. :(

What utility are you using to write the image file to your Micro SD card? If you put the card back into your regular computer, what do see on it?

Here’s my ideas, with what I consider the most likely explanations first:

- problem with writing the image to the card (maybe try a different image writing program)

- corrupted image (check md5sum/sha256sum)

- booting from SD disabled somehow in firmware (?)

  • hardware problem with the MK-802 card slot