Convoy C11 with familiar problem

I was going to post this in the 26650 section but I don’t believe the battery has relevance to my problem. I apologize ahead of time if I’m wrong!

I bought a new factory finished Convoy S11 and have had a problem with it from day 1. I’ve read about this issue with this light on this forum and other forums, as well as the Convoy store itself under customer feedback (for it’s driver).

The S11/xhp70.2 comes standard with Convoy’s own 22mm, 6v, 4.8amp single cell driver. It has 4 modes with mode 4 being high/turbo. This is also the only mode that doesn’t work. Whenever you switch the light to high/turbo, it briefly flashes for a second before dropping down to mode 1. It does this 100% of the time. It’s definitely not thermal related. My first thoughts tell me it’s either a programming issue or a driver glitch. I’ve read and followed the instructions to change the different groups but can’t seem to get it right.

Before I go spending extra money on my brand new light, I thought I‘d check here first for some thoughts and opinions.

I’m using a brand new Orbtronic 5500mah, 15amp max constant current discharge cell.


Just a guess: maybe an issue with current path, it can’t draw as much current as it needs because resistance is too high, so it thinks that battery is empty and reduces output. Try tightening retaining rings. Is the battery protected? Try high drain unprotected battery.

I was going to say this, too!

Most of the times a flashlight of mine can’t deliver proper max output it is due to battery protection!

Presto! I put in one of these bad boys with a spring bypass wire and it did the trick! I’m really glad I didn’t have to buy more batteries at this time.

I’m a bit skeptical about using unprotected cells. I guess I would consider them for use in a single cell light, but I’m gonna stick with protected cells for multi-cell applications. If I use a high drain, unprotected cell with a much higher amp rating, will my light be brighter plus, will my run time be affected?

As long as the multi cells are in parallel, , instead of series, no problem using un-protected.

I had protected batteries and ended up taking the protection off of them since I only have single cell lights or multiple cell lights that are in parallel (BLF Q8 and lantern). I decided they were more trouble than they were worth (not that I ever had any issues with them) and just represented another possible failure point in running my lights.

I’m surprised the 20mm switch you linked from MTN worked since it appears the S11 uses the normal 16mm switch. Maybe you have an older model?

Impossible to say without having one to exam. With protected batteries it’s obvious how to remove the circuity and it only takes a few minutes to do so. With the Olight I’d probably start by seeing if the top can be gently pried up some to see what’s underneath, but I’d do it outdoors with the battery discharged as much as possible.

My guess is that if the top can be safely removed then all you’ll find is a normal battery below it.

My C11 came with a 20mm switch board. Possibly because it’s using a 6v emitter?

Not to switch the subject, but…does anyone know how to loosen a crazy tight retaining ring? I’ve already tried needle-nose pliers but they wouldn’t even budge it!

Never mind. I learned something new today. The threads on my c8+ tail cap are revered! It’s all good!