Dr Jones RGBW F6 Driver Problem Solving

Hello Friends!
I have a beautiful driver from dr jones that I may have ruined. However, if I can find the component that is not behaving, maybe I can salvage the driver. You can refer to my posts in this topic about how I shorted out and drained a cell while installing this driver.

I don’t know where to start the problem solving process so I will post some voltage measurements from different points on the driver. Now these measurements are taken after hooking up a power supply and they are the SAME no matter what I do with the switch. There is no light output from any die on the emitter. All dies light up when connected directly to the power supply. Take note of the voltage readings at the red die. I would think that 2.4 volts would partially light up the red die but idk. Either way it does not light up.

Here are the voltage readings:
Voltage to the emitter from B-,
R= 2.46
G= 2.13
B= 1.87

voltage across the emitter
R= 1.4
G= 1.2
B= .7
W= null(voltage jumps all over the place)

Voltage accross the amc7135(input pin to output pin)
R= 2.36
G= 1.97
B= 1.78

Edit: Voltage across the diode is 210mv
Edit: The capacitance of the capacitor connected to the diode measures 10.9 μF in circuit

I’m not sure what else I can measure or even what these numbers mean but maybe someone can help me? It would be wonderful if dr jones would look over these numbers and give some instruction, but idk if he will read this or not :wink:

Oh ya… And is there a schematic of this driver out there anywhere?

  • With a DMM it’s difficult to tell if there is PWM or a continuous voltage.
  • Please post detailed pictures.
  • Please measure the voltage between MCU Vcc and GND.
  • If this driver uses 7135s then it’s low-side controlled and measuring LEDs against BAT- (GND) does not make sense.

I’ll check that voltage right now. It is based on amc7135s

I havnt been able to post pictures since the site upgrade. If you know why let me know. I will post a link though

Now these measurements are the same whether I push the switch after applying power or not.
.8volts from Vcc to gnd
Never mind that it’s 3.7volts

Volts from gnd
pin1 - 3.48
pin2- 0
Pin3- 0
Pin4- 0
Pin5- 3.7
Pin6- 0
Pin7- 0
Pin8- 0

Tests for continuity
Only pin 4 is connected to gnd
When testing for continuity to ground pins 2,6,7,8 causes the die to faintly light up.


So I guess the attiny is stuck open giving minimal voltage to each die of the led even without needing to “turn it on”. I think I may have fried the MCU! Man!!! Losing Dr jones firmware is like waiting 6 months to find out your not going to Hawaii on a family vacation; your parents were joking. }:slight_smile:

The attiny only applies voltage to turn the 7135s on. They work like relays. Apply voltage to the Vdd pin, and the OUT & GND pins automagically get connected. Battery+ is always applied to the LED+ even when the light is off. When the 7135 is turned on, current can flow to ground and the LED lights up.

Jump B+ to the Vdd pin on each 7135. I would use a lower than normal voltage for testing - a 3v CR123 works well for this. You just want to see at least some part of the circuit work like it’s supposed to.

This is pretty difficult to diagnose without a block diagram.

There is a voltage drop accross the amc7135(input pin to output pin)
R= 2.36
G= 1.97
B= 1.78

There is also a voltage at the emitter negative pads
Voltage to the emitter from B-,
R= 2.46
G= 2.13
B= 1.87

is that normal to have voltage drop across the amcs when the light isn’t turned on?
I measured the voltage on the pwm pins from another driver and when it is turned off the pwm pin reads zero. On my driver there is full voltage going to the amcs at all times but there isn’t any current moving through. That seems to be the problem. There is voltage, but no current.

What do you think?

Voltage applied to the VDD pin lights it up nice and bright

“full voltage going to the amcs” is sorta like saying “this shade of blue weighs 1.3 miles.”

There are 3 pins on a 7135, where are you measuring?

Look at the 7135 with the tab at the top, 3 legs at the bottom.
The middle leg and the tab are ground/B-. Called ‘GND’.
Left leg is called ‘OUT’, this goes to LED~~. If you have battery connected but LEDs off, you will measure battery voltage, minus the drop through the LED (it’s just a diode), between B~~ and OUT.
Right leg is ‘Vdd’, this is the control pin. If the MCU is off, you should measure zero volts between Vdd and GND.

If you jumper B+ to Vdd, the 7135 should turn on and the LED die that uses that bank of 7135s should light up.

Sorry, it may not have sounded like it, but I know the workings of the 7135.
So I connected a voltage to the Vdd pin for each of rgbw and all the dies light up.
The voltage between Vdd and gnd is zero. Does this simply mean the mcu will not turn on by responding to the switch?

pin2- White 7135
pin4- gnd
pin6- Red 7135
pin7- Green 7135
pin8- Blue 7135

It doesn’t “mean” anything. You’ve taken measurements and done tests. You now know exactly the results of those tests. The 7135s appear to work, the LED dies appear to work. The MCU appears to be getting the right input voltage.

The MCU appears to not be turning on the 7135s for some reason. Is it due to the MCU being fried? Software has gone crazy (EEPROM corruption maybe?)? Button doesn’t work? We just can’t say for sure. All we know is what you’ve specifically tested for so far.

Another thing to try is jumping the MCU pin for the button to GND or whatever the button normally hooks that pin up to.

Thanks for your help.
Shorting the switch pin(1or3 i think. Tried them both) to gnd doesn’t turn it on either.

I will continue to try and post as much info as a can and maybe some of it will be relevant.

I’ve been trying to think of what could have happened. These are the things I can think of.

  1. Heat from the battery shorting out could have damaged the mcu(I don’t know how sensitive they are)
  2. The firmware never worked in the first place(I doubt it, dr jones is good at those things and I’m sure he tests them before shipping)
  3. An electrical surge from the battery short damaged the mcu
  4. A simple answer that I have overlooked.

Sorry for derail the topic.
Just notice in this thread, really glad to see you back!

2. is possible; I might have simply forgotten to flash the firmware. That’s rare, but it happened once, it may happen twice.
1 & 3 may be, the incident emptied the whole cell in 30s, some ugly things may have happened.

Maybe you can swap in the MCU from the previously sent driver that was damaged by the mail service?

Why didn’t I think of that? I kept the parts from that driver and it didn’t cross my mind that the mcu is still flashed with your firmware. At this point swapping the mcu is probably what I need to do. I will have to hand solder it. I’ve not yet done that. Hopefully I don’t turn it into a junk yard of components:) I’ll let you know when I attempt this and how it goes.

If anyone still has an idea how to salvage or test the mcu of the driver I ruined, please let me know.

Is there a way to tell if the mcu is flashed or not. If so, it would be good for me to check before I mess with it. I have all of the hardware required to flash drivers myself so I could connect the clip and sub programmer to chech. HOWEVER, I have not yet learned how to do it. Maybe now is the time for me to learn. Anyway… Thanks to everyone who has replied to this thread!

  • Yes, I believe so. If the lock/protection bit(s) are set then DrJones has flashed something onto that MCU. If a mistake was made it could have been either no firmware or the wrong firmware; so just because the MCU was flashed doesn’t mean that it should work. An empty chip should look different from a programmed chip when attempting to dump. I have no personal experience with dumping these chips (only flashing them), but see here for some information: AVR Basics: Reading (and writing) flash contents | Evil Mad Scientist Laboratories
  • Personally I think you’ve already done all the testing you need to at this point. The driver does not function and DrJones has suggested an MCU swap using an MCU you already have… so that’s probably a good next step.
  • Personally I do not think that a shorted battery in the body of the light would normally damage a driver like this one. A mistake sounds like a good explanation, or maybe corruption of the memory if the DrJones firmware depends on that.
  • If it helps, here are two videos I made of stripping and assembling drivers: wight -
    iPhone ready - Nanjg stripping and A17DD-SO8 building videos