Emisar D4V2 Flash Kit Instructions (Official How To)

Good to know. Yeah, ZFlasher is great and Emisar flash kit makes it easy for D4v2 & D4Sv2, D4S will be a bit different and I think I’ll leave the D4 for now. Got the flash fever and some bits from AE, including

Programmer Testing Clip SOP8 SOP SOIC 8 SOIC8 DIP8 DIP 8 Pin IC Test Clamp

I received my first Hank lights today from Fedex. The first thing I have to say is that the pictures on the internet are deceiving. These things are much smaller than I thought they would be, and I say that in a good way.
These are little powerhouses. The build quality on these lights are excellent. The 3 lights I bought are:

Noctigon K1 Thrower, Green with OSRAM W1 Green
Emisar DT8, Dark Grey with SST-20 4000k 95CRI
Emisar D4SV2, Dark Grey W2 6000K

The DT8 came with Anduril 2, the other 2 came with Anduril 1. Using the Usbasp adapter and avrdude, I was able to update all 3 to the latest 12/13/21 builds of Anduril 2. The only issue I had was finding the right amount of pressure to apply to the pogo pins, If I pushed just a bit too much, it would lose connection, so I had to just push it enough to seat the pins and no more, and it was able to flash and verify.

A big Thank You to all in this thread for answers to all the questions I didn’t have to ask.


Hi All,

This is my first post and I'm new to this... please be gentle.

I recently purchased a tint ramping D4V2 Ti Colorful from Hank based on E21A emitters and tried to flash a new firmware to the light. It has the purple PCB.

Unfortunately I must have picked the wrong firmware as my AUX leds no longer respond to commands and the button back-light no longer lights up.

Can someone please direct me to the appropriate firmware to get this working again? Apologies for the n00b question and appreciate any help you can afford me.



Thanks for your comment. Unfortunately this firmware doesn't work for me. After I flash it, the AUX leds automatically cycle through the colors, but the button light doesn't light up, nor do the main leds light up when pressing the button...

Did you happen to note the code it blinked out when you first got the light?

Edit: my guess would be anduril.2021-12-13.noctigon-kr4-tintramp.hex 2021-12-13 16:01 28K


Try this one: Link removed (see edit 2)


EDIT: Just gonna leave this here for reference..


also.. KR4 does not have a Button/Indicator LED, thus the KR4 .hex will follow suit (in other words, no Button LED for you)

EDIT 2: disregard the first 2 pictures - as I do not yet have a tint ramping light, I have wrongfully understood the configuration

Link: D4V2 Tint Ramping Button LED Fix

The KR4 hex is the correct hex to use if your light has one of the CC regulated drivers (non AMC 7135). The aux LEDs cycling through colors is the default mode after a factory reset.

Since you have a tint ramping light, you need the following hex:

Try cfg-noctigon-kr4-tintramp.h and comment out #undef USE_BUTTON_LED ?

Thank you everyone for your help and suggestions. I tried all the above but I still couldn't get the light to work. I did, however, manage to get it to finally turn on with anduril.2021-12-13.noctigon-k9.3-tintramp-nofet.hex! I'll test the light with this firmware for now... just happy I can use the flashlight again.

The correct firmware is emisar-d4sv2-tintramp:

I’d be very careful with the K9.3 firmware. I don’t know if the driver physically has the direct-drive FET channel (using the same FET as for the linear regulation), but that would instantly kill your delicate LEDs.

I still don’t know where you’ve mentioned that it’s a tintramping version. There is also a MODELS list that will help you finding the right firmware if you know the version code. Also a PRODUCTS list with a mapping between flashlights and their firmware, but not updated yet:

Thanks so much for the warning and firmware suggestion. The one you've suggested works like a charm! All functionality is back and I'm grateful for your and everyone's help.

In his first post: “I recently purchased a tint ramping D4V2 Ti Colorful”

I have a D4SV2 that came with noctigon-k9.3-nofet firmware (emitters are SW45 and SW35 combo, single channel). Sometimes (often?) it can be a challenge to know which firmware to flash on a new light. At least to me.

I don’t know if the OP responded to my question as to what firmware the light blinked out when he got it. I haven’t seen a response to that yet.

Edit: BTW, TK made a nice change in the December A2 firmware release where in lockout mode, 3C goes to OFF (vs 4C going to ON).

I need to confirm I am picking the right firmware for each of my D4v2 lights:

1. Neutral White - SST20 4000K 95CRI
2. Neutral White - XP-L HI V3 3A, 5000K
3. Neutral White - XP-L HI V3 3A, 5000K
4. SST-20 Deep Red, 660nm
5. E21A, R9080 Warm White, 2700K - http://toykeeper.net/torches/fsm/anduril2/anduril.2021-12-13.emisar-d4v2-nofet.hex

Big Hanklight Anduril 2 Updates! [Ultralow Functionality] - YouTube says:

1. E21A -> NoFET -> emisar-d4v2-nofet.hex
2. 219 -> (I don’t have any of these) -> emisar-d4v2-219.hex
3. “Everything else” -> emisar-d4v2.hex

So, I think, for my 5 models listed above, I need the nofet for my E21A and the regular anduril.2021-12-13.emisar-d4v2.hex for everything else—is that correct?

The D4v2 firmware is for the original FET+1 driver. If you have the regulated CC driver (like the E21A version) you need to use the KR4 hex.

If you do 15C you will enter version check which will provide you with a date and a 4 digit code. That code will tell you exactly which hex to use. Refer to this document to look up the model codes.

I just got this same issue on my D4V2. Is there any fix available?

Hmmm. Remove the driver and try flashing the mcu with a clip?

I’m not familiar with how to remove a D4V2 driver; do I need to desolder the leads on the LED side?

EDIT: never mind, just realized that the microcontroller is on the back of the chip. Unfortunately I don’t have a SOIC clip that will fit on to a square chip.

I am not familiar with it either, but yes, removal often requires soldering skills though sometimes the wires are long enough to just make it awkward.

No idea if that is the solution, but it would be next on my list of problem resolution.

I hope something eorks. You could also email Hank about what has happened.

Removing the driver on an Emisar light is not really fun. Desolder all six or seven (!) tiny wires from the MCPCB (main LED or CH1/CH1 + GND, aux RGB/GND), desolder the switch (if it’s lighted, again several wires), then remove the driver with force because it’s glued in.

The flashing pads are directly connected to the MCU. So if they don’t work, direct access to the MCU won’t help you.

What exactly are the errors? Which command did you execute? Which version of the flashlight do you have?