Flickering issue


I have been reading the forums for quite some time and due to the info you all provided I decided to attempt my first custom build. I ordered the following from MTN electronics:

22mm MTN-MAX 1A-6A Buck Driver - 5V-18V

  • Driver Program: MTN-MAX Standard
  • Inductor Type: Coilcraft
  • Input Voltage: 2S (~8.4V)
  • LED Type: 6V (5A Max)
  • LVP: ~6V Ramp
  • Memory: Yes
  • Output Current: 4A
  • Turbo Timer: No 22MM-MTN-MAX

Cree XHP70 N4 1C on 16mm / 20mm Sinkpad MCPCB

  • XHP MCPCB: 6V - 20mm XHP70-N4-1C

After installing into the proper host I noticed that during moonlight or any more for that matter(moonlight being the most noticable) it flickers allot… and it is not a steady stream of the same power. The higher the mode the less noticeable it is, im using the panasonic 3400 18650 unprotected cells which have worked for me perfectly in the past and I have tried different ones but the result is the same. Does anyone have any idea what this could possible be? Maybe incorrect soldering to pill or LED somehow? Thanks for your help!

It looks more like a driver with defect (PWM issues). Second could be weak ground wire (- wire)

I have a couple of lights that will loose tension on the tailcap switch board during a battery change and will do this until I tighten the retaining ring. When they draw a lot of juice, all of the connections become very important. I would look to make sure that the tailcap and driver ground rings are making great, not good contact and then start to look for other issues.

bad ground contact
try tightening retaining ring or stuff some wires in between retaining ring to tighten even more
Maybe your unprotected cell is short and didn’t give enough spring tension? Add some spacer to see if it fixed this problem? Change to a stiffer spring?
Try cleaning your contacts as well.
if none of these worked, sometimes it’s the switch internal spring itself is losing tension or got dirty. Try cleaning that too.

I had lots of these problems on my wf502b p60 hosts where it just flickers and usually my switch is the main culprit rather than retaining rings lol.