Flickering of my Convoy S2+

Hi guys.
For quite some time, my Convoy S2+ from 2016 has started to flicker, turn off or emit brightnesses that aren’t intended by the modes (for example not actually reaching maximum brightness on the highest mode). This mostly occurs when the flashlight is introduced to cold air and it can be induced with certainty when I apply pressure on the front part of the tube (near the LED circuit board) with my fingers.
I suspect that the connection between the middle tube and the tube that contains the LED circuit board is impaired. That’s why I tried cleaning the bare metal and also tried to remove possible oxide layers with a piece of sand paper. But it didn’t really help.

I’m open for suggestions. Thank you in advance,


You may want to begin with a review of this recent thread for troubleshooting ideas:

I think I solved the problem!
Weeks ago when I looked into those threads and tried to fix my convoy I just tried to fix the ring on the switch side. It was rock solid, no chance to move it even with the perfect tools. But the ring on the LED side is also moveable, even if the holes don’t seem to be as obvious as the ones in the switch side. The ring on the LED side was so loose that I could fix it by just using some tweezers.

Thank you really much for not making me ignore the details of those threads again!

Excellent! Sounds exactly like the issue I had with one of mine.