FW3A Troubleshooting / FAQ

I forgot they added those at some point. I wonder if CheapThrills light needed those solder blobs to space the switch away from the nubbin, but his weren’t there. Kinda like a factory part mix up. Hmmm.

Does it seem like the nubbin is now too short? I’ve seen people make new ones, they hammer a little tube into a piece of plastic and out pops a new nubbin.

Thanks for your input. I don’t have a dmm right now, although I have been meaning to buy a new one. I guess I’ll be getting in touch with Neal.

Unrelated to previous question: For Turbo, does the FSM/Anduril pull up all three output pins (1x7135, 7x7135 AND FET) or just FET? And will it have a difference in output?

Anduril uses just the FET. If all 3 channels do 100%, output actually drops a little.

What is FSM?

Freedom Spaghetti Monster E-switch UI Development / FSM

Ok, what am I missing? I added Neal’s deep carry clip, I get the flash, but then it won’t turn on. Multiple lights exact same symptoms.

Clip is flush, tail cap seems tight, but poor clearance with side of clip.

Thanks in advance.

Oh, it’s a UI toolkit called Spaghetti Monster, or FSM for short by Toykeeper.

Is the head loose, then fully tighten tail cap, then tighten head?

The inner tube might not be making contact.

I had a similar issue, if you mean 2-way clip as deep carry clip. The deep carry clip that I got was thicker than the original clip. The ring part that goes between the body and the tailcap. With the deep carry clip on, the light would not turn on, or sometime strobe in low mode when the tail switch is held down. I believe the thickness cause the light to not make proper internal contact.

I resolved the problem and made the light functions as normal by just sanding down the thickness of the deep carry clip. I had some coarse grit sandpaper. I sanded the bottom side of the clip down little at a time and test fitting it until the light function. The sanding took off about half the material of the clip.

I brought two deep carry clips from Neal. One works fine with my FW1A. The other needed thickness modification for it to work on my FW3A. The white o-ring just prevent the clip from spinning, I don’t think it really need it to function properly.

No, I could not see any solder, that should not be there. Good point though.

Cutting the rubber: I don´t recommend - not good touch/feel anymore but I had to get it working somehow.

Thanls for a good answer!

The “1% strobish thing” is not the double blink.
It goes on only when I press the button and only as long as I press. Light in Lumens is far weaker than in lowest-low mode.

I think too the nub was pressing too early the clicky-switch, but then again, cutting down the nub did not help.

I removed the 2-way clip AFAIK about 3 times and tried normal clip without any help.
Since the tailcao interiors are loose, I did the assembly like you adviced. I also tried to press the rubber to correct place before insertin clicky-circuitboard.

Parts look 99% like in your picture.

BTW: clicky switch was working perfectly when I skipped rubber + SS-button parts and assembled it like so :smiley:

All in all, I would GUESS that the rubber part is slightly too large but I´m not exactly certain where.

To end it nicely: I did installed the 2-way clip to my other FW3A (thats the one I use at work) without any issues. I did all just like with the first one :crown:

Anyway. If there will be a second version or some of the design is used in upcoming lights, maybe there could be alternative ways to construct the clicky.

Still waiting… Going to hold off on ordering anything else from them until this is resolved. Sad, because I am interested in ordering about 6 lights right now for Christmas. :frowning:

Okay, I know what your talking about. The leds blink constantly very weakly. I saw it on mine once. I think it happens when the tail cap is not tight enough. If your clip was just a tiny bit too thick it might have prevented it from getting tight enough.

So I’ve spent the time and money, replaced one bad XPL HI, Replaced all of the 7135s on the driver, was a waste of time and money. No change, Only thing left is MCU?

Sure hope Neal does what he said he would! About ready to launch this thing! My patience with this particular light is definitely being tested!

Wow, there is not much left. There is the FET, but it’s only active at very high brightness levels. Maybe it is MCU related. You don’t hear about many issues with the Atiny85.

Your issue is one of the strangest I’ve heard.

Got an FW3T polished on Friday. Lasted 2 days before it broke.

The light broke a few minutes after I swapped in a different optic. The problem was that while fully assembled and not being touched it abruptly turned on in max and wouldn’t respond to the button.

I tried swapping the driver with one from an FW3A, thinking maybe a 7135 chip had gone. But that didn’t fix the problem. I also tried swapping in a different body tube and switch. Again no luck.

Further testing revealed that that the negative driver wire pad on the driver is shorting to ground. It’s not the bondwire being soldered incorrectly either since the short happens even with the star outside the driver and no bondwires attached. I think there are 2 possibilities:

  • bad solder under one of the LEDs shorting negative contact to the central heatsink pad; or
  • mask under the negative driverwire pad is somehow damaged and punching all the way through to the copper base.

My guess is the first possibility is more likely. Should be easy to tell which is the problem by removing the star and removing the LEDs from it and seeing if I still get the short.

I figure I should be able to fix either option. But if its the second, I’ll need to swap in a new star and cut some copper sheet to go under it. The Ti head FW3T has a much thinner shelf than the FW3A and a much thicker copper star.

I’m not sure why this short abruptly appeared when the light wasn’t even on. Seems like the kind of thing that should have been present from the start.

Wait, so the Titanium version has a new, thicker mcpcb than all the previous FW3A lights?

Wraithpc’s light is this model. Maybe there is some type of issue with this new mcpcb. His problem is still pretty strange.

I don’t think an insulation defect separating the layers on the mcpcb would cause his type of problems, or would it? I’m not sure. It’s something to think about.

If anyone has the correct firmware in a ready to program format for my light I’ll replace the MCU. Programmer and new Tiny 85 at ready.

The flickering at lowest levels is still present, and the light does not seem to be working at moonlight levels. If I set the light at or near its lowest level (slightly above moonlight) it works and I can turn it back on with a single click.

If I allow ramping beyond that minimum point it turns off completely, and will not turn back on with a single press. At this point the only way to get it to turn back on is with a double click, or press and hold which bypasses moonlight and starts to immediately ramp up somewhere above moonlight.

Maybe a bad circuit board/trace to one or more 7135s? I’ve inspected solder connections/board with a jewelers loupe and all looks OK, but who knows.

Since it seemed to initially work fine something failed, not a lot left for possible failures , Maybe MCU, and PCB.

With the negative pad on the star shorting to ground, the result is the driver is bypassed completely. So the second the head is screwed on partially it turns on in turbo.

My guess is it somehow got hot enough while on to melt the solder on the star. With the new optic I had put on, this caused an LED to press more firmly into the star. With a bit too much solder present, the solder squished sideways and caused a short.

I’m not sure why this triggered when the light was off, but it must have been very close. No way to tell for sure what the problem is until I get enough time to disassemble it and remove the LEDs tonight.

If my guess is correct, it may mean that the titanium head simply isn’t a good choice for the FW3A if you plan to run it on turbo.