HELP! Eagletac D25A won't turn-on with niMh

Hi guys,

My ET D25A is rated both AA and 14500 cells. I have used it initially with an AA niMh and eventually with the 14500 for months.

Now I tested it back with a fully-charged AA niMh and it does not turn on anymore, but does when I put back the 14500.

It has happened to my Xtar WK50 (edit: WK41) too. (initially working with an AA niMh and eventually with the 14500 but will not work when the niMh is used again, but was gifted away.)

Has this happened to any of you? Is there something wrong with my light?

I have the XML2 version.

My only thought would be that the spring has compressed due to the added length of the 14500 (assuming of course the ones you use are significantly longer than an Eneloop).

I’d try unscrewing the tail portion and checking out the spring… or adding a magnet or two to the back of a Nimh to see if its a contact issue

The 14500 cell that I use is a flat-top Sanyo, with a little solder blob on the (+) side so it can make contact with the ET’s head. They are literally the same length with my Eneloop or Duracell.

Is it possible that the higher voltage of the 14500 has altered the light’s electronics as to no longer ‘accept’ the niMh’s lower nominal voltage? As I said in the op, it has happened to my WK50, and now to the D25A.

Edit: WK41, not the WK50

The Xtar WK50 is rated for 0.9-1.8 Volts - so alkaline or NiMH only!
The moment you put in a 14500 into your WK50, you were simply lucky, the driver toasted to DD (direct drive) mode and not to completely burnt. The boost part of the driver is burnt forever - so 14500 only.

What happened to the Eagletac D25A?
Well, from it’s data sheet it is also rated for 0.8-1.5 volts only and 14500 should only be used for short bursts. I think, it’s toasted also… :?

I've certainly heard of that happening with cheaper lights such as some of the SK68 clones for instance but I would have expected better from Eagletac.

Have you contacted the seller or Eagletac? Or does return freight make sending it back for repair/replace uneconomical?

EDIT: As mentioned above, officially rated for NiMH only and not 14500 despite what is "advised" on data sheet. Not a proper buck/boost driver such as found in lights like the 4sevens Quark and others that fully support both chemistries. Sounds like you've fried the driver?

Do you still have any modes on a 14500?

Yes, all modes are working normally with the 14500, it’s my edc light and used almost everyday for almost a year already, and l just found out now that it won’t work with AA anymore.

I just edited my op. I checked my payment records and that light I was referring to is not the WK50 but the WK41, clearly AA/14500:
(Now I remember, the WK50 that I bought was a set-of-3 colors from SBFlashlights). The WK41 was bought on another occasion.

I don’t own this light, but try taking out the battery, reassemble, and hold the power button down for 65 seconds. Then reassemble with a nimh and see if it turns on.

This worked on my laptop when it was indicating “plugged in, not charging”. I can only guess that it was a reset of some sort. I know, it’s a longshot, but the price is reasonable. :wink:

Long shot indeed. Nope, your novel idea didn’t work too. (Just tried it)

If you have a lithium or alkaline AA lying about, give them a shot. They run higher voltage than the nimh, and may be enough to shock your “battery recognition” feature into compliance. If so, then a nimh is just a heartbeat away.

Longshot, part two. Install a nimh. Hold down the power button for 65 seconds. This has the same repair cost as the original Longshot.

Same thing just happened to mine. I’ve pulled the driver out and it seems the inductor is shorted. Maybe the prolonged high current through the inductor windings heated it up enough to create a short. No inductor equals no boost driver. Maybe one of the electronics guru’s can chime in.

The inductor is a 2R2, which in my newbish understanding means there should be 2.2ohms through the windings. I’m getting ~0-0.1 with my cheap dmm.

I had exact same problem with my thrunite t10t. I think using 14500 somehow changed the driver. Now I don’t dare to use 14500 in my replacement any more. This did not happen to my first gen T10 though.