How do I keep Advanced editor all the time

I set my default text to advanced post editor and come back and it's back on simple editor ..Anyone have a clue why this happens ?


Mine is set to Advanced, and it stays like a good dog.

(Except in PM's though.)

My Account —> Edit —> Post Editor

Make the change there and then save it.

EDIT: Nevermind. It seems the forum is not respecting that selection. A bug?

Boaz, since the bug is so new, you should probably report it here:

Mr. Admin watches that sub-forum.


Thanks for reporting this. It does seem to be working for me (Firefox and Chrome). You could try deleting all your BLF cookies and deleting your browser's cache. Also, try temporarily disabling ad-blockers and other privacy-related add-ons that mess with the page's content, as the option to always use the Advanced editor depends on Javascript to work.


This thread is in the same sub-forum I was talking about.

Ah... So it's the ad blocker huh ?

I personally hate ads and whenever I turn it off I'm appalled at what life without ad blocker looks like .Sites that demand I turn it off to read something usually get passed over by me .

..thanks again

this has been a nagging question for a long time

Yes, I agree, and I also use an ad-blocker for the same reasons. I really try to make sure the ads on BLF are not too in-your-face and not irritating, and no nag screens to disable ad-blockers. At any rate, you should be able to use an ad-blocker on BLF without losing the Advanced Post Editor defaults functionality, so maybe just try disabling specific filters and/or blocking rules. Like I said, the Advanced Post Editor by default option is sort of a weird kludge functionality that I managed to make work, but it might be detected by an ad blocker as the sort of Javascript that runs to create those really annoying ads.

I figured out what I was doing wrong. I was setting the “Advanced Post Editor” under the Signature section of my account settings. What I should have done was put a check mark next to “Use the Advanced Post Editor for new threads” and “Use the Advanced Post Editor fin existing threads.” It works now as it should. My ad-blocker is turned on and not causing any issues there.

Ah OK, thanks a lot for confirming that.