Imalent MR90 charging issue

Hi all, looking for some insight as a new member if possible. I just purchased an Imalent MR90. I seem to be having charging issues though. The red and green LEDs are both blinking when plugged in, not staying either solid red for charging, or solid green for charged.

The charger I received is a European 2 pin, but I am using an adaptor to 3 pin as I am in Ireland.

Anyone know why it is blinking red / green, I cannot see anything in the manual, or on the Imalent website.

Thanks for reading.

I don’t know the light, but if it has a tail switch it should be turned on.
Blinking usually means there’s no electrical path to the battery.

Is the battery tube fully tightened? Does the light turn on? Blinking in two colors is usually an error condition. The charger is integrated in the flashlight, so if it is malfunctioning you need to replace the flashlight.

This light is far, far away from having a tail switch. :wink:

Yeah the tube is fully closed,and the light does turn on. The battery came charged, and I have used it, but the charge is dropping now as it won’t go into turbo etc.

I emailed Imalent support, but haven’t heard anything back yet.

Just wondering if others have experienced anything similar on here.

How long have you had it plugged in and the lights were blinking?

The very first time I plugged it in they started blinking. It’s only when I read the instructions I realised they should be solid colours when charging.

How long did you leave it plugged in while blinking? It may be doing a pulse charge to bring them voltage up slowly.

Right now there’s Chinese new year, so don’t expect any reply soon. Probably in early February.

About 2 hours I’d say… should I plug it back in and leave it for longer?

Well, some e-switch lights do have an additional tailswitch.
But not this one, apparently

I would check the voltage on the battery, it may be too low and the BMS is locking it out.

While you are at it check the output voltage of the charger.

This is strange because the battery would not have come charged. They typically ship batteries at storage voltage which would not be usable with a powerful light like this.

I wouldn’t have the expertise to check the voltage unfortunately…

Not sure on the battery coming charged or not, if they definitely do not then maybe I got a faulty one that was returned?

I think I may plug it back in for a few hours and see what happens.

Got a bounce back from Imalent. They are off until early Feb so won’t hear back from them until then at the earliest!


My MS18 does this sometimes if I leave it plugged in for too long (plug it in then fall asleep lol). Have you tried disconnecting the battery and charging it solo? Or plug it in then turn it on turbo and see if it goes solid red?

Thanks for the tip. Just tried that there charging just the battery pack with the emitter disconnected…

It didn’t work for me though.

If you can afford this light you can probably afford a cheap digital multimeter from Walmart or something, too.
Should be around 6 or 7 bucks, but allows you to measure Voltage accurately, probes are included.

I was thinking if perhaps your battery was discharged too far and the charging circuitry refuses to charge it because of it.
This is possible, but you can’t measure the Voltage of the cell w/o a meter.

I’ll bring it into work next week and see can someone test the voltage of it.

The battery definitely wasn’t discharged too far though as it still turns on, and goes to the high output mode, it just won’t go into Turbo anymore

Thanks for all the feedback too folks, it’s much appreciated

So I left the light plugged in all last night and it actually charged back up a bit. Doesn’t look like it fully did though. It’s like it starts charging, then trips out, starts charging, then trips…

No idea how to embed pictures so here is a link