itp a3 eos repair?

I have this, it has quit working, it is a replacement for my first one that died. Unfortunately the manufacturer will not repair or replace. Could anyone suggest to me how to do it myself?

Itp a3 eos upgraded edition

This driver might work
This one may work also
I have no idea if they will fit, might be trimmed to fit. Did you take the light apart and test the led or the driver to figure out which one went bad. It also could be a bad ground or a connection issue. When you tighten the tube down to the head, it connects to the ground on the driver, check that its making good connection there and clean the top of the tube where it makes the connection.
Either driver above will work with a AAA but using them with a 4.2v li-ion may kill them. If you are going to use a 10440 li-ion exclusively then you might wire in a few amc7135’s ic’s to regulate current. They sink 350 or 380 ma from each one used depending on which one you use. They are wired parallel, so if you add 2 amc7135’s ic’s that’s 700 to 760 ma output again depending on which type amc7135 you use. Their to tiny for me to work on with out getting frustrated. Personally I would just wait for a sale at wallbuys or banggood where they have been sold for well under 20 bucks. I got one last year for $10.16 at wallbuys. Just my 2 cents. :slight_smile:

Thanks for the reply. I’m not sure how to take it apart. I have a new olight i3s eos and it has a ring inside with dimples holding the driver and such. My itp doesn’t have this dimpled ring, apparently its glued in or something. But I also don’t know how to test the driver and led even if I got it apart but I could check for a loose wire. Anyway, I cleaned everything inside top and bottom with a alcohol wipe, pulled the spring higher to make sure its pushing good, and cleaned the threads. Obviously none of that helped hence my post.

Where you using a 10440 in the light or AAA’s when the light was alive?

I have always used AAA. Sometimes it flicked and missed a mode, finally died altogether. Since my last post I cleaned it 3 more times and tried it, got it to flicker again. I then tried this, I put the top housing of my a3 onto the bottom housing of my tank e9, the threads aren’t exactly the same but I actually got it to work, it cycled through all modes and the beam stayed on. Then I tried it back again with just the a3 bottom and top, no flicker or anything. Tried the top on tank again and no flicker or anything. I think there’s a loose contact but I really don’t know.

That’s what it sounds like, bad connection. You just got to find out where now. Running a AAA shouldn’t destroy the driver and sounds like the driver is good. Do you have a small soldering iron?

If I understand correctly, it sounds like a body problem, not a head problem, and my first recommendation is check the spring at the bottom. stick a multimeter lead down on the spring and another on the top of the body and check resistance. if that is good, check where the top of the body hits the negative of the driver. If you turned it on/off a lot, it might have worn away the contacts.

hope this helps.

Well later that night after I post, I attempted to disassemble the light and look for a loose connection. I had a hard time getting the driver out and eventually resorted to heating it up on a hot eye on the stove top, well I finally got it apart but the pieces are so small its not worth me to try to get it back together, nearly impossible so I am just putting that light in my flashlight hall of fame.

Do you still have it? Is it in good condition (apart from the driver)?

Other than some of the red color being worn and the driver unglued from me heating up to pull out and inspect I would say its in good condition.

I’ve repaired one with torn cable… it was PITA! heated it with a torch, centering plastic melted, little of the reflective surface came of the reflector… but it survived :slight_smile:
sorry, no pics