LT1S - Trying to connect to the microcontroller (reading flash)


from the pictures in this topic:
I saw that the microcontroller is a PIC16F1825 and that there are test points with labels matching the "in circuit programming" connections. I never programmed a PIC before, but I ordered a programmer on amazon and connected it to see if I could dump the firmware and then try to write my own.

I have absolutelly no experience with PICs and failed getting any results connecting the programmer.

The programmer is a PICKIT3 from amazon, probably a clone based on its price.

I tried two different tools:

  • picminus (
    • default parameters, powering from the programmer: no luck, and the light turns on, I think the RES pin might be the one connected to the button
    • "use VPP first", it looks like it is working, the light is not turning ON, but "0" are reported absolutely everywhere. Either it failed in a way that was not detected, or read protection is enabled
    • with battery instead of powering from programmer, same as default parameters
  • MPLAB IPE, I activated the advanced mode and tried all combination of power and Vpp/Vdd and low voltage programming or not, nothing ever happen. The led on the programmer does not blink at all and it takes a while, not sure this is doing anything.

Could anyone with experience with PICs tell me whether one of the behaviors described would just mean the chip is locked?

Any other idea of what I could try?

Thanks :)