Problem with convoy build?

I just build a Convoy S11 with a XHP70.2 & the Convoy XHP70.2 driver this one
The problem I am getting is on 100% it’s flashing turn on 100% and every second it flashes only on 100% all other levels are fine. Any ideas whats going on?
I have tried it in all different modes and as soon as I click on 100% it does it in any mode from 1 to 12.
I have tried two different batteries high draw 1x 30A & 1x 10A and both do the same thing.
thanks for any help.

Edit: It seems to be a low voltage problem as I just put a new charged battery in and it was fine for about 15 seconds. Will this combo XHP70.2 and the driver need a special battery or have I got a problem with this driver.


What are the batteries? Stating 30A & 10A doesn’t mean they’re high drain with all the fake wraps.

Keepower I did get them in a group buy on here with a light sometime back. They have no problem running other high power sucking lights. So I am thinking its not a battery problem but maybe it is.

I am starting to think its heat related the driver has 55 degrees Celsius limit. It does not seem to get that hot as I can hold it with no problem but I have noticed it starts flashing around the same heat mark now with new batteries.

Weird because it was doing it straight away with the lower charged batteries.


Yes, but that’s a boost driver which increases the amps to maintain an output until approx 3.7 volts for the highest level. If it’s an older cell the voltage could be dropping off rather quickly depending on how much current is being drawn. The LVP shouldn’t be kicking in anyway, unless there’s a bad connection. Try cleaning the contacts and making sure the retaining rings are tight.

Thanks for your help I will give that a go in the morning. If no good I will try some new batteries.

You nailed it my 26650 Batteries suck. I just put in a IMR keeppower 18650 30A high drain no problems it worked like a charm.
Thanks for your help.


You’re welcome. Glad you found a solution, take care

Ok I got it wrong my batteries seem fine maybe.
The problem was caused by me using the tail cap from the S11 KW CULPM1.TG 8A Driver light. I used that tail cap because it had the extra wire mod. I put the standard tail cap back on (unknowingly) when I tried the 18650 and it worked fine so I thought it was the batteries.

So my question is why does a standard tail cap that come with the host S11 work and a hotted up tail cap that came with the S11 CULPM1.TG with 8A Driver not work ?
Is it that the batteries still could be the problem and cannot handle the extra draw from the tail cap mod? As with the standard tail cap spring it works as a bottle neck for more power drain.
I ask because I was going to solder the wire to the standard tail cap as well thinking it would be better with running the XHP 70.2 LED.

As much as I consider myself having pretty good understanding and speaking of english language, I have to admit it is pretty hard to understand what you mean.

What you are trying to express may be clear in your mind, but writing without commas or other punctuation signs can really mess things up even for native readers.

“… on 100% it's flashing turn on 100% and every second it flashes only on 100% all other levels are fine.”

So when you put the flashlight driver on 100%… it's flashing turn on 100% :???: and every second it flashes…

Maybe you meant to say when on 100% it starts blinking once a second sort of like a turn signal?

If so, it sounds like the low voltage warning from the driver.

A driver like that, outputting above 30W of power in high (100%) mode, can and will pull above 10A of current from the battery (depending on battery SoC) and battery current path resistances. Using high power drivers, it is very important to bypass springs. Standard, non-bypassed springs drop a lot of voltage (and power) when a high current goes through them, consequence of their high resistance. Even the so called high current springs I've seen… suck a lot less than standard springs, but still suck a bit.

You tell me. Did you checked the condition of their springs, namely if bypassed? I don't know what type of springs do S11s ship with, but both S11 tailcaps you describe should perform the same. At least for as long as their springs feature the same conductivity and their switches are in optimal condition. The kind of switches these use don't really like going much above 10A (check: switchtesting -june13th2015:additional test by MRsDNF in post#44-), and so it is rather important for their condition to be as pristine as possible. I can't say what switches are used in the S11, other than it looks like Omten 1288s.

In Review: Convoy S11 I see a standard spring in the tailcap with a thin, uncoiled wire bypass. In my experience, uncoiled bypasses are prone to break very soon. An uncoiled wire ends up bending around/at the same point and eventually breaking (raw copper is not exactly elastic). A proper bypass is done with a thicker wire (to reduce resistance), and coiling it. Coiling the wire can be done either internally or externally (internal or external to the spring). Internal coiling (inside the spring) is aesthetic and can be done but is also tricky (done it many times), so you may want to try external coiling (around the spring), at least for a start. A properly done low angle external wire coil should last for ages.

Thanks for that long reply your help is most appreciated.
I do tend to drop the ball on punctuation when using my mobile phone I go into txt mode.

A lot has happened since the first post it turns out to be a faulty switch.
I narrowed it down to simply the tail cap that came with my S11 CULPM1.TG with 8A Driver does not work on my new build not sure why it’s the same switch YLS-20 it already had the bypass done as standard from convoy.
So today I did the bypass on the working switch. Followed your instructions (internal coiling) worked out great. The switch works fine with the XHP70.2

I am going to order a new switch I might try to find a better quality one to use.


I read this thread with great interest since I have the same problem with my factory built S11. My light is stock with no mods whatsoever. The first 3 modes work as expected. The 4th mode (high/turbo) only flashes for a split second before dropping to mode 1. I tried fooling with the u.i. but I just can’t follow it. Maybe someone can clear it up for me. Also, I’ve read on other forums that other S11 owners are experiencing the same glitch.

I’m really interested in knowing what your long term final solution was. I’m about to place an order for a few items and wanted to know if I’ll need to add some S11 mods to it.