Problems with Everybuying/Utorch UT01

I purchased a Utorch UT01 from Everbuying. First time I’ve ordered from them and they had the best price at the time. Took exactly 30 days to arrive from the time it shipped. A little longer than I expected but that’s fine I suppose. Arrived yesterday. Tried four different batteries (two 14500 and two AA, one was an alk and the other an Eneloop). I know the batteries worked as I pre-tested all of them in my Nitecore EA11. None of the 14500’s worked. The AA alk worked for about 30 seconds but the light did not have all the modes. Then it just stopped working all together. Tried swapping out batteries, making sure it was screwed on tight etc. Nothing. Tried it again this morning and nothing. So that kinda sucks.

Contacted EB last night about the problem. Well there response was to try another battery and take a picture of the problem. :person_facepalming:

So I responded that I had already indicated that I tried multiple batteries, that work in other lights. And that a picture of a non-working flashlight looks exactly like a picture of a working flashlight that isn’t turned on. And that I didn’t appreciate the stall tactic.

Anyway, I also contacted them separately through PP and I have till 8/4 to dispute. We’ll see where this goes. Has anyone else had an issue with the UT01 and/or EB?

I think Deputydave has more problems than just a “protected 14500 battery not fitting” properly. \

Apparently he got a WONKY sample light.

He has problems with the Eneloop and Alkaline also.

Hope you get a properly working replacement Depdave.

Sorry about that, i removed my comment, i didn’t read the OP too well. :person_facepalming:

Everbuying should send you a replacement.
If you can, sending a video would probably help.

Sounds like the cruddy UT01 e-switch strikes again. I got two of these awhile ago, one works one doesn’t. Went through another vendor and I had to do a video too. I made sure they could 1)hear the switch click but not respond and 2)see the cell working in another light/removed/inserted into the UT01 so that there was no doubt that the light was DOA.

Good Luck, hopefully the next one has a good switch, when they work they’re cool little lights.


How (and what) does a video show (or prove) of not working light?

My responses have been to ask them close eyes and then open, and state that they just viewed a video of not working light.

In case of the dead Klarus lights fortunately the people who did videos had the advantage of a charge indicator LED below the switch
also with my dead XT11GT I could simply show a picture from the half molten springs, they even didnt ask for a video then
months later I got total of 3 dead XT11/12GT lights from german TLF guys which I repaired with Narsil and XPL HI NW one was fine without molten springs
one had a lot worse molten springs than the other even the plastic in the tail cap was half molten and the crispy smell of those light will be there even in 10 years

but for a dead Imalent light I had I made a video pulling the Battery from my charger
When the tailcap made contact to the tube the light blinks 1 times as the bleeder need a few ms to power the tailcap MCU on which shuts down the light to standby
from there I could show that clicking the switch did nothing at all

and Gearbest shipping me an Utorch UT01 in NW, the box labeled NW, but the flashlight had a CW LED :person_facepalming:
last Order from digikey I ordered a replacement switch for it just in case it breaks

My experience with Everbying and faulty Utorch UT01 is described here:
Long story short - I shot the video and got refund.

It can show you try but it doesn’t work properly or at all.

Good luck with that…

Anyone can claim a light is not working, so they request you to show what’s wrong with it.
Sounds reasonable to me.

By a video showing you press the switch?

Yes. You show what’s wrong, you show you use a charged battery too.
Usually someone goes back to the shop where the item was purchased when it’s not working properly, and then you can show what’s wrong.
Do you think you can go back to a flashlight shop with a picture?
Or would you say “Close your eyes” to them? :slight_smile:
You choose to buy cheap from abroad, so you’ll have to produce some reasonable evidence for a problem the item may have, if you want a replacement or a refund.
Otherwise folks could just claim away as they please and receive a 2nd item for free.
And i bet many people try that trick too.
How would you feel about that if you were the seller?
It’s common sense that you have to produce evidence of the problems when they ask you to show what’s wrong.
I think Paypal will agree with that too.

Well, I didn’t have to provide a pic or vid. They just emailed me the resolution; keep the light and they’re going to refund the full price to my PP. Acceptable. Shame it didn’t work though.

I’m figuring it’s the driver that’s the problem? As I mentioned, the 30 seconds it did work, it didn’t go through all of the modes (no turbo). Then nothing at all. Maybe the switch, but I’m thinking driver? I don’t know off hand what size or kind of driver it takes. Any thoughts on that are welcome. Don’t know anything about changing a switch though.

Well, that’s nice of them (i.m.h.o.)
Maybe this topic helped a little too.

it could be the switch, but sounds more like the driver is faulty.

Maybe…this is similar to what my first UT01 did. I ran it through the UI cycle once or twice without a real problem if memory serves me. Then the short clicks started not changing anything. After a few more minutes only long clicks would work and even then I was pushing in different directions just to get “contact” on the long clicks. The last long click turned the light on but I ended up having to unscrew the tailcap because it wouldn’t turn off again no matter how I pushed on the switch. There are dozens of similar stories on the UT01 thread from last year. There was even a suggested replacement switch but I don’t think I read where anyone made the change and no tear down that I’ve seen so far.

That said, big fat guess on my part that’s worth nada without seeing the OP’s light. :slight_smile:

Well, I did a search back through that 8 page UT01 thread. So many faulty switches got me curious. I put another alky battery in the UT01 and using my thumb nail I really pressed down into the switch…it worked…mostly. What I mean is that it did work, but not consistently. Not something I would rely on as an EDC light. I’ve done some light modding as far as replacing stars and drivers but have no experience with switches. I took the boot cover off and see the little button down inside. I took a small screwdriver and I’m able to cycle through the modes. I’m trying to figure out something that I can place into the housing, over the small button and then replace the boot cover to see if it can be made consistent. Trying to figure out what is small enough that I can give it a try.

I found out the switch is a TL 3340 if I need to replace. Does anyone have a good source for this switch? And does anyone know of a good video that would guide me through replacing the switch? I’ll try the jury rig first, but would still like to know where I can get a replacement switch and good instruction on how to replace it if possible and if needed.

Thank you :slight_smile:

I got mine 2 days ago and I has tha same problem that the switch is faulty. It only do something when Ipress harder. If not I can click it all day long and doing nothing.
I writed this to gearbest. I will wait for their reply. If I got a replacement light or refund I will buy a switch and make some photos or video of the replacing. I can do soldering well so I think it is doable. I think to get the driver out you need to remove bezel, reflector. Unsolder led wires. Remove body tube and then pull out driver. When I remove the tube the driver is moving a little so no glue or any hard stuff holding it in just the wires and the tube.

The Nokia 6120 classic phone I think has the same switch for volume control and I found some on aliexpress. I’m not 100% sure but for this price I will give it a try and order 3 buttons.


I refuse to do that for a $4.49 flashlight, for example.
Doesn’t honesty count anymore?

Well, the juries still out…

However, I showed the switch to my wife with the boot cover removed. She makes jewelry so I figured she might have something small enough to place over the switch that would allow the boot cover to have a better connection. She had a very small bead that was flat on both sides that fit pretty much perfectly on top of the switch but was wide enough that it shouldn’t shift too much. I replaced the boot and it now works as it’s suppose to work. I say the jury is out as I want to use it for a while to make sure this simple fix is actually a long term solution. The boot is no longer flat on top, it is slightly raised in the center, but not that much really. I don’t ‘think’ that it’s going to cause any issues with accidentally being activated but the proof is in actually carrying and using it. So we’ll see…

Is it not just a problem that the switch has moved somehow? A lack of support behind it?

Mine is brand new. It has this behaviour since first power on.