Site loading issue

So, when I load the site on my phone using mobile data I get:
But when I turn WiFi on it loads fine.
Before I tried using WiFi I tried clearing site data and cookies.

Anyone know why this would be happening?

No, but I can confirm the same for me. It seems to be regional. On my wifi here in the Atlanta area, I get the redirect error. But if I connect through a VPN into some other parts of the country/world then it loads fine. Idk…

I was having trouble too even posted on BLF blogspot page and FB, some people also reported the same issues

Thanks a lot for reporting it. I made a small configuration change, could you please try it again?

I have been trying to load BLF for 3 hours. I get the redirect for a few seconds and then the page loads. Mid Michigan area.

Hi, is it still happening for you as of now?

Just got this message when typed in BLF in Google browser. Tried a old bookmark for BLF and then got on.

Hmm, OK, that’s another issue though. Is the “Too many redirects” thing still happening?

Redirect issue is not happening now. Seems to be fixed.

Tried Chrome and Firefox browsers and no redirect.

Thanks for confirming. Are you still using the same device and internet service as before when it was giving you redirect errors?

Yes I am. Same device, service.

I couldn't connect from any device here in South Carolina. I don't know if it was just timing, but I was finally able to connect after going to the BLF Facebook page and then clicking on the BLF link.

Hi, roughly at what time were you having this issue?


First time I tried to load BLF was around 7PM Eastern Time. I finally was able to load BLF probably about 20 minutes before I logged on to this session.

OK thanks. I think I fixed a small configuration mistake that I made today, but please let me know if it acts up again.

I can finally go on this site!

Couldnt connect 3pm-9pm. Too many redirects. can Connect now but maybe a little slow … typing delayed

Thanks for the report. The slowness and delayed typing are a problem with your computer/device, not with BLF.

I had the same problem for about 6 hours. Site wouldn’t load. It’s working fine now.