Skilhunt H02 malfunction


my half-year old, purchased from Gearbest when it was cheap, almost unused Skilhunt H02 started to malfunction. :frowning:
I recorded a video of it. If someone could help me with fixing it would be great. Skilhunt service is non-existent.
I used Samsung and Panasonic unprotected batteries only.



Make sure all conductive services are clean, use alcohol or similar in case grease is causing a problem.


All is clean. Wouldn’t it be impossible to just “partly” work if the connections were bad?

A bad connection might only show up on higher current settings, But if you have already checked.


Oh man , this one reminds me of my experience with Skilhunt , couple of years ago !...I bought from them 5 (!) K30 for a security company and ALL 5 of them started to do like yours !!! Warranty was expired , from net I'd noticed that a lot of people had the same problems.., long argues with Skilhunt guys...,finally they admited that was a bug in their soft for UI...,the K30 was discontinued , and that was all ! No drivers were available , no excuses , no alternatives offered , nothing at all ! Some guys from Germany found some alternative solutions , but seemed to be very expensive and time consuming ones !...You can Google to see...

I promised myself that I will NEVER buy from them again and I kept my part of bargain !!! This is ONLY a personal opinion based on my experience and has nothing to do with "trying to influence buyers opinion" ...

I'm curious what will be their answer in your problem , but I do think that you'll have to pass this one as "loses" and move forward...

Good luck !

Yea, I checked it, but will do it again just to be safe. There’s one more thing. When I noticed that it started to act, I actually one or two times brought it back to normal functioning. I just rapidly clicked the button for a number of times and it was all good till some minutes later when it was gone again.

After a few times of reviving it never came back to full function.

Thanks for your comment. That’s crappy. I really started to like this torch.

See if it`s possible to strip the head down and re-assemble, do not touch the reflector.

EDIT: The review below shows it stripped down.


It is possible I found nothing suspicious, I did not remove the reflector and LED part since It’s kind of working.

I have all the equipment and can test few things, but since I’m not really into lamp circuits I don’t know what to test.

Is that yellow gunk just glue or some thermal glue?

BTW: Is warranty a thing? I mean, they say it’s 24months, but has ayone tried it? I don’t wanna pay more for shipping that the actual cost of the light itself so that they will say “damaged due to liquid”.

I thought i would have a look on GB and look for any problems that had been reported, but it gets 5 out of 5 with 157 reviews.

Hopefully you will get more help as more member come online later today, Have you tried posting your problem on CPF ??


I had some problems with the H15.
The retainer ring for the driver had to be tightened.
It’s okay now.

Ok, I’ll try to tighten it, clean the shit out of it and maybe it will just work. That would be super sweet :sunglasses:

Thanks, will ask on CPF too.

I had a similar problem that was fixed by cleaning and adding contact paste under the spring in the tailcap and around the ring on the driver.

On another light there was a definite quality problem. Skilhunt sent me a new head for free. So they are good with warranty at least sometimes.


Also check the switch for proper contact, even a little ‘wiggle’ can cause the issue you describe. Good luck.

I connected the battery directly to the board to eliminate possible housing issues. Nothing changed. Switch is good to (tested it with multimeter). No luck for me I guess.

i had almost same happened to my h02, i read few forums, resoldered almost every contact i could, especially where 2 boards connect. no use, driver craped out, it happens very often with 02, you’ll need to replace the driver, you prbly wont find same driver anywhere, but you do not have to, i used old driver board with spring, removed all parts, and soldered + and - wires to it, than i used 17mm amc driver, and soldered it to original contact board, button is not used, i removed 3 chips from the new driver, so output is 1750ma, 1 mode, for now i installed basic driver and turn on\off by tightening the cap. i placed order for amc driver that is reprogrammed to work with momentary button. but i’ve used it like that, actually a lot lately, doing construction in my house, and i find it pretty convinient, not in a rush to replace the driver actually.
oh, the driver is sold at mtnelectronics, qlite momentary button driver. it is around $5 depending on options you pick.
fortunately replacing it is very easy,

I’ve dropped mine numerous times, 2x from 6-7 feet on the same day. Still works great. I like my H02 so much, my HO3 is still in the box on standby… Guess it’s a lottery when these lights fail.

i dropped mine before many times too, no issues, than 1 day, it just stopped working.

i replaced driver with mtnelectronic q lite driver, nice driver, but 1 thing, it makes high pitch noise on all but 100% and 5%, moonlite modes. would not be an issue in a handheld light, but having this noisy thing on the head is not a good thing, i wonder if anyone knows how to deal with that.

Same thing with my H02R, the driver just stopped working after a drop. It would turn on sometimes but get stuck in turbo mode only.

Reassembled everything and soldered the leads but still nothing. Will contact Skillhunt and see what they say.

people tried, i read it on more than 1 board, skilhunt says “send it to a dealer, we work with dealers”, but 1 person on fonarevka, got lucky and they send him the driver. others just installed different ones, some bought custom made drivers, from custom builders, others, like me, got reprogrammed amc 7135 drivers that work with momentary buttons. it is cheap, reliable, and easy to install, but it has a big negative side, it makes that high pitched noise.

Hmm… Maybe they should start working with replacement drivers…