Sofirn SP33 V2 not working

I have a sofirn SP33 V2 that stopped working; it simply wouldn’t turn on. I checked the battery and it was fine but I popped a fresh one in there anyway she’s still wouldn’t turn on. I almost threw it away but it sat on my nightstand for a while. A few weeks later I hit the button and it turned on no problem and it has worked flawlessly for the last few months but tonight it decided not to turn on again. Again I switched batteries and it is still not responding. Any idea what could be wrong or how I could fix it? I have been debating upgrading to the V3 but I hate to see a perfectly good flashlight go to waste if it is salvageable.

There are some possible causes.
The flashlight can unscrew into three parts, head, body and tailcap. Make sure you assemble them together tightly.

Please check the driver if it is covered by dust or something else. If so, wipe those dust with ethanol.

It will be very helpful if you send video to show details.

Check your driver side spring. Mine was not soldered well and popped off with little force.

I’ll add some photos shortly. I took the flashlight down into the 3 main parts and wiped down the springs and the exposed part of the driver before posting. I haven’t checked to see if the driver side spring has come loose but I’ll take a look.

My SP33V2.0 also stopped working after a fall, I was looking for help because nothing seemed damaged.
And exactly the same thing happened.

Leaving it for a few weeks without a battery fixed the problem ?!

It had the battery still in it. I’m not even sure why I tried to turn it on. It worked for a few more months then kept going through phases where it would and wouldn’t with. I eventually replaced it with the newer version SP33. It’s better in many ways so I’m glad I did.