[SOLVED] UPDATE: Does anyone know how to flash Andruil to a Q8 with a Mac? now where is "avr/interrupt.h"?

I am trying to flash Andruil to a Q8 from a Mac. Im not sure if anyone out there does it or has done it. Any help would be appreciated. I have the hardware, USBasp, clip, wires. I need help with the software end. It would be much simpler if I had a pc and am in the procces of trying to build one however GPUs are super expensive because mining and parts are expensive too, anyhow if anyone out there knows how or does it any help would be appreciated.
So far I have installed avrdude, avr-libc, and homebrew. Many thanks.

Some months ago I had the same problem with my MacBook Air. I created a virtual machine with Windows 7 / 8.1 (free 30 days trial should be enough so no key is required).

You could try Virtual Box for Mac which is free (at that time I used Parallels Desktop, unfortunately not free). With Parallels Desktop there was no problem to flash drivers in the Windows OS, though I didn't test Virtual Box for this yet. Maybe an approach for this.

I am using a Raspberry Pi atm, but when I flashed on a Mac I used this tutorial:

Can not say whether it’s up to date, or anything like that

I’m currently using my mac mini to flash firmware, I put anduril on my d4 :+1: . I wish I took better notes, but looking at my command history from when I started I used the following:
brew update
brew tap osx-cross/avr
brew install avr-gcc
brew install avrdude
brew install bzr
bzr branch lp:~toykeeper/flashlight-firmware/fsm
…/…/…/bin/build-85.sh anduril
…/…/…/bin/flash-85.sh anduril.hex

brew tap was used to add a repository so you can install the avr stuff
bzr is the version control software that ToyKeeper uses
bzr branch command will download the firmwares

I did have to edit some of the source code since I was getting some errors building it, but it worked after that. Hope this helps.

I’d be very interested hear what you end up doing, as I’m hoping to do the exact same thing in the near future.

Being a complete novice I was planning to use a Windows virtual machine so I could someone else’s instructions more closely, but I’d be happy to avoid dedicating time and disk space to setting up the VM.

Hello to all who replied, I want to thank each and everyone of you. Redhawk your method worked minus the flashing to anduril. I am still struggling to be able to flash anduril but I have finally figured out flashing .hex files. If you have experiance compiling im having trouble finding “fatal error: ‘avr/interrupt.h’ file not found” that file.

skinny_tie my plan, once i figure out how to flash Toykeepers Anduril, is to write a guide because its incredibly dificult finding a guide for all of this.
stay tuned once i figure it out.

hmm, I haven’t received that error before. Just to verify have you run the commands:
brew tap osx-cross/avr
brew install avr-gcc