Vapcell S4 Plus V2 Charge Current Selection

Recently bought the Vapcell S4 + V2 charger and I'm presently charging several Li-ion cells.

The charger has been set to "Manual" mode via the charger side slide switch, which means I select the charging current instead of the charger automatically selecting the charging current in "Auto" mode.

After the charger is plugged in and then inserting the cells to be charged within the charger, I then select the charging current via the "Current" button.

Available charging currents are (supposed to be) - 250 mA, 500 mA, 1000 mA, 1500 mA, 2000 mA, 2500 mA, and 3000 mA.

After inserting the first cell to be charged (and regardless of which of the four slots are used), the charger correctly recognizes the cells as being Li-ion and the charging current indicator flashes at the default setting of 500 mA. Then I select the charging current by pressing the "Current" button. Problem is that the selection of currents is limited (for whatever reason(s)) to 250 mA, 500 mA, and 1000 mA. The higher current settings (1500 mA, 2000 mA, 2500 mA, and 3000 mA) can't be selected!?

But on insertion of subsequent cells to be charged, the full range of charging currents (250 mA up to 3000 mA) can be selected now!?

So, it appears that the charger does not allow the full range of charging currents to be applied to the first cell inserted within the charger!?

Anyone else notice this?

Maybe I have a faulty charger?


I noticed this, but only when charging batteries near the termination voltage like 4.15 volts for li-ion. The current is limited to 500ma to protect the batteries and ensure they receive the most charge for optimal capacity.

If your batteries are discharged and this is happening, you may have a faulty battery (high internal resistance) or a faulty charger.

The charger seems to have its own mind. I’ve returned at least 2 of them because they refused to charge higher than 1500 milliamps many times. These are batteries at 3.5 or 3.6 volts. If I unplug it and plug it in several times I usually can get my desired charge rate. It’s a pain in the butt. Every single battery that I have used does that except two batteries that every time I put them in there it’ll charge it at 3 amps. Those are the Vapcell G53 26650 and my P42…Molicel .

It also didn’t matter the age of the battery. It would act the same way. 90% of my batteries are hi drain cells. I have some MJ1 and GA’s that I would not consider High drain.

I spent way too much time emailing Vapecell and they didn’t want to hear it. They mentioned cleaning the contacts. plugging it and unplugging it is the only solution . So if the contacts we’re dirty unplugging it and plugging it back in would do nothing. Its an electronic glitch.

I’ve learned to live with it because there’s no other charger around that is reasonably priced that can charge all four slots with 3 amps.

These issues were happening immediately when they were brand new. My dealers is close by to me so it was easy to get new ones and replacements. But every single one had that glitch.

Maybe you got a bad batch? I got mine on Amazon in the Spring and it’s been flawless. It did exhibit weird behavior once, but unplugging and plugging it back in fixed it.


This was a period of over 6 months. So finally after replacing three of them I waited for a new batch and it did the same thing and he said I can’t replace anymore which I totally understand.

The only good thing about it is he let me keep two of them because they had no use for them.

So I use them as spares. But The Replacements are no better! It just gave me more Chargers

Interesting comments! Thanks!

The Li-ion cells I'm recharging are (fairly) new with initial voltages around 3.5 ~ 3.7 V before charging. So I doubt I have "faulty" cells, and the issue is unlikely to be cell voltage related either.

It seems there may be an issue (electronic and/or firmware?) with these chargers. So even if replacing the charger, the limited current selection "bug" would still be present!?

So it may not be worthwhile (trying to) replace this charger with another(?)

Still doing some testing on this charger to see what (other) conditions may cause the limited charge current issue and whether there's a workaround (plugging/unplugging, different cells).

EDIT: I note that the charging currents for Ni-MH cells are limited to 250 mA, 500 mA, and 1000 mA. This is by design, so there is no issue there.

Maybe the charger thinks the first Li-ion cell inserted for charging is a Ni-MH cell (despite displaying correctly that the cell is a Li-ion type) and therefore limits the charging currents? Regardless, it appears there is something wrong with the charger.

Still testing.

I don´t think it detects LiIon as a NiMH but shows LiIon. Which voltage it shows, this is the reason for recognition of the cell type.

OK, don´t have this problem as a NiMH-user, but my Xtar VC4SL has really an own mind which makes selection of the charge current to a joke.

One time I tried charging a 26350 at 3 amps because I was in a hurry and the f’er got really hot. I let it pick the amps now

I would say 1A is the max. for this type.

You didn’t get a bad batch, it’s not a bug, its not a faulty charger. This was a feature added with the V2 version upgrade, I believe at the advice of HJK and other BLF members.

Read the owners manual people-

“For safety and battery cycle life, the maximumn charge current can be set within 2 higher charging current levels.
For example: under the auto mode, when a battery is in- serted(sic), the display current is 500mA by default. maximum auto setting charging current can be set up to 1500mA (500mA, 1000mA, 1500mA)”

This carries over to manual mode as well. The charger will only let you select a current 2 steps higher than it decided is the maximum safe charging current for that cell (which in my opinion is already way too high btw). Meaning, if you were to put the battery into the charger in auto mode, and based on the charger’s reading of internal resistance, auto mode decided it shouldn’t charge faster than 500mah, it will still let you select 1000mah or 1500mah, but no higher. In manual mode, the charger is still reading resistance and has decided, in the background, what the maximum charging current should be. It will still not let you go more than 2 steps higher than this even in manual. So if it’s stopping you at 2500mah it thinks you should really be using 1500mah.

Personally I think the vapcell wayyyy overestimates how much current is safe and uses more than the rated maximum rapid charge current maybe 90% of the time, and goes over the standard charge current for battery life 100% of the time. But it is a fast charger so can’t really fault it for that.

So if it’s telling you don’t charge that with 1500mah, I’d really take that warning seriously because it actually thinks you should be rapid charging with 250mah at the most. Thats a bad cell. Or really dirty contacts.

1 Thank


I’m not so sure the charger is without fault.

If the charger is supposedly limiting current selections to just three current settings (usually 250 mA, 500 mA and 1000 mA), it seems to apply only to the first cell inserted within the charger regardless of which slot is used. Because on subsequent cell insertions after the first cell is inserted, the full range of charging currents now become available for selection (250 mA to 3000 mA)!?

So it seems to me the charger logic is still a bit screwed up.

Yeah, I have seen this behavior as well and I have mine set to the manual mode. It is strange because if I put on cell in and have limited options, then add cells to other slots that are not limited, then remove the first cell and insert one of the others into that slot, it will have the limits. But putting the original into another slot it will not. So this pretty much eliminates the bad cell hypothesis.
Contacts have been thoroughly cleaned with 99% alcohol and treated with Deoxit red and then gold.
So unless it is a contact issue with the sliders internally, it is not a contact issue… besides, it happens regardless of which slot I start with.
My conclusion is that it is some kind of firmware problem. Unfortunately, until they come out with the new version, swapping the charger out is no guarantee of getting different results.

All that being said, I seldom use anything above 1.5 amp charging. I think that, even with some of the newer cells I have that can accept much higher current for fast charging, higher charge rates negatively impact cycle life. I have enough batteries and chargers so I am never so rushed as to need over 1.5 amps, let alone 3 amps.

Well that’s definitely true, check out my thread about mine burning a hole in its charging IC.

Right, because it would only limit the charging current for the cell that it determines has a high internal resistance. It wouldn’t depend only on the slot. But the slot could be a factor. It’s well known that none of these chargers estimate internal resistance accurately, and that the resistance it measures will change based on the tiniest little things.

Put the same cell into the same slot 10 different times you’ll probably get 10 different internal resistance measurements. That’s not exclusive to this charger. It’s just an estimate. I mean, think of all the factors at play, and we’re talking about mohms here. Numbers so small really expensive and calibrated equipment is needed to reliably measure it accurately. It’s a $50 charger. Add another zero or two on there to get a device that can give an accurate measurement. Eventually you’ll pick up on the patterns and get an idea of how it decides resistances. But ya, definitely stick to manual mode IMO.

I always have. Never trusted any of the auto algorithms. On any cheap chargers. I still have seen the whacky limiting of the max current that can be selected from time to time on this one.

Same. Besides the actual internal resistance constantly changing throughout the charge, think about all the variables the charger has no way of taking into account. The resistance of the metal slot itself. How much force the spring is holding the battery with. The temperatures of everything. And then the vapcell cuts resistance in half for some reason.

So just so I understand what’s going on, you’re saying that the first slot you put a cell into will be limited? No matter what slot that is or what cell? And you can move stuff around but that first slot stays limited? Until when? Till you turn it off? What happens if you put all the 4 cells in the charger first and then plug it in?



That is pretty much it. If I remove all of the cells and unplug the power supply for a while. It will reset and work properly. I have never tried loading all of the cells and then plugging it in. More often than not I charge 1 or 2 cells at a time. SO loading all the slots would not be my normal use case.
This is intermittent, and as I mentioned I hardly ever want to charge at more than 1.5 amps. Meaning it doesn’t really bother me. But I have seen the problem.

That’s different than the issue I thought was being described. That’s definitely weird.

I never had that, and I can’t try and replicate it now because mines toast. But I took some pictures of the thing opened up over on my thread. Maybe someone who knows this stuff better than I do can spot something out of place in the design that might cause that.

I have had the charger for … maybe 4 months. It has only happened a couple of times. I have some ~5700 mAh 26650s. I just wanted to try 2 Amps for the initial charge. I was surprised when pushing the current button took me to 1.5 amps then back to 500 mA. Anyway, it would not allow me to select 2 amps. But putting a second 26650 into the 4th slot, did allow me to select 2 amps.
I think I just pulled the cells, unplugged the charger for a minute, and started over. It worked fine after that and I charged the same cells, in the same slots, at 2 amps.

Just a couple of extra comments.

Wondering if vapcell_Dennis has seen this topic? And if he could comment on this issue? And would this issue be carried over to V3 of this charger (soon to be released I believe?)?

I always start/plugin the charger first before inserting cells into the charger. This is standard practice for all chargers. Putting cells in chargers and then switching the chargers on is not recommended as it could lead to unusual or erroneous behavior by the chargers. This seems to apply particularly for automatic settings chargers.