What did you mod today?

Crafity use a new image host! Its like the 90s again waiting for image to load line by line

sorry , test again please.

For the curious:

Crafity's image was only 639 kilobytes, which is reasonable, so the fault is/was with the image host.

I expected the image to be at least 20 megabytes considering how slowly it loaded.

Copper TK16 with the beautiful 219b sw30 9080 (from azhu, recommended -> WTS/GB: NICHIA 219B NVSL219BT-V1 R9080 EMITTERS! sw45k, sw40, sw35, sw30).

And some glow of course.

My SOIC8 clip came today, a day later than expected.

My D4 has Anduril now, and the games have just begun. Now I have to figure out how to compile slightly-customized Anduril, for example to get a build that ramps properly on FET+1+15.

Edit 20 minutes later: My FW3A has fresher Anduril now, but I wasn’t a fan of having to unsolder the MCPCB to get to the ATTiny85. My D4 had just enough length on the leads to turn the driver sideways and clip on - likely because I replaced the MCPCB at some point, Hank probably had shorter leads before.

I modded my GT to a GT90!

I remembered when I finally finished modding my L6 about two years ago, I swore I would never open it again. I decided to throw Anduril on it, and it decided to remind me why I said that.

My recollection was that I’d mostly pulled off the Switch+ pad on Lexel’s lighted switch board, and had managed to barely solder the wire onto a remaining fragment of that pad. Well today when I pulled/tilted the driver out juuuuust enough to clip onto the ATTiny85, that lead pulled loose and the remainder of the pad went the way of a fart in the wind.

After some frustration attempting to re-attach to that pad (or rather, where that pad used to be), I decided to file a notch into the switch PCB and route the SW+ signal wire to the leg of the momentary switch itself on the front. It all worked great until my arrogance got hold of me: I assembled it all back together and got factory reset as soon as I applied power! I was sure I knew which leg was which on the button and didn’t double-check… so now I had to re-disassemble, file another notch on the other side, and solder to the proper leg of the switch button.

But now my L6 has Anduril, at least. I’m really never opening it again unless I have a replacement lighted switch board in-hand.

Weird question: Does RampingIOS (or, from MTNE, “D4 UI V2”) measure voltage differently than Anduril?

Edit: Yeah, I’m definitely going to be opening it again. Battery check only gives me 5.2v. I’m also gonna have to figure out how to compile my own build, since TK helped me in another thread figure out how to disable the turn-on blink

Edit note: Screwed up this post editing it when I meant to quote it, and had to re-write.

I modded a On The Road Z821 zoomie, twice:

From 15kcd to 39kcd to 64kcd+

Continuing the saga. I’ve been reading quite a bit about how to do all the things. The L6 looks like it’s going to give me a challenge. For the FET+1+15 driver in the M6 (3xXHP50.2 3V), I just shot FW3A firmware at it after figuring out the pinouts were the same. Decent hardware match, paralleling 3xXHP50.2/4x30Q/16x7135s against 3xSST-20/1x30Q/8x7135. Tested with my only button-top unprotected and it’s working great. Excited for my 4x button-top 30Q order to arrive Monday (~ish, with how USPS is these days). It will maybe hold the heat better than the FW3A, so I may eventually do a custom build with tweaked…uh, what was it again… #define THERM_FASTER_LEVEL in cfg-fw3a.h. Hey, maybe if I get good at this I’ll even tweak the ramp levels on it, since that one’s so easy to open. (A bit hard to clip to, though, since my reflow of the ATTiny85 isn’t the best.)

As for the L6, what I’ve figured out so far is that it probably uses a voltage divider (or something?) on Pin 7 to read the voltage. No idea how LVP works yet though.

Edit: Update: Chopped up a hwdef file from a D4 (for ramp levels and FET+1 stuff) and a GT (for voltage divider stuff), disabled blink at power-on, and adjusted THERM_FASTER_LEVEL on my L6; built and flashed successfully. Voltage check is working, although not my preferred behavior (gives voltage of a single cell, rather than total voltage). Bedtime. I’m sure I’ll dive back in tomorrow.

I fixed some of my gadgets having some issues since few days.

Changed up my EagleEye X6

I got some mystery bin “Boost HX” (CULPM1.TG) from aliexpress. The light had a LED4Power 4x 4040 board with Luxeon V in it and Angie optic (same one from Emisar D4S) so I thought it would be smooth sailing; it wasn’t. I kept getting shorts after the reflow. The separation between pads is so small with this board and after more than an hour fooling with just that I gave up. I had one 4XP 33mm Noctigon I use for slicing 4 LEDs at a time (so WELL used) and I figured i’ll give it one shot reflowing them onto the 3535 board. First try was a success! The next problem is that board is 1mm larger than the LED4Power one so I had to cover the LEDs and grind down that huge PCB to fit the spacer. I would have done this first but I had no faith in my ability to reflow the board on the first try and just assumed it wouldn’t work.

End result:

~4470lm @ 3s
5500K CCT

” Scallywag ” It burnt up on the first turn on and ramping up to about 50% power, poof. I had just installed ’ Lexels ’ driver. The led was working perfectly normal with the stock Haikelite driver, but I had modded the mcpcb to 12v and probably got some crossover voltage in the mcpcb. I have not had time to address it since then, busy on another build and I just received a few more mcpcb’s to mod to 12v. So new leds are ordered and soon will be back with an update. :+1:

Yes, I see you !!
You may want to post a few pics here. I’m afraid many may miss out on your mod, Great Mod !! :+1:

I finally reflowed some new emitters onto my Sofirn IF25 (the one with shifting CCT).
I used 2 x 219b 4500k (SW45k) & 2 x 219b 3000k.

I cant believe i wated this long to do it. The light’s been sitting half undone for months on my shelf, i just hated the stock LEDs ssssooo much that i couldnt imagine it being as good as it is.
The CCTs blend well together. The optic is quite throwy which is a nice change for a R9080. pretty decent mass to the light, USB-C. Im quite happy. If they just fixed the hold off in the UI….

Personally im not overly fond of the SW45k, not that i dont like the rosy tint, but 4500K is just not my thing indoors.
I think i found a way to get close to my favourite 3500k but with more rosy tint :+1:

Will give it a decent run over the next few nights before i add it to my standard rotation, but maybe its the perfect light to take away when you only have 1 light. Any indoor CCT i want and USB-C charging!

Welp, my 30Qs arrived today. Threw them in my M6 and… as soon as they connected, it turned on.

I assumed my fix for the reflector shorts broke, so I checked for shorts there… but nothing. Just to be sure, I removed the reflector, and eventually pulled the driver completely out of the light. I double checked all the pinouts for the driver, including probing it out with a DMM, and compared it to the Anduril version I flashed - no issues there. I’m not sure what path current is flowing through. I eliminated the single-7135 channel by removing it. It’s probably the FET, but in my test rig the 15x7135 channel is probably just doing direct drive too, and I’m not sure how to test which gate is being opened with a DMM.

And apparently, all I had to do was give up and post here. I went over every solder joint on the board that I could see… But just now, typing this, I decided I’d double-check that the issue wasn’t somehow with the MCU/firmware (by removing it). I’ve got a silly quick way to do it, by laying the tip of the iron across one set of legs and rocking it up, then doing the same to the other side. But just now I gently applied flux to each quartet of legs. When I first laid the iron across the legs, I noticed how the visible portion of the solder joints got a lot neater… And on a hunch, did the same to the other side. Re-tested and it appears to be giving me the “blink for on”.

I think the most frustrating part of all of this is that the light was working without issues yesterday with the single 30Q out of my FW3A. All it did was sit on the desk, empty (no batteries) since yesterday evening. I’m going to go fully reassemble the light and make sure it still works.

Tested more, seems to be working. Re-assembled… Still working. Definitely the brightest light I own now, though I have no way to actually measure. But ceiling-bounce around the room compared to my L6 definitely gives the M6 a slight edge. It also gets hot way faster on turbo. But the difference between “10K” and “7K” lumens (this is what my M6 and L6 should be doing, but again - I can’t actually measure) isn’t impressive. Probably because the way the eye sees it, it’s less than 20% increased perceived brightness (perceived brightness is doubled when lumens are quadrupled).

I don’t think I need to build any more high-lumen lights, unless I find a way to do about 40k lumens at this point. And, judging by what Acebeam and Imalent are doing, that just means stuffing as many 70.2s as I can in something, which doesn’t really sound any more interesting than my M6.

Thrunite Ti3 Ti Xmas
CREE XP-E2 Green (wavelength range: 520-535nm)

on aaa Eneloop
0.1 lumens
10 lumens
70 lumens

Green light emitting diodes accelerate wound healing

Nitecore EX11.2
CREE XP-E2 Green (wavelength range: 520-535nm)

on 16340:
0.6 lumens
ramping to
150 lumens

on CR123:
0.04 lumens
ramping to
70 lumens

Green light emitting diodes accelerate wound healing

Added a pocket clip to an Imalent LD70 today.

I found one slip-on clip that worked and was in no danger of coming off the light. But the clip tension wasn’t the greatest and it stuck out from the light more than I liked. I removed it and replaced with a screw-in clip. Fortunately, the wall of the light where I drilled was thick enough that the screws did not penetrate to the inside.

I don’t have any experience or equipment for tapping screw threads. Instead I just drilled a couple small holes with a hand-held pin-vise drill and let the screws tap their own threads.

Playing around with these clips did scuff up the light a bit though. Darn.

Practiced heating some Ti before I torch a full light, turned out pretty good.

Nice perseverance and result! I don’t think I’ve seen an Angie in an X6 mod before. Is it the same height as the CUTE-3 or do you use a different spacer?

nice gradient :+1:
will look nice when polished