Wurkkos TS10 junk

To be curious, do you have any other flashlight with a switch that you enjoy? Which is it and why? Would be good to know what switches people prefer.

Todd is such a nice guy to be donating this light to a unsuspecting friend . Undoubtedly he will love it as we all seem to .
Not a perfect light but it’s a high bang for your buck light .
I swapped a Utorch uto1 clip for the one it came with and it’s still not great since the start of the clip is in the valley of the light and it’s still hard to get it to clip onto material . Looks better just still wrong . Now I’m wondering if the lumintop clip is reallya viable alternative . I need pics before I run out and grab ‘em .
I really like this switch so there ya go . Some does and some ain’t.

If Todd really hates his friend he’ll make sure to add the clip.

Pizza … Ha! I’d never trade my light for a pizza .

I really wanted to stay out of this thread….but LMFAO!!! :+1:

1 Thank

Clip pics….

I have the Olight clip on two of my TS10s and the Lumintop on the other two. Overall I like the Olight clip better or getting it clipped on a pocket and for retention. But that recurve can scratch things like cars if one is not careful.

Thank you @Mandrake50, looks like you found the clip I am looking for : need to source an edc05 clip now, and I’ll give another shot a this TS10

Thanks for the pic .

that’s definitely the one I have on my ts-10…. And I think it’s very hard to get over material . I keep saying it’s from a Utorch ut01 and I believe it but can’t fully prove it . I have 4 or more that came in a little plastic baggie with a lanyard , clip and the lanyard has a round button slide and the ability to separate the end of the lanyard with a little plastic clip. Photos show the possibility of more than one clip being sold for the Ut01.
This is the one I have that looks exactly like Jon sliders lumintop clip

and this is another clip they used. * I don’t own this clip.

has the same pattern/ shape / rectangular shaped hole as the one on the Utorch UT -01

It appears to have a ?? Nitrile? Coating ? Slick darker grey coating . Nice clip only it seems about an 1/8th of an inch too short . The dip on the clip dropping into the dip of the light .

this may be a better option but it’s not able to find the lip to grab your clothing and you end up having to lift it . I tried taking some of the tension out with a little prying and it went from too tight to trash . It simply needs to be a bit longer .

Ya know I love the little TS10, it’s just that damn button. I should have kept my mouth shut but, ya know, it was one of those days.

It’s going to a good home. Visiting a friend and forum member here tomorrow and he loves to tinker. I’m sure he will have that button straightened out right away.

If I offended anyone I’m truly sorry.

Don’t feel bad my friend. The light is excellent, the switch is good. We all have bad experiences. Chalk it off to experience in buying lights.

It happens to all of us.

No worries, just keep reading this forum and buy more lights. Share your experience. Keep the hobby going.

Todd dropped it off and he certainly wasn’t exaggerating, it’s laugh out loud bad.
Have to make it through the first click or sometimes two to get to the real click.
Tailcap is on pretty good, may try to warm it up (very slowly, and not extreme) and see if some straps will loosen for examination.

I’ve smacked it into my hand pretty good and gotten rid of the multiple click syndrome and it seems like there’s something in the button area keeping one part of the button from pushing down, at all.
Now that there is only one click per click, (honestly it was as if there were 2 or 3 buttons in there sitting at different heights) it’s usable.
I can see the appeal, it’s a cool little light. Li-ion only with that battery size would keep me from paying money for one but this freebee will get some use.
That’s just my opinion, I know if you bought this light you don’t share it. That’s ok.
This is, without doubt, a mistake in assembly or manufacturing and cannot represent the average. Hoping all will be clear when/if I get the tail off. Not gonna rush because it’s a pretty little light.

To my fellow enthusiasts who’ve been in it for over a decade: can you imagine if someone released this light back in 2008? At this price?
We had some nice programmable UI in HDS, Liteflux, Tank007 and others but had to hunt high and low for decent emitters and wait for a boat from Australia to deliver them.
I was rooting through my flashlight tackle box when Todd came over and we both agreed it’s mostly useless. The off-the-shelf lights of today are fairly amazing. Emitter swaps are for old lights at this point.

If I manage to open tail section I’ll post a pic of the offending item that’s messing with the switch.

(edited to clarify this was the light from OP)

Sounds like the ones with trouble didn’t reach out to Wurkkos, where they would of been taken care of, but they decided to talk trash. Is this the new norm for this forum?

I mean, I’m fairly certain that’s always been the case on the internet. It’s really not a new thing. There’s even people who immediately start talking shit about the whole company, and start bringing in things like politics into the mix, just because their new gadget had a chip on it or whatever.

That being said, I’m fairly confident if OP had reached out to Wurkkos (it doesn’t seem like they did), they would have done something about it.

I once had a button problem on my TS25. I had to click really hard for it work. I sent them video of the problem. Then, I was offered a gift on my next order. After getting that offer, I filed a dispute. I got a refund in the end. For me, an inconsistent button is 100% failure and unusable, but Wurkkos seems to think that it is a minor issue.

It’s a flashlight.

As they say;
“Forget it, Jake, it’s Chinatown,”

I took no offense to the OP, he was frustrated and wanted to kill the thing, we have all been there.
It didn’t harm Wurkkos any either. If people didn’t complain nothing would ever get improved.

Life’s too short kids :slight_smile:


Does this one thread represent the entire forum? Doubtful.
I’m hoping Keith’s comment above represents the “new norm” (or “noon norm” if you like SNL skits)

Greetings Bansuri! Been a while. I’ve got a silver and brass ts10. Great little things. My buttons work.

Greetings, Great Gunga of the North! My initial thoughts are hoping you and the family are staying warm up there but then I realize you’re probably so used to it that it’s just another day in Canada. :slight_smile:
Either way, hope all is well for your family.

Seems like yesterday we were trying to keep all the tailswitches on LF2XT and the rest working consistently, didn’t imagine we’d ever see the day where we’d be able to get a decent E-switch tailcap in a mass-production light. I think we’re there! Some others are too sensitive, this TS10 has hit the sweet spot for resistance IMHO.

This particular light just fell through the QC cracks, it happens. Once I get the tail off it should be obvious.
As I mentioned, it’s a beautiful little light so I’m taking my time in my effort to open it.
The Wurkkos button-top battery is nearly 51mm, the problem disappears when using a flat-top that measures ~49mm so THAT might be my solution. Lazy? Yes, but effective.

The Wurkkos button top in two of my TS10 are 50.1mm, another one is 49.9mm, and the 4th one is 50.0mm. The lights have no switching issues, all four lights work great!

I suspect the problem with the toddcshoe light is that the contact ring in the head for the pill and body tubes, were not making good contact with the inner and outer body tube ends.

iow, its not the switch at the tail that is the issue, its just poor contact in the head, because there are Two tubes that need to make contact.

Suggest remove battery and do a few tighten loosen cycles to seat the contact rings in the head to the inner and outer body tubes…

The switch itself is a very simple affair…
It does not sound like the Tail Switch is actually the source of the problem, since you report that a 49mm battery works fine.

Congrats on discovering the issue was related to battery length… There have been other reports of non-Wurkkos protected 53mm batteries not working, but this is the first report of a Wurkkos button top battery not working… Also first report of a Wurkkos button top being 51mm

I have had about Eight TS10 (reflashed and resold several), none of them have had any switching issues. In fact I really like the tailswitch on the TS10

bottom line, yes, too long a battery can prevent the tailswitch signal from reaching the contact ring on the pill… the solution is to use a 50.1mm or shorter battery.

Fortunately the TS10 works with both flat top or button top, for example they work w the Flat Top Vapcel L10, I have one that measures 48.7mm (they also work w the H10 but I do not recommend the 10A drain rate).

Since we’re looking closely, mine measure 50.78mm so not yet 51mm.
There’s no electrical switching issue, been dealing with rear e-switch issues for many years, this is purely mechanical.
The physical presence of the longer cell is maybe pushing something out of place. Switch works fine after you’ve pushed past false clicks. (only present with longer cell inserted) Each click will sound and feel like 2 clicks.

The PCB with the spring in the tailcap is off center when looking at it, one side of the trace around the edge is more exposed. I suspect that PCB just is mounted incorrectly.
As soon as I can loosen this godforsaken tailcap all will be clear!

There are 2 tabs coming off the triangular switch plate that the button presses on. These pass through the PCB and are bent over slightly but are not soldered.
Pretty tight in there, may just bend over for better connection. One of the tabs is almost vertical so the little switch clicker might’ve been popping out?

I believe it was the tab sticking up getting pressed by the back of the battery or the spring when compressed.
This spring gets compressed to nothing by the time the head is tight.
Total compression is a little over 11mm from when the head contacts the battery.
Bent the 2 tabs down as much as I could, pretty springy metal, wouldn’t go flat but definitely better than before.
Mine did not have a piece of tape across the switch as shown in jon’s post.
Works fine now with the 51mm battery. Case closed.

Glad you fixed it. Definitely a manufacturing error. It seems to be relatively rare, but this gives people something to check out if they have the problem,

BTW, how did you end up getting the tail cap loose?