“REVIEW”: Wuben E05 V1.0 – AA/14500 battery – XPL2 LED - 900 lumens [PIC HEAVY] [***MODDED WITH Luxeon V]***

55 posts / 0 new
Last post
1stein
1stein's picture
Offline
Last seen: 1 hour 34 min ago
Joined: 12/24/2017 - 16:25
Posts: 597
Location: Poland

Really appreciate your review, many thanks. Can you please tell what are the led pad and driver diameters? I assume these might be 16mm and 17mm, but rather to be sure.

RobertB
RobertB's picture
Offline
Last seen: 40 min 4 sec ago
Joined: 12/18/2015 - 17:49
Posts: 3335
Location: USA, Michigan

I put a 4000k 90+ cri Nichia 219c and a mild diffuser in my E05. Much better. The Mt Electronics 16mm mcpcb’s drop right in like they were made for it.

toddcshoe
toddcshoe's picture
Offline
Last seen: 16 hours 38 min ago
Joined: 01/24/2018 - 23:49
Posts: 1976
Location: Foley, MO
RobertB wrote:
I put a 4000k 90+ cri Nichia 219c and a mild diffuser in my E05. Much better. The Mt Electronics 16mm mcpcb’s drop right in like they were made for it.

I did the same thing but at 5000K. Found I wasn’t using it at all because of the tint. 15 minutes later it’s one of my favorite lights.

"Everywhere I go, there I am"

LightObsession
Offline
Last seen: 18 min 55 sec ago
Joined: 02/21/2018 - 00:15
Posts: 367
Location: Illinois, U.S.

I bought one on Amazon for 1/2 price using the coupon code listed in a post above.

We’ll see if I can tolerate not having direct access to low from off and not having a 5 or 10 lumen low for a 1AA size light. I’ve been used to the Utorch UT01.

I’m expecting to like the two-way pocket clip and magnetic tail.

This will be my first 14500 light. And I won’t have any extra betteries, but have several AA NiMh batteries and some Energizer lithium primaries.

What impresses me with this light is that the lower levels are the same on 14500 or AA and it actually has longer runtimes on 14500, rather than higher and shorter, as on most other duel fuel AA size lights that I’ve read about.

LightObsession
Offline
Last seen: 18 min 55 sec ago
Joined: 02/21/2018 - 00:15
Posts: 367
Location: Illinois, U.S.
RobertB wrote:
I put a 4000k 90+ cri Nichia 219c and a mild diffuser in my E05. Much better. The Mt Electronics 16mm mcpcb’s drop right in like they were made for it.

What’s the cost of these parts and how long did it take to receive them after ordered?

I’ve never nodded a light, but might consider it on this one, if cheap enough and easy enough.

Thanks.

MascaratumB
MascaratumB's picture
Offline
Last seen: 2 hours 21 min ago
Joined: 10/29/2016 - 12:12
Posts: 4111
Location: Portugal

LightObsession wrote:
Thanks for the review.

I also would prefer direct access to low, but may get one of these, anyway.

Thanks for your words!
Yup, direct access to low would make it (almost) perfect! That is the one thing that Manker E11 has advantage on this one. A UI similar to what Olight uses would be great on this E05 beauty! Still it is gorgeaus and an awesome flashlight Blushing

1stein wrote:
Really appreciate your review, many thanks. Can you please tell what are the led pad and driver diameters? I assume these might be 16mm and 17mm, but rather to be sure.

Thank you 1stein!
If I understand correctly you are asking about the emitter plate diameter, right?
I am not with the stock MCPCB/Led but I guess it is about 16mm diameter. The one I used with the Luxeon V is 16mm and fits perfectly and as RobertB mentioned above, the ones with 16mm will fit Wink

About the thickness, as I mentioned here , the MCPCB from Led4Power is thicker than the original one.

-
-
-
-

I also wanted to inform about the mod I made.
Using the Luxeon V with the SMO reflector actually produces some shifts or at least some artifacts!
At first I was excited because I didn’t have the greenish tint, but now I notice that the overal configuration actually has some “things” that don’t produce a completely homogeneous beam.

It is hard to capture in a photo due to balance, but here is an attempt.

Note that the spill is homogeneous, but the hotspot has 2 or 3 different “rings”! I don’t know if with other LEDs there is this effect as well, but if so, I suspect the SMO reflector may be the cause for it.

Using a diffuser sheet will even the beam and will produce a great beam. I guess that is what RobertB talked about too. Would be nice to find a Orange Peel reflector small enough to fit the head, though Wink

[REVIEWS] AMUTORCH: S3 / S3 vs 219c / AM30 / AX1 / VG10 /// SOFIRN: SF14 + SP10A / SP32A / SP10B /// NITEFOX: UT20 / ES10K / K3 /// ODEPRO: KL52 / B108 /// ACEBEAM: H20 / TK16 /// BLITZWOLF: BW-ET1 /// DQG: AA Slim Ti /// HC-LIGHTS: SS AAA /// XTAR: PB2 Charger /// OLIGHT: M2R Warrior /// WUBEN: TO10R / E05 / T70 / E10 /// ON THE ROAD: M1 / i3 / M3 Pro /// ROVYVON: A2 + A5R / E300S / A8 /// KLARUS: XT1C /// LUMINTOP: Tool AA V2.0 + Tool 25 /// LIVARNOLUX: 314791 /// SKILHUNT: M150

Tricks: 1 / 2 / 3 / 4 / 5 / 6 / 7 / 8 /// TIR Lenses: 1 / 2 /// Others: Biscotti 3 + 1*7135 / Triple TIR w/ XP-G2 ///// My Collection ///// My Review's Blog (PT)

GIVEAWAY: 1

LightObsession
Offline
Last seen: 18 min 55 sec ago
Joined: 02/21/2018 - 00:15
Posts: 367
Location: Illinois, U.S.

I received mine today. I’ll likely return it because of the mode memory and no direct access to low, unless it was the last used mode. I much prefer the UI on my Utorch UT01.

In addition to not liking the lack of direct access to low, I’d also prefer that the 300 lumen level be available in the normal cycle, rather than having to select turbo and wait for it to drop down to 300.

Other observations. My efforts to lock out the light using the switch results in the strobe function, more often than lockout, but I’ll experiment with that some more. It’s possible that the light is actually in low mode some of those times, rather than off, since triple click when on goes to strobe and the low mode is low enough that one might think that the light is off, when it’s actually in low.

The switch is very stiff and requires being pressed below flush with the surface of the light, so perhaps accidental activation would be unlikely, even if the light is not locked out.

I do appreciate that the blinky modes are hidden, unless you mess up trying to put the light in lockout mode.

I’m charging the battery now and will mess with the light more later.

Edited to add that only about 25% of the time can I successfully lockout or unlock the light with the side switch. I just can’t seem to the the three fast clicks correct with the very stiff switch.

Muto
Online
Last seen: 8 min 31 sec ago
Joined: 09/04/2012 - 16:42
Posts: 2066
Location: Southeast, PA

Been EDC’ing this for a couple weeks and it has never turned on in the pocket so don’t think you should stress over the lockout timing.
And I do have other items in the pocket.
HTH

After the Apocalypse there will be only 2 things left alive, Cockroaches and Keith Richards
..
Rockin’ In Bedrock, Twitch, Twitch!
..
Big Sky Country

LightObsession
Offline
Last seen: 18 min 55 sec ago
Joined: 02/21/2018 - 00:15
Posts: 367
Location: Illinois, U.S.

I also noticed that it appears to be relatively low CRI compared to some other lights – reds and yellows appear washed out.

I still haven’t adapted to the very long press to turn the light off. I frequently change output levels unintentionally, instead of turning the light off. This is especially irritating when I was in low mode and have to cycle through all of the modes to get back to low before attempting to shut the light off again.

I really wish that it had direct access to low, then it wouldn’t matter as much if I mistakenly increased the output level when attempting to turn the light off.

teacher
teacher's picture
Offline
Last seen: 3 months 6 days ago
Joined: 02/23/2016 - 19:04
Posts: 9596
Location: NE & SW Alabama

I think the CRI thing depends on the individual. Red & yellows in no way appear washed out to me when using this light.

Long press to off does take some getting used to…. and I still have not got used to that completely.

With a small bit of practice I found triple click to lockout very easy to achieve almost every attempt.

For the price with the Vipon Coupon & what you get for that price, I think this light is a great deal. Thumbs Up

You never know how a horse will pull until you hook him up to a heavy load./"Bear" Bryant 

 .................................. "Slow is Smooth, Smooth is Fast" ...................................

       Texas Lumens Flashlights / M4D M4X Deals : sign up - save $$$$  

         Rudeness Level _ mΩ _ {width:70%} _ LightWiki _ LED Tint Chart  

      Xlamp size chart _ BatteryU _ Flashaholic? Need Professional Help???            TheOriginal _ TAB _ LightSearch _ BatterySearch _ 14500's _ DiCal 

 

                                             

Muto
Online
Last seen: 8 min 31 sec ago
Joined: 09/04/2012 - 16:42
Posts: 2066
Location: Southeast, PA
MascaratumB wrote:
DBSS wrote:
That swap looks nice! Wish I had the skills to do stuff like that.

Hey man, it surely is, as the beam is much nicer! About the skills, well, mine are few and scarce compared to so many people here!
I’ve just tried to practice the (un)soldering process in different lights and LEDs! For this mod, I used my “normal” soldering iron, flat tip tweezers (to focus the iron on the solder and protect the LED, and some solder fluid + wire + thermal paste! After taking the reflector and gasket out, all gets easier Wink

Trust yourself and practice in “less” good lights or components and you’ll get the hand calibrated Wink Thumbs Up

Are you saying you did not remove the emitter board and just un-soldered/soldered from the top?
Did you remove the white plastic disc and if so did it screw out or just pull out using the notches?
Edit: Re-reading your post it sounds like you changed the board and the LED as one piece, I am going to try to swap just the LED.
Going to try emitter swap tomorrow with the new Lumileds Luxeon V2 in 5000k or maybe 3000k.

Thanks!
Keith

After the Apocalypse there will be only 2 things left alive, Cockroaches and Keith Richards
..
Rockin’ In Bedrock, Twitch, Twitch!
..
Big Sky Country

LightObsession
Offline
Last seen: 18 min 55 sec ago
Joined: 02/21/2018 - 00:15
Posts: 367
Location: Illinois, U.S.

I decided to try it with the diffuser.

Now I find it really handy – even with my challenges with the UI and stiff switch button.

I wonder if the diffuser will stay on the light when it’s clipped to the top of my back pocket? I may try carrying it bezel down, so that the cap will go into the pocket, if it comes off of the light. The diffuser cap also fits on the tail, so it could be stored there, when the magnet isn’t needed.

MascaratumB
MascaratumB's picture
Offline
Last seen: 2 hours 21 min ago
Joined: 10/29/2016 - 12:12
Posts: 4111
Location: Portugal

Muto wrote:
Edit: Re-reading your post it sounds like you changed the board and the LED as one piece, I am going to try to swap just the LED.
Going to try emitter swap tomorrow with the new Lumileds Luxeon V2 in 5000k or maybe 3000k.

Thanks!
Keith

Yup, this second part is correct Wink
I took the lens / reflector / plastic gasket out, unsoldered the wires and changed the MCPCB with the Luxeon V in it! As the Luxeon has different dimensions (comparing yo the XPL2), I had to change it all. I kept the original MCPCB with the Led, though, for other mods I may want to do Wink

LightObsession wrote:
I still haven’t adapted to the very long press to turn the light off. I frequently change output levels unintentionally, instead of turning the light off. This is especially irritating when I was in low mode and have to cycle through all of the modes to get back to low before attempting to shut the light off again.

I really wish that it had direct access to low, then it wouldn’t matter as much if I mistakenly increased the output level when attempting to turn the light off.

I am with you on this as I mentioned before! It is a bit annoying to have to cycle through all the modes again to turn it OFF on ML mode Facepalm

[REVIEWS] AMUTORCH: S3 / S3 vs 219c / AM30 / AX1 / VG10 /// SOFIRN: SF14 + SP10A / SP32A / SP10B /// NITEFOX: UT20 / ES10K / K3 /// ODEPRO: KL52 / B108 /// ACEBEAM: H20 / TK16 /// BLITZWOLF: BW-ET1 /// DQG: AA Slim Ti /// HC-LIGHTS: SS AAA /// XTAR: PB2 Charger /// OLIGHT: M2R Warrior /// WUBEN: TO10R / E05 / T70 / E10 /// ON THE ROAD: M1 / i3 / M3 Pro /// ROVYVON: A2 + A5R / E300S / A8 /// KLARUS: XT1C /// LUMINTOP: Tool AA V2.0 + Tool 25 /// LIVARNOLUX: 314791 /// SKILHUNT: M150

Tricks: 1 / 2 / 3 / 4 / 5 / 6 / 7 / 8 /// TIR Lenses: 1 / 2 /// Others: Biscotti 3 + 1*7135 / Triple TIR w/ XP-G2 ///// My Collection ///// My Review's Blog (PT)

GIVEAWAY: 1

RobertB
RobertB's picture
Offline
Last seen: 40 min 4 sec ago
Joined: 12/18/2015 - 17:49
Posts: 3335
Location: USA, Michigan
LightObsession wrote:
RobertB wrote:
I put a 4000k 90+ cri Nichia 219c and a mild diffuser in my E05. Much better. The Mt Electronics 16mm mcpcb’s drop right in like they were made for it.

What’s the cost of these parts and how long did it take to receive them after ordered?

I’ve never nodded a light, but might consider it on this one, if cheap enough and easy enough.

Thanks.

Do a little research how to install and solder for best results

http://www.mtnelectronics.com/index.php?route=product/product&path=60_94...

nobody
Offline
Last seen: 1 hour 25 min ago
Joined: 01/12/2019 - 04:58
Posts: 255
Location: In the dark

Just received my E05 that I ordered in January. I noticed that the manual said it it is V2.0. It’s not clear to me what the difference is. Does anyone know? I like it very much. The tint could be better, the clip made for a little deeper carry and the UI could use a few tweaks, but those are really minor to me. The discounted price was pretty good too. Bottom line is its a great light with a lot going for it.

MascaratumB
MascaratumB's picture
Offline
Last seen: 2 hours 21 min ago
Joined: 10/29/2016 - 12:12
Posts: 4111
Location: Portugal
nobody wrote:
Just received my E05 that I ordered in January. I noticed that the manual said it it is V2.0. It’s not clear to me what the difference is. Does anyone know? I like it very much. The tint could be better, the clip made for a little deeper carry and the UI could use a few tweaks, but those are really minor to me. The discounted price was pretty good too. Bottom line is its a great light with a lot going for it.

Hum, didn’t know a V.2 was released!
Can you say anything about the UI, if it is the same or not?

You can try to check if the manual has major differences from the one I posted in the OP and that I post below again (click on images to see them bigger):

Thumbs Up

[REVIEWS] AMUTORCH: S3 / S3 vs 219c / AM30 / AX1 / VG10 /// SOFIRN: SF14 + SP10A / SP32A / SP10B /// NITEFOX: UT20 / ES10K / K3 /// ODEPRO: KL52 / B108 /// ACEBEAM: H20 / TK16 /// BLITZWOLF: BW-ET1 /// DQG: AA Slim Ti /// HC-LIGHTS: SS AAA /// XTAR: PB2 Charger /// OLIGHT: M2R Warrior /// WUBEN: TO10R / E05 / T70 / E10 /// ON THE ROAD: M1 / i3 / M3 Pro /// ROVYVON: A2 + A5R / E300S / A8 /// KLARUS: XT1C /// LUMINTOP: Tool AA V2.0 + Tool 25 /// LIVARNOLUX: 314791 /// SKILHUNT: M150

Tricks: 1 / 2 / 3 / 4 / 5 / 6 / 7 / 8 /// TIR Lenses: 1 / 2 /// Others: Biscotti 3 + 1*7135 / Triple TIR w/ XP-G2 ///// My Collection ///// My Review's Blog (PT)

GIVEAWAY: 1

RobertB
RobertB's picture
Offline
Last seen: 40 min 4 sec ago
Joined: 12/18/2015 - 17:49
Posts: 3335
Location: USA, Michigan

Wuben made one to TLF specs. No strobe, and a few tweeks to the UI. Wonder if thats what the V2 is.

nobody
Offline
Last seen: 1 hour 25 min ago
Joined: 01/12/2019 - 04:58
Posts: 255
Location: In the dark

The manual is at work so I will have to check that tomorrow. I don’t notice any difference in the UI. It does still have the strobe.

cpcpcp
Offline
Last seen: 7 months 3 weeks ago
Joined: 02/28/2019 - 22:00
Posts: 5

I ordered one from Amazon with vipon discount two weeks ago. I really liked the light until yesterday it stuck in Med and Low mode after flickered a bit on Turbo mode. The battery was at 3.9V when it happened. I charged the battery to full, and tried a fully charged NiMH battery, but nothing helps.

The UI still works as before, it just cannot switch to High or Turbo at all. I used the light for a total of at most 30 minutes and only used at most 500 mah from the 14500 battery before the problem occured. I only used it for a 15 minute walk on Turbo (3 min and drop to 300 lm), and the rest uses were all Turbo for a few seconds.

The seller on Amazon is sending me a replacement, but I wonder if I was just unlucky, or shall I try to avoid Turbo in the future?

Is there a way to fix the broken light or it is only good as a host for mod?

MascaratumB
MascaratumB's picture
Offline
Last seen: 2 hours 21 min ago
Joined: 10/29/2016 - 12:12
Posts: 4111
Location: Portugal

cpcpcp wrote:
I ordered one from Amazon with vipon discount two weeks ago. I really liked the light until yesterday it stuck in Med and Low mode after flickered a bit on Turbo mode. The battery was at 3.9V when it happened. I charged the battery to full, and tried a fully charged NiMH battery, but nothing helps.

The UI still works as before, it just cannot switch to High or Turbo at all. I used the light for a total of at most 30 minutes and only used at most 500 mah from the 14500 battery before the problem occured. I only used it for a 15 minute walk on Turbo (3 min and drop to 300 lm), and the rest uses were all Turbo for a few seconds.

The seller on Amazon is sending me a replacement, but I wonder if I was just unlucky, or shall I try to avoid Turbo in the future?

Is there a way to fix the broken light or it is only good as a host for mod?

You were probably unlucky with your light! So far I didn’t see any complaints about fails with this light! Did it fell to the ground or something?
Maybe it was a driver component failure, due to soldering or other thing!

It is nice that you’re getting a replacement. Maybe you can use the host to put another driver in and have 2 nice lights in a compact form Wink

[REVIEWS] AMUTORCH: S3 / S3 vs 219c / AM30 / AX1 / VG10 /// SOFIRN: SF14 + SP10A / SP32A / SP10B /// NITEFOX: UT20 / ES10K / K3 /// ODEPRO: KL52 / B108 /// ACEBEAM: H20 / TK16 /// BLITZWOLF: BW-ET1 /// DQG: AA Slim Ti /// HC-LIGHTS: SS AAA /// XTAR: PB2 Charger /// OLIGHT: M2R Warrior /// WUBEN: TO10R / E05 / T70 / E10 /// ON THE ROAD: M1 / i3 / M3 Pro /// ROVYVON: A2 + A5R / E300S / A8 /// KLARUS: XT1C /// LUMINTOP: Tool AA V2.0 + Tool 25 /// LIVARNOLUX: 314791 /// SKILHUNT: M150

Tricks: 1 / 2 / 3 / 4 / 5 / 6 / 7 / 8 /// TIR Lenses: 1 / 2 /// Others: Biscotti 3 + 1*7135 / Triple TIR w/ XP-G2 ///// My Collection ///// My Review's Blog (PT)

GIVEAWAY: 1

nobody
Offline
Last seen: 1 hour 25 min ago
Joined: 01/12/2019 - 04:58
Posts: 255
Location: In the dark

Hopefully it was just a one off. Mine has been working great in all modes. I use it every day out in the warehouse. I hope the replacement works fine. BTW, did your manual note that it was V2.0? I still need to post the pics of my V2 manual. I only find a couple very minor differences in the wording.

MascaratumB
MascaratumB's picture
Offline
Last seen: 2 hours 21 min ago
Joined: 10/29/2016 - 12:12
Posts: 4111
Location: Portugal

nobody wrote:
Hopefully it was just a one off. Mine has been working great in all modes. I use it every day out in the warehouse. I hope the replacement works fine. BTW, did your manual note that it was V2.0? I still need to post the pics of my V2 manual. I only find a couple very minor differences in the wording.

Hum, still, even if it was a V2.0 I don’t think that it would imply a malfunctioning , unless the batch has some issues. Maybe it was really one off!

When you have the photos, you can also put them here to compare the V1 and V2, please?

Also, there is the TLF version, sold here: https://www.selected-lights.de/led-lampen/selected-lights-wuben-e05-tasc...

It has 720 lumens, and Nichia Samsung (90 CRI) inside. Also the UI is different!!! Take look !

[REVIEWS] AMUTORCH: S3 / S3 vs 219c / AM30 / AX1 / VG10 /// SOFIRN: SF14 + SP10A / SP32A / SP10B /// NITEFOX: UT20 / ES10K / K3 /// ODEPRO: KL52 / B108 /// ACEBEAM: H20 / TK16 /// BLITZWOLF: BW-ET1 /// DQG: AA Slim Ti /// HC-LIGHTS: SS AAA /// XTAR: PB2 Charger /// OLIGHT: M2R Warrior /// WUBEN: TO10R / E05 / T70 / E10 /// ON THE ROAD: M1 / i3 / M3 Pro /// ROVYVON: A2 + A5R / E300S / A8 /// KLARUS: XT1C /// LUMINTOP: Tool AA V2.0 + Tool 25 /// LIVARNOLUX: 314791 /// SKILHUNT: M150

Tricks: 1 / 2 / 3 / 4 / 5 / 6 / 7 / 8 /// TIR Lenses: 1 / 2 /// Others: Biscotti 3 + 1*7135 / Triple TIR w/ XP-G2 ///// My Collection ///// My Review's Blog (PT)

GIVEAWAY: 1

cpcpcp
Offline
Last seen: 7 months 3 weeks ago
Joined: 02/28/2019 - 22:00
Posts: 5

MascaratumB wrote:
cpcpcp wrote:
I ordered one from Amazon with vipon discount two weeks ago. I really liked the light until yesterday it stuck in Med and Low mode after flickered a bit on Turbo mode. The battery was at 3.9V when it happened. I charged the battery to full, and tried a fully charged NiMH battery, but nothing helps.

The UI still works as before, it just cannot switch to High or Turbo at all. I used the light for a total of at most 30 minutes and only used at most 500 mah from the 14500 battery before the problem occured. I only used it for a 15 minute walk on Turbo (3 min and drop to 300 lm), and the rest uses were all Turbo for a few seconds.

The seller on Amazon is sending me a replacement, but I wonder if I was just unlucky, or shall I try to avoid Turbo in the future?

Is there a way to fix the broken light or it is only good as a host for mod?

You were probably unlucky with your light! So far I didn’t see any complaints about fails with this light! Did it fell to the ground or something?
Maybe it was a driver component failure, due to soldering or other thing!

It is nice that you’re getting a replacement. Maybe you can use the host to put another driver in and have 2 nice lights in a compact form Wink

I never dropped it. Hopefully it is just a one-off. If I figure out a way to open it, I will try to see if there is any soldering problem.

cpcpcp
Offline
Last seen: 7 months 3 weeks ago
Joined: 02/28/2019 - 22:00
Posts: 5
nobody wrote:
Hopefully it was just a one off. Mine has been working great in all modes. I use it every day out in the warehouse. I hope the replacement works fine. BTW, did your manual note that it was V2.0? I still need to post the pics of my V2 manual. I only find a couple very minor differences in the wording.

It came with V1.0 manual.

Pages