12-Mode Help

We need a new “light programming” section, as these complicated UIs are for the dogs. I cannot adjust the 12 modes of my new L21A with these instructions…

Specific Gear: 12 groups

  1. Click the switch to turn on/off the flashlight, half-press the switch to select the mode
  2. If the flashlight is turned on, quickly half-press the switch 20 times to enter the configuration mode. (On a visual interface (such as a mobile phone), as long as you click on an option, it means that the option is selected. The flashlight has no visual interface, it uses flashing to indicate an option, and “half-press the switch during flashing” means Select this option.)

● Option 1 (normal flashing once + buzzing flashing): half-press the switch to enter the sub-options and start to select the gear group. If the user does not operate, the configuration mode enters option 2.
Sub-option 1.1 (normal flashing once): Touch the switch to select gear group 1 (0.1, 1, 10, 35, 100%, flashing, beacon, battery detection)
Sub-option 1.2 (normal flashes twice): Touch the switch to select gear group 2 (0.1, 1, 10, 35, 100%)
Sub-option 1.3 (normal flashing 3 times): Touch the switch to select gear group 3 (100, 35, 10, 1, 0.1%)
Sub-option 1.4 (normal flashing 4 times): Touch the switch to select gear group 4 (1, 20, 100%, strobe, flash, beacon, battery detection, SOS)
Sub-option 1.5 (normal flashes 5 times): Touch the switch to select gear group 5 (1, 20, 100%)
Sub-option 1.6 (regulation flashes 6 times): Touch the switch to select gear group 6 (100, 20, 1%)
Sub-option 1.7 (normal flashing 7 times): touch the switch to select gear group 7 (0.1, 1, 10, 50, flashing, beacon, battery detection, SOS)
Sub-option 1.8 (normal flashes 8 times): Touch the switch to select gear group 8 (0.1, 1, 10, 50)
Sub-option 1.9 (Normal flashing 9 times): Touch the switch to select gear group 9 (50, 10, 1, 0.1)
Sub-option 1.10 (normal flashing 10 times): Touch the switch to select gear group 10 (1, 10, 35, 100)
Sub-option 1.11 (normal flashing 11 times): touch the switch to select gear group 11 (100, 20, flashing)
Sub-option 1.12 (normal flashing 12 times): touch the switch to select gear group 12 (100% single gear)

● Option 2 (normal flashing twice + buzzing flashing): half-press the switch to activate or deactivate the gear memory. If the user does not perform any operation, the flashlight will enter the last gear.

It just seems to start in option one. No amount of flashing adjusts anything.

Sorry, cant help. Wish Simon would get on board with Anduril and e-switch lights. Surprised to see new larger lights coming out with only the power tail switch. If it was Anduril:

  • probably 100's of us here could help
  • manuals are available in well written clear English
  • lots of threads and posts already detailing how to operate Anduril
  • Buck and boost drivers do work, or can be made to work with Anduril

I don’t have a new L21, but I have several S21A that I’ve managed to switch mode memory on and select the mode group successfully using the biscotti cheat sheet here .

I’ve never had to half-press 20 times to get to the “menu.” 10-ish has always worked for me.

That’s even worse. I have no idea what that diagram is saying. And I have no idea where to start with this light.

You did scroll down to this one, right?

Yes. Doesn’t work. It’s a reverse clicky and requires hard pushes to get it to cycle. It only changes modes and doesn’t ever stop working and go into some kind of programming mode.

Finally got it to stop turning on at all, but takes 35 fast clicks. Still, turning off or trying to half-press to select anything is useless and doesn’t nothing.

Oh, that sounds like you just have the 4-mode version, not the 12 mode group version. Your original message made it sound like you were able to get to the mode group chooser. Is that not the case?

If you ordered the 12group (not the 4-mode), sounds like maybe Simon sent you the wrong thing.

I can go from blinkies to no-blinkies. That’s it.

If you have blinkies, you don’t have the 4-mode version. Sorry, I’m out of ideas.

I don't find the UIs too hard to adjust as long as the driver isn't faulty. But if it's advancing modes, it's also registering half-presses, so it should theoretically also do everything else accessible through half-pressing. Maybe you can share a video showing what you're doing so we can tell you if the light is actually misbehaving or not?

I received an S2 + a while ago and I also had trouble selecting another mode. The procedure I adopted was to turn on the flashlight and press the “middle” switch 21 times and as soon as it started flashing quickly, I quickly turned it off and turned it on again … then it started flashing 1 time, 2 times and so on … when it arrived in number 10 I turned off the flashlight and from there it followed the programming of number 10 …, that is, Suboption 1.10 (flashing normally 10 times): Touch the switch to select the gear group 10 (1, 10 , 35, 100). But if you unscrew or change the battery it will return to factory mode number 1 automatically.

This did it! Thank you! I have it in mode 8 right now!

Just remember not to loosen or remove the back cover! 8) 8) :sunglasses:

Many complain about UI or whatsoever be it Anduril, Narsil, or Biscotti… Once you got it, it’s just at your finger tip…

That doesn't really make sense btw, as the S2+ and other flashlights with a similar tail switch disconnect the battery from the microcontroller when off (that's how it switches modes, basically the same as turning it off and on again). So removing the battery really shouldn't be any different from leaving it off for a few seconds.

I understand what I meant, but unless my S2 + came with a factory problem, I already did and redid this procedure and every time I perform the physical lock of the flashlight (loosen the rear cover) when I tighten the rear cover again to turn it on, the programming always goes back to mode 1. Maybe if another member of the forum could do the same procedure there we can know if it’s normal to the UI or if it’s just my flashlight that has a problem ….

I just actually tried it with mine and it did the same. I observed that it didn't lock out cleanly though, as the threads still made some contact sometimes even when the tail cap was unscrewed two full turns.

So I believe what's happening is this: While turning the tail cap the microcontroller sees the intermittent contact as a bunch of fast half-presses and basically goes through the whole settings in a split-second. Can you try unscrewing the tail cap with the tail switch turned off? That should prevent the microcontroller from being powered on in the first place while the tail cap turned or not fully tightened.

Yes, every time I do the procedure the switch is already off … never test with the switch on … but I will also test and see if something changes.

I’ve been reading this thinking y’all have broken lights. I’m pretty sure I never lose the mode group, or mode memory setting on my S21A (12 mode) when I take the battery out to charge it. I just tried it again, and it didn’t even lose the current remembered mode.