IF22A strange charging LED behavior, exchanged torch is normal

I recently got me a IF22A.
When I charge the torch the red LED is blinking strangely.
One normal bling and then one or two short ones.

It is the same as in this video at 1:50:

I then complained to Sofirn about this and received an additional torch.
This one charges normally, red long blinks when charging, green solid LED when finished.
No short blinks.

Does anybody know what that means?
Can someone imagine which error that would be?
Has this been on other Sofirn torches as well, is there danger in continuing using the wonky torch?
It is the only difference I found compared to the newly exchanged torch.

Have the same issue here, also with a sc21 that died pretty quick. Was trying to open it up and have a look, but it was glued tight!
Will have to put some hours into that before i can tell what has happened. My IF22A is still woring as it shold and it turns green when fully charged and turned on.

How did your SC21 die? Was it during charging or during normal use?
If during charging, I could use the faulty IF22A but not use the charge port.

No, it just would not give light one time after a physical lockout. So:

Charge, test light, light it up some more. Turn off. Twist until it doesn’t turn on, twist for usage and, nothing. Quite strange. Tried to polish all surfaces with electrical contact, just dead.

And because I have 2 of them I can tell it’s not a battery issue or bad contact at the minus side.

Sofirn sent me a new when I told them what happened but it hasn’t arrived yet, speedy service though! So,I figured I would tinker with the dead light while waiting… :smiley:

My if22a is with me right now, chugging along!

The two Sofirn IF22A lights I purchased from AmazonUS work correctly, but forum member "tactical_grizzly" had a similar experience as you did with the IF22A switch LED while charging according to the quote below from his review:

Exactly, I don’t think it has any correlecense. Just bad soldering and bad luck if it dies I guess…

So OP, which is normal?

You mentioned yours : “One normal bling and then one or two short ones.”

You also mentioned : “It is the same as in this video at 1:50”

What is happening to yours “One normal bling and then one or two short ones.” is NOT the same as in the video @1:50. The video shows a constant red blinking.

So now your replacement light is with red long blink that is different from the video?

Video does not show constant red blinking but the behavior I described.

Matt Gill (Flashaholic) explained that to a comment on his video that it would only occur on a battery that was already charged or nearly charged. Worked perfectly otherwise

Sorry, my bad, I was watching the video with my phone and at my age, my eyes didn’t get the slight red blink.
After reading Funtastic comment, I use my desktop and watch the video again and saw that. Now I get what you mean. :beer:

Thanks for the info…

I tried the same with a half charged battery and got the same behavior :frowning:

If this model is also equipped with the same charging board as the Wurkkos TS21 and FC12 then it’s not a fault, just a bug that affects some of them. Apparently Sofirn didn’t receive the boards that they intended to use

I do not have either of these Wurkkos, as I do not like Wurkkos.
Do you have a picture of the charging board?

I experienced the exact same charging indicator issue with my IF22A that Sofirn sent me for review . In my testing, the charging worked perfectly fine, it’s just the indicator that doesn’t work correctly.

I have exactly the same Problem with my IF22A as in the Quote. It never turns green while loading. It worked a few times in the beginning after i bought it but since a couple months not anymore.
I bought it in September when it was pretty new so i can’t return it.
I just hope the overcharge protection still works.

Contact Sofirn at sofirnlight.com since they’ll help out under their 12 month warranty, but you’ll need to provide a video which could be hard to show

I bought it from Aliexpress do they still help then ?
Yeah i think on a video it will be hard to prove it. I loaded the light 7 hours and never turned green.

Okay, you need to sort it through AliExpress since Sofirn have different teams for each platform with various prices. Just email the Sofirn store on AliExpress and if they won’t provide much help then go to sofirnlight or post on their facebook page

While the charger is connected, does the light's switch continually "blink red" forever or does the "blinking red" eventually stop when "charging has completed"?

If you have a "Volt Meter" you could measure the battery's voltage after "charging has completed" to ensure the voltage is at or below 4.2 Volts DC.

If you have a "USB Meter" your video could show both the "USB Meter" and the "light's switch" during charging and send the portion of the video where the USB Meter's current goes from a positive value to a value of zero (indicating that charging has completed) to show Sofirn what happens with the "light's switch" during the moments before and after charging has completed.

7 hours seems too long. As I remember it takes less than 6 hours using a USB-A charging port and less than 3 hours using a USB-C charging port to charge an almost fully discharged 21700 battery in my IF22A.

This is probably not your problem, but it did happen to me and one thing to be aware of and check before charging is to be sure that the light is able to turned on (when the light is not connected to the charger), because if the light is not able to be turned on, it will also not be able to be charged.

I "physically lock out" the IF22A by loosening the tail cap or the head or both to ensure the light does not turn on accidentally while in my jacket pocket. Once I forgot to tighten these before using the built-in charging port and the light's switch just continually blinked red (which should indicate it is charging), but it never charged or finished charging, even though the light would turn on while connected to the charger.


The above behavior ("blinking red", but no charging when "physically locked out") only occurs when using a USB-A charging port. There is no "blinking red" or charging when using a USB-C charging port while "physically locked out".

Some additional information:

The head of my IF22A (without the battery tube or battery) can light up the main LED when attached to a USB-A charging port using a USB-A to USB-C cable, but the head alone will not light up the main LED when attached to a USB-C charging port using a USB-C to USB-C cable without the battery tube and battery installed (but after it lights up I then can remove the battery tube and battery and will be able to turn the main LED on and off).