Wallbuys Tracking

Does anyone know how to track packages sent by Wallbuys? I pressume it’s hongkong post, but I could be wrong.

Any info guy’s?


As far as i know log onto wallbuys and go to account, orders…

Yeah, I meant once they have given me a tracking number, sorry.


The tracking website should b there also

Where would that info be?


That is easy go to my acount click your order and a window appears
look after such thing [Tracking # Added: RC146236530HK ] or so…the number wit RC…HK is your order number copy it

and than you can use this link for tracking just replace the number in the end with yours…

That’s what I have been doing but it wont let me put the whole number in. Just RC*. Now when I put in what it lets me, it says there is no info for this number.


What let you not put the number in? Is the number not displayed at wallbuys or what do you mean?
And what says the wallbuys system when it has been shipped?

It will not let me put the whole RC*HK. It misses the last 2 numbers and letters.

Still not get what you mean with put in this context…?
Can you see the whole number?
than you can track it

Have you tried this site

there is your tracking number displayed too…

Yes I can see the whole number but HK post will not let me enter the whole number. Just the RC and the next 7 numbers. It will not let me enter the last two numbers and letters which are HK.


I think your on the wrong page refresh page try again…I mean new search

Just followed Werners link. I’ll try again. Hold on.


OK I went to mail tracking and put the number in, but now it say’s:

To promptly retrieve the record of your item, please key in your Enquiry Reference Number (if available), for example, 05000123A:

Where would I find that?


N ot on the system yet!

Ok, Thanks jakey. How long does it normally take?


It depens mine usually 24-48hrs…

Hmm. mine has been nearly 4 days :frowning: Looks like I’m in for a little wait.

Thanks for you help to Werner.


do what i have written, copy your tracking number in the url window on your browser and then hit enter…if that don’t work try to hit your computer with a shoe that often helps…. :wink:

SIZE ten or bigger.lol